[Webinar] Streamline your web hosting managementRegister Today

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1233
  • Last Modified:

windows cannot access the specified device, path, or file.

I am running Roaming Profiles on a Windows 2003 Server. After the phase in I am seeing weird to say the least access errors:


Windows cannot access the specified device, path, or file. You may not have the appropriate permissions to access the item

Is there a way to fix this. It only happens for some users and on some programs. For example:

The user logs in and tries to run a program and gets that error.

I log in and run the same program with out any problem.

Yet another user logs in and run the same program with out a problem.

I move to anohter computer and log in as first user and run program and it will work just fine.

I am at a loss here.
0
segrave
Asked:
segrave
1 Solution
 
sysadmin81Commented:
Check that the roaming profile has at least the user and system as full control on the roaming profile folder.  Also, check that the administrator and not the user is the owner of the folder.
0
 
iCoreKCCommented:
I have seen strangeness like this due to a bad OS image on the workstation.

We re-imaged the workstation and all was well.

I would say it is not an AD / User issue of you can use the same user credentials on a different machine.

I have also seen these gremlins due to a bad Cat 5 cable and or port switch.  
0
 
segraveAuthor Commented:
Ok here is the deal. The reimaging worked for a small amount of time. After updating the program it did the same thing again where it would show the rror.

I logged back into administrator and got a popup box telling me that the Publisher was unknown.

I unchecked the check box and hit ok. Logged back into the user and it finally worked like it should.

I need to know how to get that box to show back up on all users or bypass the publisher unkown error in order to allow all users to use the program.
0
Get your problem seen by more experts

Be seen. Boost your question’s priority for more expert views and faster solutions

 
ChiefITCommented:
I am working on a similar post that may answer some of your questions.

http://www.experts-exchange.com/OS/Microsoft_Operating_Systems/Windows/XP/Q_23112598.html

Within this article: (Identifying and resolving similar AD SIDs)
http://www.wsus.info/forums/index.php?showtopic=9312&pid=34802&mode=threaded&start=

""Want to figure out which computers have duplicate SIDS?
Use psGetSID from Sysinternals: http://www.microsoft.com/technet/sysintern...s/psgetsid.mspx - You can run this against all computers in your domain to discover who has a duplicate SID.

You should really then run NewSID from Sysinterals on any of the duplicate computers to resolve any potential issues in the future (not to mention the security issues involved with having duplicate SIDS on the network): http://www.microsoft.com/technet/sysintern...ies/newsid.mspx  ""

Note: if you have problems with clients not showing up or periodically disappearing in WSUS, you should also refer back to this article.
0
 
ChiefITCommented:
OH, and please credit iCoreKC for identifying imaged machines as a problem, if this fix works for you.
0
 
segraveAuthor Commented:
That reinstall worked for a short time. As for the SID my image is setup to run the sysprep after reboot. Basically it will run through the setup when I boot after image.

The problem with the program has to do with the Unknown publisher. Is there a way to allow programs with unknown publisher? or allow programs I designate?

Also when I reinstalled the image I was able to run the program, then after update it crapped out on me again.
0
 
segraveAuthor Commented:
A friend had an idea to make the ExE run as administrator. Not sure if this is in the right direction or not but am going to give it a try. Any input on this is great and appreciated.
0
 
ChiefITCommented:
Segrave:

I do have alternative solution that I see on about 1/8th of the posts on EE 2003 server zone. It has to do with Network Load Balancing, (or load sharing), over a switched network. About 1/8th of the discrepancies I see on this 2003 server zone result from the improper configuration of dual NICs on a switched network. Let me explain:

You are showing symptoms of a network that is experiencing intermittant communications. This is a result of a flooded NIC shutting itself down. Flooded NICs come from a loop of packets that build upon themselves and overcome a NIC card. The error, "Windows cannot access the specified device, path, or file",   tells me the DNS query can not be made to your server by itself. Whenever you see this error, it almost always means the computer can't translate the Netbios address to an IP address. So, that IP address may have been shut down or in a paused state.

A flooded NIC can be tricky to troubleshoot. The server will look like it is happy because you will not see many errors in Event viewer or DCdiag reports that will tell you services have been momentarily shut down as a result of a flooded NIC. NICS will pause services. The services that are paused depends on the service that floods the NIC. It can be exchange, DNS, DHCP, WSUS, IIS or any number of a list of components on the machine. When these services are paused, you get intermittant comms.

Since I see about 20 EE posts on the 2003 server zone daily that I think are flooded NICs, I have been working on a all-in-one fix to flooded NICS. You are seeing this in the developing stages of a all-in-one fix.

Here is what I see as the problem:
1) The difference between a switch and a Network Hub is the switch will create a defined path to a NIC card. The hub broadcasts the packets across the LAN. Since there is a defined path, your server may not recognize itself as having the authority to open its own files using a DNS query. On a load sharing switched network, you have two NICS and two defined paths to open files on that server. That can really confuse the authentication process if not configured right.
2) Also, since there are two defined paths, the packets may split and try to go across two paths. This further confuses the process. You may get packets that loop throughout the switched network.

To fix this, you need to imagine yourself as a packet. How would you go to the computer you wish to address to.

Here is what I advise:
1) If you don't need to load share, disable all NICS but one. Configuring two NICS can be a bit tricky. A computer with a single NIC will process requests for about 250 Nodes on a LAN. So, if you don't need it, disable it.

2) If you need to load share, configure both your server and network switches to provide a clean path that the server recognizes. (NOTE-Some networking gurus will disable the ability of a switch to provide a defined path to the server. That, in essence, changes your expensive switch to a network hub. The differences between a Network hub and a switch is the switch provides a defined path.)
3) It is sometimes best to call the switch manufacturer and ask them how to Network Load Balance (NLB) over this switched network. They can give you the configuration of your switches and tell you how to program them.
4) Get a networking guru on your side. EE has some really good networking techs. My networking skills are limited. Due to the errors I see daily, my skills are improving.

The settings you need to be aware of to configure your switched network for NLB.
-Spanning Tree configuration on the switch
-Port Fast configuration on the switch
-Server needs an update to allow NLB on a switched network.
-The differences between Unicast and Multicast modes

****Putting the load balancing into perspective: (overview)
An example, from one of our own, of a properly configured switched NLB network:
http://www.experts-exchange.com/OS/Microsoft_Operating_Systems/Server/2003_Server/Q_23037760.html

A little explaination of spanning tree and portfast.
http://itt.theintegrity.net/pmwiki.php?n=ITT.Spanning-TreeAndPortfast
(NOTE: Portfast is necessary for XP clients. XP clients will time out otherwise.)

Preventing NIC flooding caused by NLB:
http://technet2.microsoft.com/windowsserver/en/library/bf3a1c95-f960-4ed3-b154-3586631fb0061033.mspx?mfr=true

****Configuring your server:
NLB over a swtiched network, Microsoft Update Fix:
http://support.microsoft.com/kb/261957

Technet article on Network load balancing on a switched network:
http://technet.microsoft.com/en-us/library/bb742455.aspx

The differences between Unicast and Multicast modes:
http://support.microsoft.com/kb/291786
(The server requires Multicast mode to work with dual NICS)

*****Configuring your switch:
This will be switch specific- call your switch manufacturer

****Noticable errors associated with NLB over a switched network and/or flooded NICS:

Event ID 5719, spanning tree portfast:
http://support.microsoft.com/kb/247922

Event ID 1030 and 1058 WSUS:
(NOT yet well documented)

***Other problems that can cause a NIC to flood:
Network connectivity between clients and servers may fail. This failure occurs after the installation of either security update MS05-019 or Microsoft Windows Server 2003 Service Pack 1 (SP1).
http://support.microsoft.com/default.aspx?scid=kb;en-us;898060

Sorry for the long post!

Any networking gurus out there to guide him through this??


0
 
segraveAuthor Commented:
I have checked into that and we are only using one nic per server. All machines work for all other programs across the share except for these two custom programs that have no Publisher. I trust these programs in the terms of I know who  makes them and they are only used for internal use.

Basically it works up to a point where it gets updated.

A small explanation of how this program works it mainly that it works off of a bunch of exes. When it is updated all it does is replace exes. That is when the problem arrives.

After update I get a box asking me if I should run it with a check box to ask me every time I load this program.

Now if I uncheck the box as a user sometimes it will continue to work sometime it will not. As administrator of the domain it will work for me regardless on every machine. For some users it will work and for some it will not.

Now I have all users ina profile named Roaming and all users are Domain Users. The program has both groups on the folder for the program as read and write permissions on all servers that the program is installed.

I hope this helps to find an answer. All the answers above are very good and will help me with some other problems I will soon encounter I am sure as we are growing faster than I can keep up.

0
 
segraveAuthor Commented:
I have gotten closer. It has something to do with the short cuts in relation to the program.

I have teh program loaded on all computers and the server.

When a user has a personal shortcut that transfers back and forth it will give teh windows access error.

If the shortcut is in All Users it doesn't seem to have a problem.

I am only seeing this problem with two programs which seem to be the only two custom programs that we have.

0
 
segraveAuthor Commented:
Problem solved. Not sure how or why, but here is the answer. I will give the points to who ever can answer this so that when it updates I can get past it next time.

TO make the program work I have to do the following.

1) Log in as administrator
2) Run program
3) Unchecked the security box for unknown publisher, that states ask me every time I run this program.
4) Log back in as user.

Works fine from that point.

I know the next time it updates I will run into this again as the program replaces exes everytime it updates.
0
 
segraveAuthor Commented:
Well Problem totally resolved and case closed. It was the internet explorer setting for the local machine zone. After setting this to low I was able to get past this. Thank you guys for all your help. I cannot see giving the points to any one person as no one was able to give me this answer but I will have more questions this week that will give out a good amount of points.
0

Featured Post

Keep up with what's happening at Experts Exchange!

Sign up to receive Decoded, a new monthly digest with product updates, feature release info, continuing education opportunities, and more.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now