We help IT Professionals succeed at work.

SMTP 553 Error

I am receiving a bounce back from yahoo addresses when users try to email someone@yahoo.com

I am using Exchange Server on WIndows SBS 2003.

Your message did not reach some or all of the intended recipients.

      Subject:      Testin email
      Sent:      1/23/2008 11:58 AM

The following recipient(s) could not be reached:

      finelines1234@yahoo.com on 1/25/2008 9:52 AM
            There was a SMTP communication problem with the recipient's email server.  Please contact your system administrator.
            <midsouthsteel.net #5.5.0 smtp;553 Mail from tandreasen@midsouthsteel.net not allowed - [10]>
Comment
Watch Question

CERTIFIED EXPERT
Top Expert 2008

Commented:
Your DNS is a mess.

You have your MX records set incorrectly with a zero weight (change it from 0 to 10), there is no host that corresponds with the MX records (you need to create a host called mail.yourdomain.com and point it to your external IP address, and your SMTP greeting is malformed (but isn't going to work even if you fix it) it should be mail.yourdomain.com -> http://www.block.net.au/help/smtp-greeting

The quickes solution here is to route all your mail via your smarthost - as you are clearly using the POP3 connector to receive mail, then you don't have much of a choice -> http://www.amset.info/exchange/smtp-connector.asp

Author

Commented:
Ok, I looked under the smtp settings of my exchange server and everything appears normal.

My Hosting information (godaddy.com) has my mmx records set up. Everything looks good there as well.

Any more ideas?
CERTIFIED EXPERT
Top Expert 2008

Commented:
>>Ok, I looked under the smtp settings of my exchange server and everything appears normal.

It is still wrong, change your SMTP greeting with the link I gave above to mail.yourdomain.com instead of just yourdomain.com

Now that your A record exists (it didn't before - could be slow DNS propogation), I can test further.  Your DNS records are now all good.

Your reverse DNS is now incorrect, it is pointing to mail.craft-art.com which then points to a different IP;

1.  Talk to your ISP and tell them you want a reverse DNS entry on your IP pointing at mail.yourdomain.net
2.  Fix your SMTP greeting

Then, you should be done
Ok, everything is done, but I am still not able to send to yahoo accounts.
I have contacted my ISP and they changed it to point to mail.midsouthsteel.net.
I have changed my smtp greeting to mail.midsouthsteel.net.

Thank you for all of your help.

Explore More ContentExplore courses, solutions, and other research materials related to this topic.