[Webinar] Streamline your web hosting managementRegister Today

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 2133
  • Last Modified:

Outlook Clients Being Prompted to Accept Security Certificate

Hello, I'm a newb to EE, so be gentle.
Recently installed an Exchange 2007 box into my environment. Transitioned all mailboxes from the SBS2003 Exchange server to the new Exchange 2007 box. Removed the Exchange 2003 server (but not the core SBS box) from the SBS server. Installed an SSL cert from GoDaddy in Exchange 2007.
Now, when Outlook clients connect, they are prompted with a security alert because "The name on the security certificate is inavlid or does not match the name of the site." The alert reports the domain name as "machine.internaldomain.local". Naturally this will fail as the cert is registered for 'office.externaldomain.com'.

I have tried changing the account settings (Control Panel>Mail) to connect to the server using the 'office.externaldomain.com' address, but when I reopen OL2007, the problem persists and I see that the account settings for server have been reset to 'machine.internaldomain.local'.

Am I missing something? The error is nuisance only, but a nuisance is a nuisance and a problem for end users. Thanks!
0
xyden
Asked:
xyden
1 Solution
 
xydenAuthor Commented:
Thanks! That did the trick!
0
 
demyntedCommented:
This fix worked for me as well...

Thanks!

Gary
0

Featured Post

SMB Security Just Got a Layer Stronger

WatchGuard acquires Percipient Networks to extend protection to the DNS layer, further increasing the value of Total Security Suite.  Learn more about what this means for you and how you can improve your security with WatchGuard today!

Tackle projects and never again get stuck behind a technical roadblock.
Join Now