Exchagne Server 2007 crashed during sp1

Brand new server, freshly installed Windows Server 2003 x64.  installed Exchange Server 2007, completed setup, function perfectly.  Then...I tried to run Exchange Server 2007 SP1.  2/3 way through the install it came up with some error about missing files and then ended the install.  
I rebooted the server and nothing in exchange worked.  Many missing files.  Command prompt, setup /mode:Recover Server /DoNotStartTransport (from sp1 source).  Got almost done and popped out Exchange Server Setup Encountered an Error.  Tried again same thing.  Tried to uninstall - will not do.  The services all start now but it is not working right/completely.
Only error in Event viewer is a vague error about communication with the hub transport and only on startup.
Any suggestions.
Fortunately this was not in production yet.  Though I had move 1 mailbox to it for testing plus synced basic public folders, free busy time to it form old Exchange Server 2003.
tfountainAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

ikm7176Sr. IT ManagerCommented:

can you be more detailed in explaining the errors encountered during setup. can you post the installation progress.
0
BusbarSolutions ArchitectCommented:
I think that the SP1 installation source is corrupted, try to download it and install the new downloaded file
0
tfountainAuthor Commented:
OK, last night I was able to get the uninstall to start but only remove components that successfully recovered from the command line setup.com /mode:RecoverServer.
The two remaining componets: MailboxRole and HubTranoposrt will not uninstall.  MailboxRole errors out that it cannot find the exchagne server, and HubTransport with "Setup previously failed while performing the action "DisasterRecovery".  You cannot resume setup by performing the action "Uninstall".
The error in the event viewer was related to certificate error on the HubTransport.  I fixed that but still cannot uninstall or fix exchange.
0
The Ultimate Tool Kit for Technolgy Solution Provi

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy for valuable how-to assets including sample agreements, checklists, flowcharts, and more!

BusbarSolutions ArchitectCommented:
why don't you run the setup in install mode and install thoe 2 components
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
tfountainAuthor Commented:
busbar:
I could not run setup in install mode, got similar error to when I tried to run uninstall.

ikm7176:
Yes, that would have been the answer.....
I say would have been, as yesterday afternoon I could wait no longer.  I went on site, formatted the server, used ADSI edit to remove any remnants of the old server and rebuilt.  I found a very similar article to the one you list above and I am sure that would have worked.  Oh well, fortunately it was not a production server, yet, today it will be.

Cause of the original issue:
I talked with my partner who built the server the first time (up to the exchange install).  I did not realize he had in stalled AV on the server and did not think to check for and disable it before the install.  I believe this somehow may have been causing connection issues with AD and therefore caused SP1 to crash.  When I rebuilt the server I:
Installed the OS, did all the OS SP's and updates, installed Exchange 2007, added the connectors, and installed Exchange 2007 SP1.  It went flawlessly.

Thanks much to all for their help,
Thanks ikm7176 - points to you as this I believe was the answer I needed.  Hopefully this helps someone else in the future.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Exchange

From novice to tech pro — start learning today.