Problems accessing shared files and folders through a PPTP VPN

i have a pc at home, connected to a wireless router. i have set up a PPTP VPN connection to this pc, port forwarding etc set up on the router and this works absolutely fine.

now when i've made the connection to the VPN, i can't access any shared files, whether i do it through run and then \\desktop etc or if i map a drive.

now get this, when i'm connected to the VPN, i am unable to ping the pc's networked ip address, and again i am unable to ping my laptop from the pc.

I can however ping the client and server ip address's for the VPN connections.

i've checked the firewall logs, and i can't seem to see any errors in them.

I have attached a diagram that might shows what happens.

Can anyone offer any solutions?

the home pc is using XP Pro SP2, the laptop is using XP Home SP2, however i've tried doing it from another laptop using Pro SP2 and this makes no difference. The router is a Buffalo WHR HP G54 using tomato 1.14 firmware.

Thanks in advance
vpn-problem.JPG
LVL 1
fatcontroller82Asked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

ryansotoCommented:
Your home pc and vpn clients are on the same network 192.168.1.X

Change your home machine to 192.168.10 or something like that and retest
You will also need to configure the vpn to allow traffic from the client to the home network.
0
fatcontroller82Author Commented:
that doesn't make a difference. I connect to a VPN in my work place when i'm at home, and the IP Address's are all in the same range/network and the file sharing works fine.

essentially the connection i'm making from work to home is the same as i'm making from home to work, only one works and the other doesn't.
0
Erik BjersPrincipal Systems AdministratorCommented:
When you have a VPN setup this way the remote client and the internal network CAN NOT HAVE THE SAME SUBNET as ryansoto stated.  Change either the IP address of your laptop or your home computer, but the laptop can not have the same IP address as the internal network or VPN traffic will not flow.  Once the laptop is connected to the VPN it can have (and should) have the same IP Subnet as your home PC, but before connecting it should not.

eb
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
The Ultimate Tool Kit for Technolgy Solution Provi

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy for valuable how-to assets including sample agreements, checklists, flowcharts, and more!

Erik BjersPrincipal Systems AdministratorCommented:
Sorry should have looked closer at your diagram... your IP settings appear to be correct and the problem may be Windows firewall or other firewall you have installed.

Please run the Ipconfig /all and tracert IP.OF.HOME.PC from the command prompt on your laptop when connected to the VPN and past the results here.

eb
0
fatcontroller82Author Commented:
i was thinking firewall too, but i only use windows firewall, and that works fine when i'm at home with my laptop using my local network and not my vpn......which would suggest everything's set up fine at the pc's firewall.....and probably the firewall on the router too.....i've done the tests you asked and here they are, let me know what you reckon......
tracert.JPG
ipconfig.JPG
0
fatcontroller82Author Commented:
the above test was done while at home on the same local network, but just vpnning in (it works the same way, which i'm sure you'll already know). the test below is using my laptop with a mobile phone's HSDPA connection, completely untouching my home network on my laptop, apart from through the VPN connection, and i get the EXACT same results, apart from the ip address's being different of course!
tracert-through-HSDPA-connection.JPG
0
Erik BjersPrincipal Systems AdministratorCommented:
In the first sets of posts it will not work because your laptop alredy had the same IP subnet 192.16.1.x as it would get once in the VPN and this will never work.

The second set of screen shots tells me that you do not have a default gateway setup when you are connected to the VPN and all traffic is attempting to go out the default gateway of your internet connection 10.34.236.70.  And since you are trying to go to a 192.168.1.x IP address it appears it is trying to go out the internet gateway and that will not work.

Also Windows firewall can be a pain in the a$$ so if you can disable it on both systems and see what happens, if that works then it is a firewall problem and should be easy to solve, otherwise keep reading.

What are you using as the VPN client?

We need to try to get a little more info on how packets are flowing.  Download packetyzer from http://www.paglo.com/opensource and in stall it.  Once this is installed you can use it to capture packets when you try to ping the other host or access a share.  This will give you info on what is happening.

eb
0
fatcontroller82Author Commented:
hi ebjers, thanks for the info. what should the default gateway be when connecting outside of my home network, as maybe i can assign this statically.

the vpn client is simply the built in dial up connections through windows. nothing fancy concentrators being used.

i'll download that program later and run it......in the meantime if you could let me know about the default gateway that would be spot on. should it be the ip address of the VPN SERVER IP on the home pc?

I'll try the firewall too later on but i don't think this will make a difference
0
Erik BjersPrincipal Systems AdministratorCommented:
I'll have to get back to you on the default gateway, I don't have an XP box handy and need to check a few settings.

eb
0
fatcontroller82Author Commented:
here's the proper ipconfig for the HSDPA connection
ipconfig-using-HSDPA-connection.JPG
0
fatcontroller82Author Commented:
turns out windows firewall doesn't like GRE (Protocol 47) packets. i disabled windows firewall and stuck to the one on the router and it works a treat.
0
Erik BjersPrincipal Systems AdministratorCommented:
I beleive I mentioned that windows firewall may be the cause of the problem in multipleposts
0
ryansotoCommented:
ebjers should receive the credit for this thread
0
fatcontroller82Author Commented:
hi ebjers, i gave you 100 points because you did suggest it may be a firewall problem but since i didn't want to leave my system unsecure, you also mentioned it could be a gateway issue.....you said you'd get back to me, and after 5 days you still hadn't and in that time i had been searching my firewall logs again and again, and finally noticed the GRE packet problem. don't think your deserve all the credits for telling me to something fairly easy as to disable the firewall, its the reasoning behind it that should have been given....ie blocking of protocol 47.........
0
Erik BjersPrincipal Systems AdministratorCommented:
I diden't get back to you because I was still working on the problem and had no more information for you.  If you beleive the answer helped but did not fully solve the problem then you assign a lower grade say a b or a c, but you still award the points.  From what I understand that is the way that things work on EE.  And yes firewall may have been an easy ansewer, but sometimes it is the easy answers that are the hardest to think of ourselfs that's what makes EE so great, you get new people looking at the problem for you and they come up with things you missed or over looked.

I'm glad you got everything working.

eb
0
fatcontroller82Author Commented:
hi ebjers, thanks for the reply and yeah i'm glad it's now fixed.....thanks for your help
0
Erik BjersPrincipal Systems AdministratorCommented:
NP, it's why I'm a member
0
Vee_ModCommented:
Force accepted.
Vee_Mod
Community Support Moderator
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
VPN

From novice to tech pro — start learning today.