[Webinar] Streamline your web hosting managementRegister Today

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 215
  • Last Modified:

Break Points when debugging remotely a ASP.net site Need clarification

I got remote debugging working. :-)

But I notice I have to set all breakpoints first then debug.

I tried having no break points. Debug then after IE comes up set a break point. Refresh.  Does not break.

I tried adding a break point after it breaks does not break on the new break  point.

If I clear a breakpoint that was added before I debug then it does not break (as expected) but if I add it back in.  doesn't break.

So I figure that I have to set all break points I want before I start debugging.

Is this true or am I missing something?

0
boricua1213
Asked:
boricua1213
1 Solution
 
Sachintana DissanayakeSenior Web DeveloperCommented:
I also had similar issues sometimes back, when I the following it got worked properly.
    - Exit from VS 2005.
    - Delete all files inside C:\WINDOWS\Microsoft.NET\Framework\v2.0.50727\Temporary ASP.NET Files
    - iisreset

You should build the whole web site as in the debug mode. (check datetime of all dll and pdb files)

But there are so many workarounds that different people have found out.
   http://forums.asp.net/t/1159642.aspx
   http://forums.microsoft.com/MSDN/ShowPost.aspx?PostID=2680153&SiteID=1
0

Featured Post

The new generation of project management tools

With monday.com’s project management tool, you can see what everyone on your team is working in a single glance. Its intuitive dashboards are customizable, so you can create systems that work for you.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now