[Webinar] Streamline your web hosting managementRegister Today

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 523
  • Last Modified:

VSS 2005 Access logs ???

Hi Experts,

I was looking for VSS users access logs and I have a found a options in

# MS-Visual Source Safe Administrator >> Tools >> Options >> General Tab >> I gave a path to "Log all actions in a journal file"

But still it not logging anything.

Please advice ! Thanks !
0
NetMaxtor
Asked:
NetMaxtor
  • 7
  • 6
1 Solution
 
anyoneisCommented:
Works great for me. Do the users all have modify permissions for the file you specified?


David
0
 
NetMaxtorAuthor Commented:
My VSS server is located in a windows 2003 AD environment and I already granted the Everyone full permission in the security tab. (But I didn't share shared the location)
Any idea ?
0
 
anyoneisCommented:
I don't understand " I didn't share shared the location". Does everyone have the right to modify the directory where the log is located? How about trying to put the log where the ini file is located for a test.

David
0
Never miss a deadline with monday.com

The revolutionary project management tool is here!   Plan visually with a single glance and make sure your projects get done.

 
NetMaxtorAuthor Commented:
I have created this file out side from the main VSS DB folder. (which is shared for all users)
Now moved the log file in to that VSS DB folder.
0
 
anyoneisCommented:
Did it help? VSS is a non-server based product, so in effect, each user has all of the server code running under his or her account when he/she accesses the code repository. Hence the requirement to share everything with modify permissions.
0
 
NetMaxtorAuthor Commented:
still no luck it seems !!! But i'll update !
0
 
NetMaxtorAuthor Commented:
anyoneis: still its not write anything. Following were my actions

1. Placed the log file out side of the VSS repository folder and granted everyone full access
2. Placed the log file in side the VSS repository folder and granted everyone full access

both didn't work !! and giving a error message "In valid DOS path "C:\PATH TO LOG FILE"

Please advice !
0
 
anyoneisCommented:
Invalid DOS path" is weird - I can't imagine how that is happenning, What exactly diod you give for the Journal file?

0
 
NetMaxtorAuthor Commented:
I just put a file name, and it's created file without a extension, is it wrong ?
Please advice !
0
 
anyoneisCommented:
No extendsion os ok, but you need to use a rooted path, such as "C:\Copy of Path\VssLog". Otherwise, you get that "invalid path" message.  Try this:

1) Close SourceSafe.
2) Open the adminb tool
3) Select  Tools Options
4) Use the browse button to select a directory.
5) Say Open, then add on a file name for the journal
6)CLock OK
7) Open up SourceSafe
8) Check out a file and edit it. - (Make a change!)
9) Check the file back in.
10) I beleive you will find a journal entry

David
0
 
NetMaxtorAuthor Commented:
Finally I found the issue ! Log generation path should be a UNC path since networked people accessing the VSS repository !

So I shared the location and given the necessary windows permission and after that I entered the path like \\VSS-Log\AccesLog

Now it's working fine !!  Thanks for your help David !
0
 
NetMaxtorAuthor Commented:
I found the resolution !
0
 
anyoneisCommented:
Glad you found it! The docs are not very helpful on that one. But, in retrospect, it makes sense,

Caio,
David
0

Featured Post

Get your problem seen by more experts

Be seen. Boost your question’s priority for more expert views and faster solutions

  • 7
  • 6
Tackle projects and never again get stuck behind a technical roadblock.
Join Now