?
Solved

Delete Public folder emails after the folder was delete it

Posted on 2008-01-26
13
Medium Priority
?
1,307 Views
Last Modified: 2008-03-25
Hello

I have an sigle exchange 2007 server in a single domain.
I think I had a corrupted public folder database since I was not able as administrator to create any public folder from outlook. On the old database I create a folder call service-request and I mail enable so it had an email call service-request@mydomain.com. I was not able to send any email to that adress so I come to the conclusion that I have to delete the public folder database and recreate. So i stop all teh exchange services and delete the public folder database file and then restart the services. The reason i did it this way was because when I try to delete it from Exchange console it keep complaining about the Offline Adress book that is map to this public fodler. So after I restart the service I go the mailbox public folder database and it say that the file can't be find and it ask me if I want to create a new Public fodler database. I said yes and now I can create any folder that i want without any problem. It look that my original problem is solved but after I create the folder call service-request , Exchange it assign the emaill servicerequest2@mydomain.com and that's because the original email adress from the old folder on teh old database still exist. The question is "where"? I look in the users mailbox but there is only users not public folders adress. I need to delete the original one so I can rename the new one. I apreciate your help
0
Comment
Question by:intelglobe
  • 7
  • 4
12 Comments
 

Author Comment

by:intelglobe
ID: 20749975
I try to remouve again the second databse that I create and it give me the same error as the first time.
--------------------------------------------------------
Microsoft Exchange Error
--------------------------------------------------------
The public folder database 'Intelglobe Public Folder' cannot be deleted.

Intelglobe Public Folder
Failed
Error:
The public folder database "DC\First Storage Group\IPublic Folder" contains the following offline address book(s):
\Default Offline Address Book
. Before deleting the public folder database, move the offline address book(s) to a web-based distribution point.

I'm not sure if deleting this time the entire database it will also delete the old email adress. It may delete the one associate it with the existing public folder. How can I mouve the adress book
0
 

Author Comment

by:intelglobe
ID: 20750075
I solve the problem with the Offline adress book but now I get a fodler replication problem.
I change the replication for the database from 15 minutes to never run but looks like there is another spot I have to change.

--------------------------------------------------------
Microsoft Exchange Error
--------------------------------------------------------
The public folder database 'Intelglobe Public Folder' cannot be deleted.

Intelglobe Public Folder
Failed
Error:
The public folder database "DC\First Storage Group\Public Folder" contains folder replicas. Before deleting the public folder database, remove the folders or move the replicas to another public folder database. For detailed instructions about how to remove a public folder database, see


0
Easily manage email signatures in Office 365

Managing email signatures in Office 365 can be a challenging task if you don't have the right tool. CodeTwo Email Signatures for Office 365 will help you implement a unified email signature look, no matter what email client is used by users. Test it for free!

 
LVL 10

Expert Comment

by:Smart_Man
ID: 20751552
have you deleted your public folder ?

please tell me the new situation in more detail
0
 

Author Comment

by:intelglobe
ID: 20751657
Ok
I delete the public and delete the old email adress for the old public folder from Active Directory users and computers. Now I recreate the public folder but when I send emails to the public folder I get in the que "There is currently no route to the mailbox database" The folder is already mail enable.
0
 
LVL 10

Expert Comment

by:Smart_Man
ID: 20751719
hope that helps

http://technet.microsoft.com/en-us/library/bb676395.aspx

waiting for your reply
0
 

Author Comment

by:intelglobe
ID: 20751788
I already have a receive and send connector since I can receive and send internal and external emails.
The problem is just sending to the public folder and the domain adress for the public folder is the same as the comapany domain so it should be accepted.
0
 
LVL 10

Expert Comment

by:Smart_Man
ID: 20751795
please provide more describtive lines + screenshots if you can

waiting for your reply
0
 

Author Comment

by:intelglobe
ID: 20751855
Identity: dc\Unreachable\63
Subject:
Internet Message ID: <A8945558667A93478B84351A65312A55018CC99F5B@dc.mydomain.local>
From Address: me@mydomain.com
Status: Ready
Size (KB): 55
Message Source Name: FromLocal
Source IP: 255.255.255.255
SCL: -1
Date Received: 1/26/2008 3:50:08 PM
Expiration Time: 1/28/2008 3:50:08 PM
Last Error: There is currently no route to the mailbox database
Queue ID: dc\Unreachable
Recipients:  Service-Request@mydomain.com
0
 

Author Comment

by:intelglobe
ID: 20751884
Not sure how can I describe this.
So to resume the entire situation I will say that I have an exchange 2007 server on a single domain.
There is already a send a receive connector for mydoamin.com.
Users can send and receive emails internal and external.
In Outlook 2007 I go to Public folder and create new public folder call service-request with mail post.
On the exchange 2007 Console I go to toolbox and Public Folder Management console. I right click on teh service-request public folder and chose mail enable. I verify that the email of the public folder is service-request@mydoamin.com. Now I try to send email from inside chosing from the Global adress list the service-request recipient and once I send it get stack on the Query, Undeliverable domain tab.
From Outside I will not get it eider but I will get next day NDR
Hope this will explain better.
Thank you
0
 

Author Comment

by:intelglobe
ID: 20756799
Well the problem is related to a mist configuration on adsi
It suppose to be a Public Folder hierarchy but it was not.
I had to crreate it manually and then create an object that point to the public fodler.
0
 
LVL 1

Accepted Solution

by:
Computer101 earned 0 total points
ID: 21208214
PAQed with points refunded (500)

Computer101
EE Admin
0

Featured Post

Creating Active Directory Users from a Text File

If your organization has a need to mass-create AD user accounts, watch this video to see how its done without the need for scripting or other unnecessary complexities.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

This article describes Top 9 Exchange troubleshooting utilities that every Exchange Administrator should know. Most of the utilities are available free of cost. List of tools that I am going to explain in this article are:   Microsoft Remote Con…
There are literally thousands of Exchange recovery applications out there. So how do you end up picking one that’s ideal for your business & purpose? By carefully scouting the product’s features, the benefits it offers you, & reading ample reviews f…
This video demonstrates how to sync Microsoft Exchange Public Folders with smartphones using CodeTwo Exchange Sync and Exchange ActiveSync. To learn more about CodeTwo Exchange Sync and download the free trial, go to: http://www.codetwo.com/excha…
Whether it be Exchange Server Crash Issues, Dirty Shutdown Errors or Failed to mount error, Stellar Phoenix Mailbox Exchange Recovery has always got your back. With the help of its easy to understand user interface and 3 simple steps recovery proced…
Suggested Courses

588 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question