how can detect which devise is using Com1 ?

Windows 2K3, Citrix PS 4.0
I would like to make Com1 available for a particular device. It doesn't show up as part of the available coms in device manager, which i am assuming means that a device is usinbg it.
1) How can i detect who is using it.
2) How can i switch the device that is using it to use a different Com so i can use Com1 ?

Please reply ASAP.

Thank you!
winpro2000Asked:
Who is Participating?
 
scrathcyboyConnect With a Mentor Commented:
the FIRST thing you need to do is go into the system BIOS -- COM1 is almost always on the motherboard -- so look for the BIOS setting on devices or peripherals, and you will see a COM port that is attached to the mobo.  This should be COM1, if it is not, set it to COM1.  Save the BIOS, then reboot, then you might need to follow the above suggestions.
0
 
2PiFLConnect With a Mentor Commented:
If it doesn't show in device manager that means it's not installed.

Go into Device Manager, Expand Ports | Right Click on a Com port | Click Properties | Click the Port Settings tab then the Click the Advanced button.   Click the drop down arrow next to Comm Port Number and it will show you which ports are in use.  You can also change the port number by Clicking on the number you want to use, then Clicking OK.
0
 
adg080898Connect With a Mentor Commented:
Go to control panel, system, device manager (OR just hold the windows key and press break). In device manager, choose view/view devices by connection. Find com1 and see what is under it in the tree.
0
SMB Security Just Got a Layer Stronger

WatchGuard acquires Percipient Networks to extend protection to the DNS layer, further increasing the value of Total Security Suite.  Learn more about what this means for you and how you can improve your security with WatchGuard today!

 
winpro2000Author Commented:
Thank you all for your answers, but i actually dont even have the ports listed under device manager. I think i will have to new hardware and select communication ports the install drivers for this port, which i don;t know what driver i would need to install at this poiny. hp or microsoft??

That being said. What do you think i should start with at this point/
0
 
scrathcyboyConnect With a Mentor Commented:
Are you talking a port on the server, or in the citrix install?  They are totally different.

On the server 2003 OS, you don't need any drivers at all for COM ports, they are automatically installed by the OS.  If you are talking about a server port being seen in citrix, and on the citrix clients, then YES, that has to be setup in Citrix configuration.  YOu assign the REAL port of COM1 on the server to a "COM1" citrix port, which is a virtual assignment that all citrix clients can see.
0
 
winpro2000Author Commented:
I am talking about the OS doesn't even see any ports in device manager. Citrix has nothing to do with this issue except that it will be used to publish a program that will use Com1. So i would like to make the port available.
What i also did is adding hardware component from device manager, then choosing ports. Although there is exclamation mark (meaning driver is not installed) i went to the porperty of this port (The OS assigned Com3 by default) port settings\ advanced and tried to switch the com to Com 1 but it was in use as well as Com 2.
In Device manager \ View by Connection, I looked for IRQ 4 and it was used by ACPI processor. Does that make sense?
Of course i called HP to find out how it can be changed, and they do not recomend changing the IRQ in the Bios.
I wonder what is your thoughts on this.


0
 
scrathcyboyConnect With a Mentor Commented:
The true assignment of which port the COM port is using at the hardware level MUST be done in the BIOS.

Go into the BIOS first, and look for the peripherals section, and see what the hardware setting is for the one and only (?) COM port on the motherboard.  If it is set to COM3, I see no reason not to change it to COM1, and save and reboot.  Then 2003 would detect it as COM1 (actually before you do that, remove the port you manually installed from device manager, then reboot and go into the BIOS and do the above).  WHen you boot back to the OS, 2003 will correctly detect it as COM1 and you will be fine.

Their aversion to not changing it probably relates to worry that a modem is installed on COM1.  If device manager shows nothing at COM1, there is no reason to be afraid of changing it in the BIOS.  Try that.
0
 
winpro2000Author Commented:
I will check tomorrow what does the bios says. But as i said the bios uses IRQ 4 for  ACPI processor. Can this be easily changed to use a different IRQ??
0
 
scrathcyboyConnect With a Mentor Commented:
COM1 IS IRQ 4 -- that is the normal for COM1 and COM3
COM2 is IRQ3 -- that is normal for COM2 and COM4

What I am saying is you do not want/need/have to change the IRQ -- just the port address to COM1 -- there should be a setting that simply says -- COM  1, 2, 3, or 4.  Pick COM 1.
0
 
winpro2000Author Commented:
Device manager says Com1 is in use.
0
 
scrathcyboyConnect With a Mentor Commented:
"I will check tomorrow what does the bios says"

we were talking about the BIOS, not device manager.  If "com1 is in use" you must already have the BIOS set to COM1, or another device like a modem using COM1 -  I think you are missing what I have been trying to explain.  Good luck.
0
 
winpro2000Author Commented:
I got you now. I couldn't restart the server because it is a production server.
I will do it tonight hopefully. As soon as i do i will let you know.
0
 
winpro2000Author Commented:
Here is the update. Take a look at the attached file. I would like to hear your thoughts
adding-serial-port.doc
0
 
scrathcyboyCommented:
so it was the BIOS change that did the trick?  I thought so.  Good luck.
0
 
winpro2000Author Commented:
Yes, it was the Bios.. Good job and thank you for your help!
However i have to add this. Even though i disabled EMS who was using Com1 and  Bios serial port that was set to Auto and i set it to Com2, When the system booted up i saw Com1 was still in use. I ignored the warning message  and i changed it anyway. Com1 was changed and the OS see Com1 finally as a free bird!!
0
All Courses

From novice to tech pro — start learning today.