*.msi files giving "not valid win32 application" in XP Pro SP2

About a week ago I had to reinstall windows XP pro sp2 from an original OEM Sp2 CD. The re-install went OK.

When I came to do updates it bombed out with a failure when trying to update to Windows 3.1 installer.
Have possibly solved that problem as the version of msi.dll is 3.1 and windows udpate no longer tries to install it.

However no files with the .msi extension will install giving the *.msi is not a valid Win32 application.

Have tried to use a file to update the registry keys but that won't complete.

I need to install php and mysql on IIS5.1

Also all windows updates fail after the install of win installer 3.1 - 93 updates in total
dgncAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

MotoCrazyCommented:
Reboot the computer, the try to download and install Windows Installer on its own. You can get it here:

http://www.microsoft.com/downloads/details.aspx?familyid=889482FC-5F56-4A38-B838-DE776FD4138C&displaylang=en

See if that allows updates to complete. You may have gotten a corrupt download of the installer.
0
orangutangCommented:
0
dgncAuthor Commented:
Rebooted - downloaded new copy
Installed OK
Tried to install a *.msi
Failed - same message
Updates - all fail
Rebooted - tried *msi again same result
Applied dougnox fix - fails "Cannot import C:\&....\msi_assoc\msi1.reg : Not all data was successfully written to the registry. Some keys are open by the system or other processes"
Reboot - killed Kapersky and other optional processes - tried dougnox again - failed
0
Cloud Class® Course: Microsoft Windows 7 Basic

This introductory course to Windows 7 environment will teach you about working with the Windows operating system. You will learn about basic functions including start menu; the desktop; managing files, folders, and libraries.

MotoCrazyCommented:
Wow! Can you try the DougKnox fix from Safe Mode?
0
orangutangCommented:
Hmm, download and open Process Explorer(http://technet.microsoft.com/en-us/sysinternals/bb896653.aspx), press Ctrl+F, and check to see what process has any of these keys open:
[HKEY_CLASSES_ROOT\.msi]
[HKEY_CLASSES_ROOT\Msi.Package]
[HKEY_CLASSES_ROOT\Msi.Package\DefaultIcon]
[HKEY_CLASSES_ROOT\Msi.Package\shell]
[HKEY_CLASSES_ROOT\Msi.Package\shell\Open]
[HKEY_CLASSES_ROOT\Msi.Package\shell\Open\command]
[HKEY_CLASSES_ROOT\Msi.Package\shell\Repair]
[HKEY_CLASSES_ROOT\Msi.Package\shell\Repair\command]
[HKEY_CLASSES_ROOT\Msi.Package\shell\Uninstall]
[HKEY_CLASSES_ROOT\Msi.Package\shell\Uninstall\command]

Also, check out this recent topic:
http://www.experts-exchange.com/OS/Microsoft_Operating_Systems/Windows/Q_23096404.html

and download and open Dial-a-fix (http://wiki.djlizard.net/Dial-a-fix#Mirrors.2Fdownload_locations.2C_and_articles), check "Fix Windows Installer:", and click "GO". Also, have you tried installing it in safe mode?
0
orangutangCommented:
Search for those keys in Process Explorer without the brackets.
0
Vadim RappCommented:
This error usually means that some file is damaged.

Try running from command line msiexec.exe. It should show a window with parameters.

If not, then run sfc /scannow.

If yes, then find some other msi file and try to install. If that one is ok, then the problem is in your msi file.
0
Vadim RappCommented:
also, disable kasperski.
0
dgncAuthor Commented:
I have now been able to do all the updates but still I get the message when I double click on a *.msi
process Explorer doesn't return any processes when the searches are tried
Dial-a-ficx seemed t get the updates working

Have tried associating the file using
=======
C:\>assoc .msi
.msi=Msi.Package

C:\>assoc .msi=Msi.Package
Error occurred while processing: .msi.

C:\>
=======
0
orangutangCommented:
Have you checked to see what process has those keys open? Also, have you tried in safe mode?
0
dgncAuthor Commented:
No processes had the key open
Have tried it in safe mode - same result
0
dgncAuthor Commented:
I am off to bed now - back in about 6-7 hours

Thanks for your help so far
0
orangutangCommented:
Download and open IceSword (http://antirootkit.com/software/IceSword.htm), expand the "Registry" section, and delete those keys. Then, try reinstalling MSI or adding the .msi registry .reg file to the registry.
0
dgncAuthor Commented:
orangutan - have done the icesword suggestions - no change.

Clicking a *.msi is still giving the "not a valid Win32 Application" message

Also prevxCSI does not throw up any problems.

I also note that in Kapersky Internet Security 6.0 that
Mail Anti-virus
Antihacker
Anti Spam
All have a status of "failure" with the warning "Some protection components failed to laod"
 
0
orangutangCommented:
Were you able to delete the keys successfully? Also, have you checked your event viewer for anything that may help to narrow down the problem?
0
dgncAuthor Commented:
I was able to successfully delete the keys and restore them.

The only 'events' I can find that could be associated with it has the following message
::::
Event Type:      Error
Event Source:      W3SVC
Event Category:      None
Event ID:      14
Date:            27/01/2008
Time:            16:47:06
User:            N/A
Computer:      DAVID
Description:
The HTTP Filter DLL C:\PHP\php5ts.dll failed to load.  The data is the error.
For additional information specific to this message please visit the Microsoft Online Support site located at: http://www.microsoft.com/contentredirect.asp.

For more information, see Help and Support Center at http://go.microsoft.com/fwlink/events.asp.
Data:
0000: 7e 00 00 00
::::              
but I don't think that is pertinent
0
orangutangCommented:
Have you tried to manually reinstall the Windows Installer and run a .msi file in safe mode? Also, send us your HijackThis (http://www.trendsecure.com/portal/en-US/threat_analytics/hijackthis.php) log.
0
dgncAuthor Commented:
Have done a manual install of windows installer and that what allowed me to do the 90 odd windows updates from the SP2 CD to date.

Same message when trying an msi in safe mode

I ran a full system scan using kapersky earlier on today and it flag up a trojan
win32.Delf.dzr but I can't find out what it does apart from being a downloader.

Attached is hijackthis.log
hijackthis.log
0
orangutangCommented:
Well, maybe it could be a virus problem. Scan with SUPERAntiSpyware (http://www.superantispyware.com/downloadfile.html?productid=SUPERANTISPYWAREFREE). Also, sometimes the antivirus program itself can cause the problem. Try disabling any security software and then try again.
0
dgncAuthor Commented:
Scanned with SuperAntiSpyware and the only think found was an ad tracking cookie.

Turned of security products and tries to rum *.msi - usual error message
0
orangutangCommented:
Well, if it's not too much of a hassle, try completely uninstalling all security software and then trying everything over again.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Vadim RappCommented:
I'm pretty sure that the only cure to this problem is in running repair installation from the installation disk, and preferably, another disk rather than your OEM. According to Microsoft, big amount of mysterious system crashes are traditionally caused by bad media. "Not valid system image" is sure sign of physically damaged file, and cleaning the registry is akin to trying to treat bad tooth on someone in coma from car accident. Also it should be mentioned that the very first question should be whether Installer itself is damaged or not, which can be easily achieved by running msiexec.exe alone, and checking the signature of msiexec.exe and msi.dll. Until this is checked, I wouldn't even think about touching the registry.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Installation

From novice to tech pro — start learning today.