Windows SBS 2003 Backup Error

I have a SBS 2003 Server and I am running the default settings for the Backup located in the Server Management console. (Default meaning I have not made any changes other that where to tell it to back up to.)

I am backing up to a External Hard Drive (500GB LaCie) that has 450 GB free. The Hard Drive is located on a Windows 2003 Terminal Server. The drive is accessible from the SBS server through the share created.

I continue to get the following error but am not sure why or how to go about troubleshooting the problem,  (log report from SBS Back up):

1/26/2008 3:12 PM
-------------------------------
Date: 1/26/2008
Time: 3:12 PM
User: I*-----------
-------------------------------

Backup Runner started.
Launching NTBackup: ntbackup.exe backup "@C:\Program Files\Microsoft Windows Small Business Server\Backup\Small Business Backup Script.bks" /d "SBS Backup created on 1/26/2008 at 3:12 PM" /v:yes /r:no /rs:no /hc:off /m normal /j "Small Business Server Backup Job" /l:s /f "\\Ts********\Back UP (G)\Backup Files\Small Business Server Backup (01).bkf" /UM
NTBACKUP LOG FILE: C:\Documents and Settings\SBS Backup User\Local Settings\Application Data\Microsoft\Windows NT\NTBackup\data\backup07.log
=====================<BEGIN NTBACKUP LOG FILE>=====================
Backup Status
Operation: Backup
Active backup destination: File
Media name: "Small Business Server Backup (01).bkf created 1/26/2008 at 3:12 PM"

Volume shadow copy creation: Attempt 1.
Backup (via shadow copy) of "C: "
Backup set #1 on media #1
Backup description: "SBS Backup created on 1/26/2008 at 3:12 PM"
Media name: "Small Business Server Backup (01).bkf created 1/26/2008 at 3:12 PM"

Backup Type: Normal

Backup started on 1/26/2008 at 3:14 PM.

Error: The device reported an error on a request to write data to media.
Error reported: Unknown error.
There may be a hardware or media problem.
Please check the system event log for relevant failures.
The operation was ended.
Backup completed on 1/26/2008 at 3:25 PM.
Directories: 231
Files: 4706
Bytes: 765,296,549
Time:  11 minutes and  40 seconds

Error: C: is not a valid drive, or you do not have access.


Error: An inconsistency was encountered in the requested backup file.

Error: E: is not a valid drive, or you do not have access.


Error: An inconsistency was encountered in the requested backup file.

Error: F: is not a valid drive, or you do not have access.


Error: An inconsistency was encountered in the requested backup file.

Error: PO********\Microsoft Information Store\First Storage Group is not a valid drive, or you do not have access.


Error: An inconsistency was encountered in the requested backup file.

----------------------

The operation did not successfully complete.

----------------------

=======================<END NTBACKUP LOG FILE>=====================
NTBackup finished the backup with errors.

For more information about failed backups, see the article on troubleshooting your backup at the following Web page: http://go.microsoft.com/fwlink/?LinkId=18414

Backup ended at Saturday, January 26, 2008 3:25 PM
Backup Runner finished.
alanseanAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Jeffrey Kane - TechSoEasyPrincipal ConsultantCommented:
The problem is right at the beginning of your log... you have modified the USER that backup runs under...

Since yours says:

"User: I*-----------"  Or whatever you modified that from.

It should be running under the SYSTEM account.

So perhaps you did make a change to the scheduled task?  

You can fix this by either running the backup wizard to stop using SBS Backup, making sure the Scheduled Task is deleted, and then rerunning the wizard again to recreate it.  Or you can just open the Backup Small Business Server Scheduled Task, and change the "Run as" to NT AUTHORITY\SYSTEM with a BLANK password.

If you've modified the AD Structure at all, removing the SBS Backup User account (which is disabled by default but is required to be there), this might also have caused this problem.

Jeff
TechSoEasy
0
alanseanAuthor Commented:
THe section that says:
-------------------------------
Date: 1/26/2008
Time: 3:12 PM
User: I*-----------
-------------------------------

I purposely blanked out the user name that was listed on the report. This User:I*------, is the Administrator user name.

When I run the back up wizard I only made to modifications, one was to not back up drive G and to not back up the mailboxes.

All of the other options " /v:yes /r:no /rs:no /hc:off /m normal /j "Small Business Server Backup Job" /l:s /f "  I assume are defaults by the wizard.

The wizard does not ask me who to run the back up as, so I am assuming it is running it as the user that is logged in, in this case it is the Administrator.

I have not modified the AD structure or removed the SBS Backup User.

I am not sure where to find the Backup Small Business Server Scheduled Task, when I look in the NT Back up program it does not have a schedule.

Also if I re run the back up wizard and tell it to stop using the SBS back up, I am not sure where to check  to make sure the Scheduled Task is deleted.

I appreciate the information, I just fell I need a bit more to get it through my head,

0
Jeffrey Kane - TechSoEasyPrincipal ConsultantCommented:
"I purposely blanked out the user name that was listed on the report. This User:I*------, is the Administrator user name."

I understood that... but it shouldn't be running as the administrator account.  It needs to be running under the SYSTEM account.

You would find the Scheduled Task in the Control Panel > Scheduled Tasks.  Go ahead and change the "Run as" to NT AUTHORITY\SYSTEM as I recommended above.

Then, I'm thinking that you don't have proper permissions on your backup destination.

Make sure that the folder you are backing up to is SHARED with the following "Share Permissions"
Backup User (DOMAINNAME\SBS Backup User)  --  Full Control
Domain Admins (DOMAINNAME\Domain Admins) -- Full Control
Everyone -- Read

Then on the Security Tab add the following permissions to those which are inherited:
Backup User (DOMAINNAME\SBS Backup User) -- Full Control -- This Folder, Subfolders and Files
Domain Admins (DOMAINNAME\Domain Admins) -- Full Control -- This Folder, Subfolders and Files
SYSTEM (NT AUTHORITY\SYSTEM) -- Full Control -- This Folder, Subfolders and Files

That should take care of it for you.

Jeff
TechSoEasy
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Upgrade your Question Security!

Your question, your audience. Choose who sees your identity—and your question—with question security.

alanseanAuthor Commented:
I have made the changes as suggested, now I see this as the Backup report:


1/27/2008 8:47 AM
-------------------------------
Date: 1/27/2008
Time: 8:47 AM
User: SYSTEM
-------------------------------

Backup Runner started.
Launching NTBackup: ntbackup.exe backup "@C:\Program Files\Microsoft Windows Small Business Server\Backup\Small Business Backup Script.bks" /d "SBS Backup created on 1/27/2008 at 8:47 AM" /v:yes /r:no /rs:no /hc:off /m normal /j "Small Business Server Backup Job" /l:s /f "\\Tspondpeds\backup\Backup Files\Small Business Server Backup (02).bkf" /UM
NTBACKUP LOG FILE: C:\Documents and Settings\SBS Backup User\Local Settings\Application Data\Microsoft\Windows NT\NTBackup\data\backup08.log
=====================<BEGIN NTBACKUP LOG FILE>=====================
=======================<END NTBACKUP LOG FILE>=====================
NTBackup finished the backup with errors.

For more information about failed backups, see the article on troubleshooting your backup at the following Web page: http://go.microsoft.com/fwlink/?LinkId=18414

Backup ended at Sunday, January 27, 2008 8:47 AM
Backup Runner finished.
0
alanseanAuthor Commented:
OK I fiinally gave up and went into the office (as opposed to doing it remotely).

I removed the LaCie hard Drive from the Windows 2003 Terminal Server and plugged in directly into the SBS  and ran the back up and it works just fine.

You were correct as to the idea that it was a permissions problem. I am not really sure why that problem exists, I can access the drive on the Terminal Server through the share from the SBS and copy and delete items to it and since the back up would run and at some point stop, but that is another problem for another day.

Thank you.
0
Jeffrey Kane - TechSoEasyPrincipal ConsultantCommented:
Well, that sounds like a better idea anyhow... since your write time will be much faster when its directly connected.

Jeff
TechSoEasy
0
tacfCommented:
In our case this issue was caused by the Symantec Endpoint Protection client, and the way it stores it's antivirus definitions. With an ASR it's not possible to exclude directories, so we chose to stop using Symantec's product and moved to another. Endpoint Protection also caused problems with our Backup Exec backups.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
SBS

From novice to tech pro — start learning today.