Error - Outlook Express - While saving image. AppName: msimn.exe ModName: dxmasf.dll

Hello Experts

The error shown below occurs when I open an email in Outlook Express 6 on my Windows XP SP2 system, Right-Click on an image in it, and choose the "Save Picture As" option.

AppName: msimn.exe
AppVer: 6.0.2900.2180
ModName: dxmasf.dll
ModVer: 6.4.9.1125
Offset: 0000d25e

See attached JPG screenshots and text file with descriptions of each.

The error pops up when I browse to my Primary Slave internal IDE 160GB hard drive and begin to browse the folders on the 122GB FAT32 partition created on it for document and image storage.

That partition is only half full and, although it does have a large number of folders containing a mixed range of file sizes, the folder depth is not unusual or excessive.

The error occurs whether or not I am viewing files and folders in Thumbnail or Details view, and is not related to navigating too fast, because it happens when I try the same operation at a snail's pace.

Although not completely immune from this error, other hard drive partitions on an 80GB external USB hard drive formatted as FAT32, and with less content than the internal one, do not generate this error when browsed to for the same purpose.

The error is consistent whether or not I try to rename the image to be saved in the file name field of the Save dialog.  It also shows the same error regardless of whether the image is a jpg, gif, or bmp file.

The error reporting debug process during the error generated the file "fed7_appcompat.txt" in my TEMP folder while attempting to save a JPG image from within an email that defaulted to the file name:
!cid_00a001c85f1f$d71bb000$2680cd4c@w3g5z7

The "fed_appcompat.txt" is XML-based, and I have ONLY shown an edited extract of what seem to me to be the most relevant lines in the "Code Snippet" box.  I can supply the complete error file if needed.

Here are the file properties of the file "dxmasf.dll" installed on my system:

CompanyName = Microsoft Corporation
FileDescription = Windows Media Source Filter
FileVersion = 6.4.09.1125
InternalName = dxmasf.dll
LegalCopyright = Copyright (C) 1992-1999 Microsoft Corp.
OriginalFilename = dxmasf.dll
ProductName = DirectShow
ProductVersion = 6.4.09.1125
DirectShow = Core
OLESelfRegister = DXM20

That being a DirectX (or more correctly DirectShow) file, I am puzzled why this file should be conflicting with Outlook Express.

NOTE:

I am getting the same error when I try to save an image from a web page in Internet Explorer (IExplore.exe and dxmasf.dll).  Because the error messages and events are practically the same, I am not documenting it or supplying screenshots.

What I have done to try and resolve this:

1. Ran   regsvr32 dxmasf.dll  and although it reported successful re-registering, the error persisted after a reboot.

2. Ran sfc /scannow - no files restored and error not resolved.

3. Reinstall XPSP2 and reinstall Windows Updates.  IE and OE were unmodified versions of those installed by SP2, so this will have put them back to what they were before this error situation.

4. Reinstalled the default XP SP2 version of DirectX 9c that was on it before, and did so by running the redistributable package.

5. Checked all drives for errors - error still there.

6. Defragged all drives - error still there.

Can anyone explain why a DirectShow DLL should be generating an Outlook Express and Internet Explorer error, and why this should only be happening (99% of the time) on one particular drive that has more folders than the others?

Can anyone suggest a fix, or links to a page that contains a tried and tested fix for this problem.  I have googled it, but I don't see any apparently reliable "solutions" for this.

Please have a look at the screenshot images attached and they will show what I have tried to describe.

Thanks

Bill
fed_appcompat.txt
Note:
** Ver1 ** = 6.00.2900.2180 (xpsp_sp2_rtm.040803-2158)
** Ver2 ** = 5.1.2600.2180 (xpsp_sp2_rtm.040803-2158)
 
<?xml version="1.0" encoding="UTF-16"?>
<DATABASE>
 
<EXE NAME="msimn.exe" FILTER="GRABMI_FILTER_PRIVACY">
    <MATCHING_FILE NAME="msimn.exe" VERSION="** Ver1 **"/>
 
    <MATCHING_FILE NAME="msoe.dll" FILE_VERSION="** Ver1 **"/>
    <MATCHING_FILE NAME="msoeres.dll" FILE_VERSION="** Ver1 **"/>
    <MATCHING_FILE NAME="oeimport.dll" FILE_VERSION="** Ver1 **"/>
    <MATCHING_FILE NAME="oemig50.exe" FILE_VERSION="** Ver1 **" />
    <MATCHING_FILE NAME="oemiglib.dll" FILE_VERSION="** Ver1 **"/>
    <MATCHING_FILE NAME="setup50.exe" FILE_VERSION="** Ver1 **"/>
    <MATCHING_FILE NAME="wab.exe" FILE_VERSION="** Ver1 **" />
    <MATCHING_FILE NAME="wabfind.dll" FILE_VERSION="** Ver1 **"/>
    <MATCHING_FILE NAME="wabimp.dll" FILE_VERSION="** Ver1 **"/>
    <MATCHING_FILE NAME="wabmig.exe" FILE_VERSION="** Ver1 **"/>
</EXE>
 
<EXE NAME="dxmasf.dll" FILTER="GRABMI_FILTER_THISFILEONLY">
    <MATCHING_FILE NAME="dxmasf.dll" FILE_VERSION="6.4.09.1125" />
</EXE>
 
<EXE NAME="kernel32.dll" FILTER="GRABMI_FILTER_THISFILEONLY">
    <MATCHING_FILE NAME="kernel32.dll" FILE_VERSION="** Ver2 **"/>
</EXE>
 
</DATABASE>

Open in new window

Image-Index.txt
OE-Error-001.jpg
OE-Error-002.jpg
OE-Error-003.jpg
OE-Error-004.jpg
LVL 39
BillDLAsked:
Who is Participating?

[Webinar] Streamline your web hosting managementRegister Today

x
 
ded9Connect With a Mentor Commented:
Hi,

Check whether you have ie7 folder in windows. I know you do not have ie7 installed. Click start-->run and type ie7 --go to spuninstall folder and double click on the computer setup icon to uninstall internet explorer 7.


Did you try renaming the file.

Ded9
0
 
ded9Commented:
Hi,

First try regsvr32 dxmasf.dll  

doesnt work try this

renaming the file dxmasf.dll

doesnt work

click start ---> Run ---> type ---> ie7---go to spuninstall folder and double click on the computer setup icon to uninstall internet explorer 7.

doesnt work try this

http://www.solveithere.com/ier.html



Ded9
0
 
ded9Commented:
Hi,

Also can try downloading latest version of directx or do a spyware scan from safe mode with networking.


Also can try doing doing clean boot restart the computer in normal mode and then try saving the picture.

Clean boot http://support.microsoft.com/kb/310353



Ded9
0
The new generation of project management tools

With monday.com’s project management tool, you can see what everyone on your team is working in a single glance. Its intuitive dashboards are customizable, so you can create systems that work for you.

 
war1Commented:
Hi Bill,

You may need to take ownsership of folders and files in the slave drive to access them.
http://support.microsoft.com/?kbid=308421

Hope this helps!
war1
0
 
BillDLAuthor Commented:
Hi ded9

I don't have IE7 installed, and don't want to either.  It was working just fine about 3 weeks ago with IE6 and I don't want to clutter up the system with another version that may not fix the problem.

I have already re-registered the DLL:

>>>
"What I have done to try and resolve this:
1. Ran   regsvr32 dxmasf.dll  and although it reported successful re-registering, the error persisted after a reboot.
etc....
<<<

My system has been thoroughly scanned for viruses and other malware, and it is clean.

I may end up installing a more recent version of DirectX, but the system was working file with the default XP SP2-installed version and I would be installing another version to potentially complicate what might be a simple cause.

Thanks war1, that's good thinking, but the partition in question on the slaved hard drive is FAT32 and this system is set to use Simple File Sharing anyway.  It's only used for non-confidential file storage, and I need to be able to swap it to Win98se once in a while.

Thanks guys.
0
 
BillDLAuthor Commented:
Sorry, I meant to say that I had renamed dxmasf.dll.  Within seconds Avast AntiVirus popped up notifying me that winlogon required write access to dxmasf.dll, and the file was restored, apparently from the folder:
C:\WINDOWS\$NtServicePackUninstall$
A bit-for-bit binary comparison shows that the renamed file, the restored one, and the one in $NtServicePackUninstall$ are exact matches.

I don't really want to turn off the Windows File Protection at the moment.

Start > Run > IE7 = "Windows cannot find IE7. etc"
File search for *spuninstall" = nothing found.

I know this system intimately, as it is my workhorse, and I know that there are no folders containing any files remotely associated with IE7.

I'm going to renstall DirectX 9c from the redistributable and see if that fixes the problem.  I'll let you know.

Thanks
0
 
BillDLAuthor Commented:
Whoops, I searched for *spuninstall* and spuninstall without the * *
0
 
BillDLAuthor Commented:
I also meant to say that I started in Safe Mode and the error still occurred.
0
 
ded9Commented:
Hi,

Do not touch the spuninstall folder it might be related with other software.

It seems avast addin in oulook express is creating this problem.

Check in safe mode with networking  whether you get the same error.

If you do not get the same error in safe mode with networking then it seems the problem is cause by firewall.


Ded9
0
 
ded9Commented:
Hi,

Then try uninstalling avast and then check.


Ded9
0
 
ded9Commented:
Hi,

Also can try reinstalling internet explorer and oultook express

http://www.bleepingcomputer.com/tutorials/tutorial71.html

Also can try setting internet explorer as your default browser and then check.


Ded9
0
 
BillDLAuthor Commented:
Hi ded9

>>> Do not touch the spuninstall folder it might be related with other software <<<
I wouldn't, even if that folder existed.  I don't mess with the C:\WINDOWS\$NtServicePackUninstall$ folder either.

>>> It seems avast addin in oulook express is creating this problem.  Try uninstalling avast and then check. <<<
Perhaps mentioning that was misleading.  I've used Avast AntiVirus for a while without any problems, and the Internet Mail Protection is not the cause.  I uninstalled and reinstalled it again just to be sure.   I'm not going to uninstall Avast and leave it off, but have already tested by disabling all its services and resident protection modules.  The "Standard Shield" is there for good reason, and prompts me if system or program requests are made to write to, create, or delete certain files.  I can say yes or no.  It only popped up as Winlogon decided that dxmasf.dll needed to be restored to my system.
 
>>> Check in safe mode with networking  whether you get the same error.  If you do not get the same error in safe mode with networking then it seems the problem is cause by firewall. <<<
I mentioned the results of this after you previously suggested it, but we posted close together and perhaps your screen didn't refresh to show my reply which indicated that the error is still there.  I have the Windows Firewall uninstalled because it's useless.  Instead I use ZoneAlarm.  In combination with Avast's Network and Web Shields, this has me pretty secure, but not to the point where it's going cause this kind of problem.  I could see that it could be a problem if it was occurring while using Webmail, or if the image in Outlook Express was being fetched from an Internet source, but it's embedded into the email.   Just to be sure, I killed off ZoneAlarm but the error continues.

I'll get back to you with the recommendation to reinstall IE and OE, but note that these are both the default WinXP SP2 versions and I did reinstall SP2.  I may try and force a reinstall of them as "Optional Components" though.

Thanks
0
 
ded9Commented:
Hi,,
In that case create a new user account and check the issue will be resolved.


Ded9
0
 
BillDLAuthor Commented:
Hi ded9 and war1

I created a new user account and tested, but still the same error.

I have "resolved" the issue in the meantime, and hope that it stays OK until I wipe the drive and reinstall in the near (hopefully) future.  It's an improvised fix, and I'm not sure yet if any other applications will be affected, but none so far.

The points go to you ded9, because in effect I eventually did as you suggested earlier and what I had intended to do as I was nearing the last options I wanted to consider.  I did it with a bit of cheating though.

As I mentioned, deleting or renaming dxmasf.dll with Windows System File Protection running just restored the file again.  I first made a backup copy named dxmasf.xxx to the same folder and one as dxmasf.dll to another non-system folder, then ran a utility named XPLite (http://www.litepc.com/xplite.html) to disable the File Protection.

I could have done this in other conventional or less conventional ways, but XPLite has a nice little button to "Stop" the protection ONLY for that session, and does so after a couple of seconds.
By the way, in case you look at that site, the answer is NO when you wonder whether XPLite caused this problem.  It hasn't been used to slim down THIS computer, but I've used it often enough with fine results on others.

Anyhow, this allowed me to delete dxmasf.dll.  I  tried extracting a fresh copy from the folder I created by unpacking the SP2 setup package to the System32 folder, and copied it to the folder containing the backup I had made from there earlier.  They are an exact match in binary comparison, so I can safely say that the file wasn't corrupt.  

With the newly extracted dxmasf.dll, I rebooted to allow File Protection to be re-enabled, and dxmasf.dll is now not backed up.  I tested the outcome with the newly extracted dll in place, and got the same error, so I just deleted it and rebooted.

The problem has gone, and I have not yet had any errors or unexpected behaviour in any applications or programs without it, which makes me wonder what the hell it IS used for and called by.

A bit of a hack job, but all is OK for now.

Thanks guys.
Bill
0
All Courses

From novice to tech pro — start learning today.