Internet Sharing With MAc Ethernet Port 2 to a Router Downstream

Can this be done?

I have a WAN connection fro Ethernet Port 1 to a fiberoptic modem.  Internet works fine.  I have Internet Sharing turned on or Ethernet Port 2.  If I connect E2 to another NIC, no problem - gets IP address and can connect to the Internet.  However, If I connect my router's WAN port to the Mac's Ethernet port 2, the router fails to get an IP address from the Mac.  I have tried just about everything and I just can't get it to work.  Any ideas what the problem might be?  I should mention that it DID work briefly - once - but never again.  No idea why.  Do I need a special cable for this?  Do I need to configure the connection parameters differently?  The reason I am trying to do this instead of putting the router upstream and connecting the Mac to it is because the router is a piece of junk Buffalo router that has nowhere near the throughput it claims to.  I need to be able to connect to the Internet wirelessly, which is why I need the router, but if I connect the mac to it my max DL/streaming speed drops from 900kbps to 300.  That won't do.

shachoAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

darron_chapmanCommented:
You can just plug port 2 on your mac into one of the LAN ports.... this should allow any other computers connected to this router (wired or wireless) to pull an IP directly from the Mac
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
shachoAuthor Commented:
I'm a little grey on the mechanics of networking so please bear with me.  

Doesn't the router need to be connected via the WA port in order to function as a second DHCP server for everything that is connected to it?

0
shachoAuthor Commented:
Sorry - WAN port
0
Big Business Goals? Which KPIs Will Help You

The most successful MSPs rely on metrics – known as key performance indicators (KPIs) – for making informed decisions that help their businesses thrive, rather than just survive. This eBook provides an overview of the most important KPIs used by top MSPs.

shachoAuthor Commented:
Or are you saying - that's not even necessary?  Should I disable the DHCP function on the router?
0
darron_chapmanCommented:
no... your MAC will be the DHCP server and then it is connecting to basically a switch that has wireless capabilities... anything connecting to that "switch" should pull dhcp information from the MAC
0
darron_chapmanCommented:
Yes... DHCP should be OFF on your router
0
shachoAuthor Commented:
OK - turned the DHCP function off and restarted the router.  It is still assigning the old IP address to my downstream computer.  Shouldn't the downstream computer be getting its IP address from the Mac?
0
shachoAuthor Commented:
BTM - router is Buffalo Air Station WHR-HP-G54
0
darron_chapmanCommented:
should be... try restarting the downstream computer....
0
darron_chapmanCommented:
And verify that DHCP is off... i've seen in the past where I've turned off DHCP and gone back in only to discover that it was still on
0
shachoAuthor Commented:
DHCP is definitely set to disabled on the router.  But the downstream computer is still getting its address from the router, not the Mac.  Should address translation be of for the router?
0
darron_chapmanCommented:
address translation should only be used to translate the address of the wan port to addresses of the LAN ports... that shouldn't be affecting this, but it won't hurt to shut it off... it's odd that with DHCP off, your downstream computer is still pulling DHCP... try power cycling the router (unplug it, wait about 15 seconds, then plug it back in)
0
shachoAuthor Commented:
Tried it already.  No luck.  Here's a report from the router's log:
00:00:07 DHCP OpenDhcpSocket: can't set initial netmask: Invalid argument
00:00:08 DHCP broadcasting DHCP_DISCOVER


0
shachoAuthor Commented:
Does the router need to be set up as a bridge?
0
darron_chapmanCommented:
It looks like you disabled DHCP on the WAN port... you need to disable DHCP on the LAN side... probably something that says distribute IPs or something along those lines
0
darron_chapmanCommented:
Looking at the manual for your router, click on LAN config on the left hand side, then click DHCP server then UNCHECK Enable next to DHCP server .. this is just going by what I read on the manual
0
shachoAuthor Commented:
Under WAN settings

IP Address Options:
Internet@Start
Acquire from DHCP server
Use PPPoE client
Use IP Unnumbered
Configure manually

I have Acquire from DHCP server selected

Under LAN settings:
There is a checkbox labeled "Use DHCP Server"
It is unchecked.

Under lease information:
There is a section called something like "PC's engaging in web settings" (it's in Japanese).  The IP address of the downstream PC shows up here.  Is the PC assigning it's own address as the last one that worked?  Seriously, I have rebooted the PC twice and released the connection more times than I care to count.








0
shachoAuthor Commented:
You're description is accurate.
0
darron_chapmanCommented:
what is the address of the downstream machine?
0
shachoAuthor Commented:
192.168.11.50
50 because at one point I configure the DHCP server to start with 50.
0
darron_chapmanCommented:
your downstream computer is set for DHCP, right.... what IP address does your downstream computer get when connected directly to your mac?
0
shachoAuthor Commented:
Here's an interesting twist.  To test my theory I tried connecting the pc to the mac directly.  It got a new functioning address and connected to the internet successfully.  Now it's plugged back into the router and one of the router's LAN ports is connected to the Mac.  Downstream PC is getting the original IP address correctly from the mac and connects to the internet.  Still trying to connect to the router's configuration utility.
0
shachoAuthor Commented:
Now I can't connect to the router.  The router's address should be 192.168.11.1.  The PCs address is 192.168.2.2.  The default gateway is 192.168.2.1.


0
shachoAuthor Commented:
Incidentally, is the MAC's Internet sharing software really capable of assigning more than one downstream IP address?
0
darron_chapmanCommented:
you'll need to set up a second IP (manual) on your downstream mac make it 192.168.11.2 with a subnet mask of 255.255.255.0 and a default gateway of 192.168.11.1 (Although that could be blank.... you could set this up as a new location...
0
darron_chapmanCommented:
>>Incidentally, is the MAC's Internet sharing software really capable of assigning more than one downstream IP address?

Yes... that's the whole idea of internet sharing ... to share a connection with multiple computers...
0
shachoAuthor Commented:
I'm afraid you lost me on that one.  Just to make sure we're discussing the same configuration, I have:

- A PPPoE connection that goes in to Ethernet 1 on a Mac Pro.
- Internet sharing on the Mac Pro is set to share the PPPoE connection with computers connected to Ethernet 2.
- Ethernet 2 is connected to a Buffalo router via the router's LAN port 1.
- A Windows PC is connected to the Buffalo router's LAN port 2.
- The Windows PC is now receiving it's IP address from the MAC.
- I used to be able to connect to the router at 192.168.11.1; now I cannot.


0
darron_chapmanCommented:
sorry... i assumed your downstream computer was a MAC... in order to connect back to your router... you'll need to go into your network settings and change the IP from DHCP to static and assign it the address I gave above... then to get back online you need to switch it back from static to DHCP
0
shachoAuthor Commented:
I'm still a little confused.  I need to change the PC's connection parameters from Obtain IP Address Automatically from DHCP to 192.168.11.2?
0
shachoAuthor Commented:
Is there anyway I can check to see if the router is getting an IP address from the Mac without looking at the router's config screen?
0
darron_chapmanCommented:
only if you need to configure the router... otherwise you should leave it on DHCP... it's kind of a pain, but windows doesn't provide an option to do locations like a MAC does, and you can set up multiple IPs on Windows, but they both have to be manual... another option is to somehow set the range of IPs that the MAC gives out to 192.168.11.xxx ... i don't share with my MAC, so I don't know how exactly that is accomplished ... i can do some research though
0
darron_chapmanCommented:
The router doesn't need to get an IP address from the MAC.
0
shachoAuthor Commented:
OK I think I'm getting closer to understanding.  Are you saying that I need to change my connection parameters when I want to connect to the router, then switch it back to DHCP when I want to connect to the Internet?  Fair enough (if so).  But why can't I connect to the router the way I've been doing it all along, at 192.168.11.1?


0
darron_chapmanCommented:
Let me be a little clearer here.. I hope.  You Mac is connected to the router on the LAN port along with the downstream Windows machine.  The Mac is now a DHCP server, and the router is acting like a switch.  Any computers connected to this router either via the LAN port or the wireless connection will get IP information from the Mac.  The only thing the router is doing now is providing a connection to your Mac, that's all.  It has no need to obtain an IP address from an upstream source, because the router itself is not providing the internet connection, it's just a "go-between" if you will.

The reason why you can't connect to your router the way you have in the past, is because now your downstream computer is no longer on the same subnet as the router.  It's on the same subnet as the Mac.  The way around that is to somehow change the range of IPs that the Mac gives out to match the subnet range of the router.  I'm unsure of the way to do this however.
0
shachoAuthor Commented:
I see.  I just assumed the router would have to be a legitimate node on the network to function.  So by your logic, I should be able to enable wireless on the router and the wirelessly connected NIC should get an address from the Mac - no problems, yes?  While I'm trying this, can you explain why connecting Ethernet 2 to the router's WAN port doesn't work?

Mike

0
darron_chapmanCommented:
Yes, the wireless SHOULD work by pulling an IP from the Mac

Well... I just thought of a way you can connect to your router.  When connected to your router, change your router's LAN IP to 192.168.2.254 with a subnet of 255.255.255.0 ... when you switch back over to DHCP, you will be able to access the router at 192.168.2.254 instead of 192.168.11.1

I can't explain why the WAN port doesn't work... if you had the WAN port set up to use DHCP, then it should have pulled an IP from the Mac... I'm not sure why it didn't
0
shachoAuthor Commented:
Man this is too much.  OK, here's the problem now.  If I disable DHCP on the router, I have no way to connect to it at all.  So I'm dead in the water.  It's a miracle that the wired connection worked out, but now I want to set up wireless - and I can't access the router.  So I have to reset the router again and start over.  
0
shachoAuthor Commented:
Incidentally - when I try to connect the Mac's E2 port to the router's WAN port, the router's log says:

OpenDhcpSocket: can't set initial netmask: Invalid argument

Does this mean anything to you?


0
shachoAuthor Commented:
Ugh.  At this point I'm beyond caring.  I reinitialized the router, turned off DHCP, plugged the PC into the Mac to get a good IP address, rebooted the router, plugged the IP source from the Mac into a router LAN port, and it works.  All of my PCs are connecting to the Internet now with addresses from the Mac.  I can't configure the router, but at this point I don't care to!  Thanks for your help!

Mike

0
shachoAuthor Commented:
...and for your patience!

Cheers,

Mike

0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Apple Hardware

From novice to tech pro — start learning today.