• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 602
  • Last Modified:

Exchange 2003 not processing emails

I am experiencing an issue with Exchange 2003 server whereby it stops delivering emails that have come from outside the organisation to Outlook. When I restart the server, all the emails that were not delivered to Outlook users get processed and delivered.

This is the last event prior to the last time Exchange stopped delivering emails:
Event Type:      Information
Event Source:      MSExchangeTransport
Event Category:      Routing Engine/Service
Event ID:      994
Date:            1/27/2008
Time:            1:26:34 PM
User:            N/A
Computer:      COMPUTERNAME
Description:
Following connector's linkstate is suppressed because it either points to or comes from a leaf RG node. <CN=Default SMTP Connector,CN=Connections,CN=First Routing Group,CN=Routing Groups,CN=First Administrative Group,CN=Administrative Groups,CN=First Organization,CN=Microsoft Exchange,CN=Services,CN=Configuration,DC=DOMAINNAME,DC=local>

For more information, see Help and Support Center at http://go.microsoft.com/fwlink/events.asp.

I posted this problem previously, and the solution was to uninstall Anti-virus as it was not configured properly. After uninstalling it, Exchange worked fine for a few days, but then the same issue started again.
Any clues?
0
mash79
Asked:
mash79
  • 2
  • 2
1 Solution
 
JimboEfxCommented:
That message is not unexpected in a single server org with logging turned up (which i presume you did following your issues).

Troubleshooting Assistant
http://www.microsoft.com/technet/support/ee/transform.aspx?ProdName=Exchange&ProdVer=6.5.6940.0&EvtID=994&EvtSrc=MSExchangeTransport&LCID=1033

Best Practice Analyzer:
http://www.microsoft.com/downloads/details.aspx?FamilyID=DBAB201F-4BEE-4943-AC22-E2DDBD258DF3&displaylang=en

I would do a number of things here:

Run the troubleshooting assistant above for exchange to see if it gives you a heads up.
Run the best practice analyser for good measure.
Restart individual services to see which run when restarted causes the mail to be processed.
Troubleshoot mail flow

http://technet.microsoft.com/en-us/library/aa996805.aspx
0
 
mash79Author Commented:
Will do.
0
 
ellisbitsCommented:
I too have the same problem with Exchange 2003, where all external emails stop arriving. It started as very intermittent, but is now happening every day - it is unusable! Usually restarting the exchange and sql services gets it going again, but why is it happening - does anyone have some ideas?? All external  mail goes out OK and internal mail OK.
0
 
mash79Author Commented:
Hi

I found the solution to my problem the other day. It was not Exchange 2003, but MailMarshall SMTP. For some reason, its queues were reaching maximum allowed lengths and not processing. The problem has not resurfaced since applying some outstanding patches.

If you have any third party apps sitting on top of Exchange 2003, I would suggest checking them out.

I will leave the question open for another few days incase anyone can help out ellisbits.
0
 
ellisbitsCommented:
My solution has been to replace the firewall box, as our ISP found that emails were being refused/deferred delivery. So far all external emails are flowing in.
0

Featured Post

2018 Annual Membership Survey

Here at Experts Exchange, we strive to give members the best experience. Help us improve the site by taking this survey today! (Bonus: Be entered to win a great tech prize for participating!)

  • 2
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now