Visual Studio 2005 not debugging/build correctly - NO SYMBOLS LOADED (mscorlib.dll)

Hi everyone!

The problem is when I try to debug/release my application I get the following problems (in the code snippet).

This started happening after I tried to build fluorinefx from source. Before that, everything was just working fine, and now no project will build correctly and it keeps giving e NO SYMBOLS LOADED warnings. Now I cant debug and some projects wont run.
Already uninstalled every .net related program (framework, visual studio, etc) and reinstalled (took all f& night doing it) and it still wont work. Already tested even to create a simple, empty,one form, c# windows app and running it gives me the same errors.

PLEASE SOMEONE HELP ME! Im in the middle of a project and nothing works anymore!!!! I have to deliver some content tomorrow and suddenly that vs2005 shit stopped working.

thank you a lot

Juliano

'WebDev.WebServer.EXE' (Managed): Loaded 'C:\Windows\assembly\GAC_32\mscorlib\2.0.0.0__b77a5c561934e089\mscorlib.dll', No symbols loaded.
'WebDev.WebServer.EXE' (Managed): Loaded 'C:\Windows\Microsoft.NET\Framework\v2.0.50727\WebDev.WebServer.EXE', No symbols loaded.
'WebDev.WebServer.EXE' (Managed): Loaded 'C:\Windows\assembly\GAC_32\WebDev.WebHost\8.0.0.0__b03f5f7f11d50a3a\WebDev.WebHost.dll', No symbols loaded.
'WebDev.WebServer.EXE' (Managed): Loaded 'C:\Windows\assembly\GAC_MSIL\System.Windows.Forms\2.0.0.0__b77a5c561934e089\System.Windows.Forms.dll', No symbols loaded.
'WebDev.WebServer.EXE' (Managed): Loaded 'C:\Windows\assembly\GAC_MSIL\System\2.0.0.0__b77a5c561934e089\System.dll', No symbols loaded.
'WebDev.WebServer.EXE' (Managed): Loaded 'C:\Windows\assembly\GAC_MSIL\System.Drawing\2.0.0.0__b03f5f7f11d50a3a\System.Drawing.dll', No symbols loaded.
'WebDev.WebServer.EXE' (Managed): Loaded 'C:\Windows\assembly\GAC_32\System.Web\2.0.0.0__b03f5f7f11d50a3a\System.Web.dll', No symbols loaded.
'WebDev.WebServer.EXE' (Managed): Loaded 'C:\Windows\assembly\GAC_MSIL\System.Configuration\2.0.0.0__b03f5f7f11d50a3a\System.Configuration.dll', No symbols loaded.
'WebDev.WebServer.EXE' (Managed): Loaded 'C:\Windows\assembly\GAC_MSIL\System.Xml\2.0.0.0__b77a5c561934e089\System.Xml.dll', No symbols loaded.
'WebDev.WebServer.EXE' (Managed): Loaded 'C:\Windows\assembly\GAC_MSIL\System.Web.RegularExpressions\2.0.0.0__b03f5f7f11d50a3a\System.Web.RegularExpressions.dll', No symbols loaded.
'WebDev.WebServer.EXE' (Managed): Loaded 'C:\Windows\assembly\GAC_MSIL\Microsoft.JScript\8.0.0.0__b03f5f7f11d50a3a\Microsoft.JScript.dll', No symbols loaded.
'WebDev.WebServer.EXE' (Managed): Loaded 'C:\Windows\assembly\GAC_32\VJSharpCodeProvider\2.0.0.0__b03f5f7f11d50a3a\VJSharpCodeProvider.dll', No symbols loaded.
'WebDev.WebServer.EXE' (Managed): Loaded 'C:\Windows\assembly\GAC_MSIL\CppCodeProvider\8.0.0.0__b03f5f7f11d50a3a\CppCodeProvider.dll', No symbols loaded.
'WebDev.WebServer.EXE' (Managed): Loaded 'C:\Windows\assembly\GAC_MSIL\System.Web.Mobile\2.0.0.0__b03f5f7f11d50a3a\System.Web.Mobile.dll', No symbols loaded.
'WebDev.WebServer.EXE' (Managed): Loaded 'C:\Windows\assembly\GAC_MSIL\System.ServiceModel\3.0.0.0__b77a5c561934e089\System.ServiceModel.dll', No symbols loaded.
'WebDev.WebServer.EXE' (Managed): Loaded 'C:\Windows\assembly\GAC_MSIL\SMDiagnostics\3.0.0.0__b77a5c561934e089\SMDiagnostics.dll', No symbols loaded.
'WebDev.WebServer.EXE' (Managed): Loaded 'C:\Users\Juliano\AppData\Local\Temp\Temporary ASP.NET Files\website\a08e2ad9\10bace9e\assembly\dl3\600c270e\00b0ba97_e94ec801\FluorineFx.DLL', No symbols loaded.
'WebDev.WebServer.EXE' (Managed): Loaded 'C:\Users\Juliano\AppData\Local\Temp\Temporary ASP.NET Files\website\a08e2ad9\10bace9e\assembly\dl3\c9810b06\00beb281_ec53c601\log4net.DLL', No symbols loaded.
'WebDev.WebServer.EXE' (Managed): Loaded 'C:\Windows\assembly\GAC_32\System.Data\2.0.0.0__b77a5c561934e089\System.Data.dll', No symbols loaded.
'WebDev.WebServer.EXE' (Managed): Loaded 'C:\Users\Juliano\AppData\Local\Temp\Temporary ASP.NET Files\website\a08e2ad9\10bace9e\assembly\dl3\19c992c5\00b0ba97_e94ec801\FluorineFx.Hosting.DLL', No symbols loaded.
'WebDev.WebServer.EXE' (Managed): Loaded 'C:\Users\Juliano\AppData\Local\Temp\Temporary ASP.NET Files\website\a08e2ad9\10bace9e\assembly\dl3\187ef4d4\00ddeb98_e94ec801\FluorineFx.ServiceBrowser.DLL', No symbols loaded.
'WebDev.WebServer.EXE' (Managed): Loaded 'C:\Users\Juliano\AppData\Local\Temp\Temporary ASP.NET Files\website\a08e2ad9\10bace9e\assembly\dl3\78337063\00763171_90f1c701\ICSharpCode.SharpZipLib.DLL', No symbols loaded.
'WebDev.WebServer.EXE' (Managed): Loaded 'C:\Users\Juliano\AppData\Local\Temp\Temporary ASP.NET Files\website\a08e2ad9\10bace9e\assembly\dl3\437adea6\0036185a_b8e4c701\MySql.Data.DLL', No symbols loaded.
'WebDev.WebServer.EXE' (Managed): Loaded 'C:\Users\Juliano\AppData\Local\Temp\Temporary ASP.NET Files\website\a08e2ad9\10bace9e\assembly\dl3\b3c1e95b\43ab2841_e560c801\ServiceLibrary.DLL', Symbols loaded.
'WebDev.WebServer.EXE' (Managed): Loaded 'C:\Windows\assembly\GAC_MSIL\System.Web.Services\2.0.0.0__b03f5f7f11d50a3a\System.Web.Services.dll', No symbols loaded.
'WebDev.WebServer.EXE' (Managed): Loaded 'C:\Windows\assembly\GAC_32\System.EnterpriseServices\2.0.0.0__b03f5f7f11d50a3a\System.EnterpriseServices.dll', No symbols loaded.
'WebDev.WebServer.EXE' (Managed): Loaded 'C:\Windows\assembly\GAC_MSIL\System.Runtime.Serialization\3.0.0.0__b77a5c561934e089\System.Runtime.Serialization.dll', No symbols loaded.
'WebDev.WebServer.EXE' (Managed): Loaded 'C:\Windows\assembly\GAC_MSIL\System.IdentityModel\3.0.0.0__b77a5c561934e089\System.IdentityModel.dll', No symbols loaded.
'WebDev.WebServer.EXE' (Managed): Loaded 'A_61b3177b_7e23_4df0_86da_b2830878201f', No symbols loaded.
'WebDev.WebServer.EXE' (Managed): Loaded 'M_61b3177b_7e23_4df0_86da_b2830878201f', No symbols loaded.
'WebDev.WebServer.EXE' (Managed): Loaded 'C:\Users\Juliano\AppData\Local\Temp\Temporary ASP.NET Files\website\a08e2ad9\10bace9e\App_Web_nsnawjnr.dll', Symbols loaded.
A first chance exception of type 'System.Threading.ThreadAbortException' occurred in mscorlib.dll
'WebDev.WebServer.EXE' (Managed): Loaded 'C:\vsprojects\FXRemoting\WebSite\bin\FluorineFx.ServiceBrowser.dll', No symbols loaded.
'WebDev.WebServer.EXE' (Managed): Loaded 'saqd2arx', No symbols loaded.
'WebDev.WebServer.EXE' (Managed): Loaded 'C:\vsprojects\FXRemoting\WebSite\bin\FluorineFx.ServiceBrowser.dll', No symbols loaded.
'WebDev.WebServer.EXE' (Managed): Loaded 'i6l0azwj', No symbols loaded.
'WebDev.WebServer.EXE' (Managed): Loaded 'C:\vsprojects\FXRemoting\WebSite\bin\FluorineFx.ServiceBrowser.dll', No symbols loaded.
'WebDev.WebServer.EXE' (Managed): Loaded 'l_orj1hf', No symbols loaded.
'WebDev.WebServer.EXE' (Managed): Loaded 'C:\vsprojects\FXRemoting\WebSite\bin\FluorineFx.ServiceBrowser.dll', No symbols loaded.
'WebDev.WebServer.EXE' (Managed): Loaded 'lq8ncnuq', No symbols loaded.
'WebDev.WebServer.EXE' (Managed): Loaded 'C:\vsprojects\FXRemoting\WebSite\bin\FluorineFx.ServiceBrowser.dll', No symbols loaded.
'WebDev.WebServer.EXE' (Managed): Loaded 'tbgqoekm', No symbols loaded.
The thread  has exited with code 0 (0x0).
The program '[5804] iexplore.exe: Script program' has exited with code 0 (0x0).
The program '[2332] WebDev.WebServer.EXE: Managed' has exited with code 0 (0x0).

Open in new window

LVL 17
julianopolitoAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Evan CutlerVolunteer Chief Information OfficerCommented:
Is this a web solution?
I understadn the output,
What was in the error list?
0
julianopolitoAuthor Commented:
No errors in the solution. This is a web solution. I'm using fluorineFX to create remoting app with flex. But those errors are appearing for every project now.
Already followed instructions below:
http://www.codeproject.com/KB/debug/symbols.aspx?print=true

Now it loads symbols (very very slow) and nothing is like before. Output is this in the code snippet.

I need to know not only how to fix the problem itself, but how to make things work as before.

'WebDev.WebServer.EXE' (Managed): Loaded 'C:\Windows\assembly\GAC_32\mscorlib\2.0.0.0__b77a5c561934e089\mscorlib.dll', Symbols loaded.
'WebDev.WebServer.EXE' (Managed): Loaded 'C:\Windows\Microsoft.NET\Framework\v2.0.50727\WebDev.WebServer.EXE', Symbols loaded.
'WebDev.WebServer.EXE' (Managed): Loaded 'C:\Windows\assembly\GAC_32\WebDev.WebHost\8.0.0.0__b03f5f7f11d50a3a\WebDev.WebHost.dll', Symbols loaded.
'WebDev.WebServer.EXE' (Managed): Loaded 'C:\Windows\assembly\GAC_MSIL\System.Windows.Forms\2.0.0.0__b77a5c561934e089\System.Windows.Forms.dll', Symbols loaded.
'WebDev.WebServer.EXE' (Managed): Loaded 'C:\Windows\assembly\GAC_MSIL\System\2.0.0.0__b77a5c561934e089\System.dll', Symbols loaded.
'WebDev.WebServer.EXE' (Managed): Loaded 'C:\Windows\assembly\GAC_MSIL\System.Drawing\2.0.0.0__b03f5f7f11d50a3a\System.Drawing.dll', Symbols loaded.
'WebDev.WebServer.EXE' (Managed): Loaded 'C:\Windows\assembly\GAC_32\System.Web\2.0.0.0__b03f5f7f11d50a3a\System.Web.dll', Symbols loaded.
'WebDev.WebServer.EXE' (Managed): Loaded 'C:\Windows\assembly\GAC_MSIL\System.Configuration\2.0.0.0__b03f5f7f11d50a3a\System.Configuration.dll', Symbols loaded.
'WebDev.WebServer.EXE' (Managed): Loaded 'C:\Windows\assembly\GAC_MSIL\System.Xml\2.0.0.0__b77a5c561934e089\System.Xml.dll', Symbols loaded.
'WebDev.WebServer.EXE' (Managed): Loaded 'C:\Windows\assembly\GAC_MSIL\Microsoft.JScript\8.0.0.0__b03f5f7f11d50a3a\Microsoft.JScript.dll', Symbols loaded.
'WebDev.WebServer.EXE' (Managed): Loaded 'C:\Windows\assembly\GAC_32\VJSharpCodeProvider\2.0.0.0__b03f5f7f11d50a3a\VJSharpCodeProvider.dll', Symbols loaded.
'WebDev.WebServer.EXE' (Managed): Loaded 'C:\Windows\assembly\GAC_MSIL\CppCodeProvider\8.0.0.0__b03f5f7f11d50a3a\CppCodeProvider.dll', Symbols loaded.
'WebDev.WebServer.EXE' (Managed): Loaded 'C:\Windows\assembly\GAC_MSIL\System.Web.Mobile\2.0.0.0__b03f5f7f11d50a3a\System.Web.Mobile.dll', Symbols loaded.
'WebDev.WebServer.EXE' (Managed): Loaded 'C:\Windows\assembly\GAC_MSIL\System.ServiceModel\3.0.0.0__b77a5c561934e089\System.ServiceModel.dll', Symbols loaded.
'WebDev.WebServer.EXE' (Managed): Loaded 'C:\Users\Juliano\AppData\Local\Temp\Temporary ASP.NET Files\website\a08e2ad9\10bace9e\assembly\dl3\600c270e\00b0ba97_e94ec801\FluorineFx.DLL', No symbols loaded.
'WebDev.WebServer.EXE' (Managed): Loaded 'C:\Users\Juliano\AppData\Local\Temp\Temporary ASP.NET Files\website\a08e2ad9\10bace9e\assembly\dl3\c9810b06\00beb281_ec53c601\log4net.DLL', No symbols loaded.
'WebDev.WebServer.EXE' (Managed): Loaded 'C:\Windows\assembly\GAC_32\System.Data\2.0.0.0__b77a5c561934e089\System.Data.dll', Symbols loaded.
'WebDev.WebServer.EXE' (Managed): Loaded 'C:\Users\Juliano\AppData\Local\Temp\Temporary ASP.NET Files\website\a08e2ad9\10bace9e\assembly\dl3\19c992c5\00b0ba97_e94ec801\FluorineFx.Hosting.DLL', No symbols loaded.
'WebDev.WebServer.EXE' (Managed): Loaded 'C:\Users\Juliano\AppData\Local\Temp\Temporary ASP.NET Files\website\a08e2ad9\10bace9e\assembly\dl3\187ef4d4\00ddeb98_e94ec801\FluorineFx.ServiceBrowser.DLL', No symbols loaded.
'WebDev.WebServer.EXE' (Managed): Loaded 'C:\Users\Juliano\AppData\Local\Temp\Temporary ASP.NET Files\website\a08e2ad9\10bace9e\assembly\dl3\78337063\00763171_90f1c701\ICSharpCode.SharpZipLib.DLL', No symbols loaded.
'WebDev.WebServer.EXE' (Managed): Loaded 'C:\Users\Juliano\AppData\Local\Temp\Temporary ASP.NET Files\website\a08e2ad9\10bace9e\assembly\dl3\437adea6\0036185a_b8e4c701\MySql.Data.DLL', No symbols loaded.
'WebDev.WebServer.EXE' (Managed): Loaded 'C:\Users\Juliano\AppData\Local\Temp\Temporary ASP.NET Files\website\a08e2ad9\10bace9e\assembly\dl3\b3c1e95b\43ab2841_e560c801\ServiceLibrary.DLL', Symbols loaded.
'WebDev.WebServer.EXE' (Managed): Loaded 'C:\Windows\assembly\GAC_MSIL\System.Web.RegularExpressions\2.0.0.0__b03f5f7f11d50a3a\System.Web.RegularExpressions.dll', Symbols loaded.
'WebDev.WebServer.EXE' (Managed): Loaded 'C:\Windows\assembly\GAC_MSIL\SMDiagnostics\3.0.0.0__b77a5c561934e089\SMDiagnostics.dll', Symbols loaded.
'WebDev.WebServer.EXE' (Managed): Loaded 'C:\Users\Juliano\AppData\Local\Temp\Temporary ASP.NET Files\website\a08e2ad9\10bace9e\App_Web_nsnawjnr.dll', Symbols loaded.
A first chance exception of type 'System.Threading.ThreadAbortException' occurred in mscorlib.dll

Open in new window

0
Evan CutlerVolunteer Chief Information OfficerCommented:
Appears you lost some GAC references...

First thing to try:
1. Make sure you have <compilation debug="true"> in web.config and try again.

Second thing:
try running dotnetfx.exe
It's the redistributable for net 2.0.
It usually resets GAC Links.

Here's the link:  
http://www.microsoft.com/downloads/details.aspx?FamilyID=0856EACB-4362-4B0D-8EDD-AAB15C5E04F5&displaylang=en

Don't forget to backup your projects first.  Don't want you to lose your work.
0
Microsoft Azure 2017

Azure has a changed a lot since it was originally introduce by adding new services and features. Do you know everything you need to about Azure? This course will teach you about the Azure App Service, monitoring and application insights, DevOps, and Team Services.

julianopolitoAuthor Commented:
Tried that, but it says it is already installed on my system. Is there a way to force reinstall?
0
Evan CutlerVolunteer Chief Information OfficerCommented:
yeah, go to control panel, remove it, reboot, then install it.
0
Evan CutlerVolunteer Chief Information OfficerCommented:
your removing .net framework 2.0
0
julianopolitoAuthor Commented:
.net framework is not showing in the control panel. i'm using vista. I'm uninstalling .net framework 2.0 sdk , but .net framework I can't find how to uninstall.
0
Evan CutlerVolunteer Chief Information OfficerCommented:
ok.  try this...

Repairing .NET Framework 2.0/3.0 files on Windows Vista

You can use the following steps to repair the files that are a part of Windows Vista Media Center:

Click on the Start menu, choose All Programs, then Accessories, then right-click on the Command Prompt item and select Run as administrator
Click Continue to authorize opening a command prompt with administrative privileges
Run this command in the cmd prompt: sfc /scannow
The cmd prompt should list text stating "Beginning system scan. This process will take some time."
Wait for the scan to complete (this can take several minutes so be patient)
When the scan completes, the SFC tool will indicate whether or not it found any integrity violations and offer you the chance to fix any that are found
Repairing .NET Framework 2.0/3.0 registry entries on Windows Vista

Unfortunately, there is not an easy way of repairing the registry keys/values that are installed by Windows Vista like there is for files.  If you want to try to repair the registry keys/values that are a part of the .NET Framework 2.0 and 3.0, you will need to run Windows Vista OS setup again and repair the OS.

0
julianopolitoAuthor Commented:
Repairing OS is something really drastic. If I need to do this, as I already considered I'll make a fresh clean install from scratch. But the problem it will take a day, wich I don't have. But I'll wait for some more solutions to see if anyone figures it out. (don't know if there is a solution, it is microsoft, but)
0
Evan CutlerVolunteer Chief Information OfficerCommented:
ok.  found one more thing.

Try this.
http://support.microsoft.com/default.aspx/kb/837224
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
julianopolitoAuthor Commented:
Beginning verification phase of system scan.
Verification 98% complete.Windows Resource Protection found corrupt files but wa
s unable to fix some of them.
Details are included in the CBS.Log windir\Logs\CBS\CBS.log. For example
C:\Windows\Logs\CBS\CBS.log

I'm attaching the last part of the log (I cut it because the log was 50 mb long, so now it has 2.7 mb)
I don't know if it says something useful, but here it goes.

Anyway it did not work, vista could not repair some items. But repaired some, I do not know what happened exactly, what to do now?Is formatting the only option? (since repairing windows is not a option to me, cause I do not believe windows can repair itself)
CBS.log
0
Evan CutlerVolunteer Chief Information OfficerCommented:
ok, was that from :sfc /scannow
or from : ngen Mscorlib.dll
?
0
julianopolitoAuthor Commented:
from sfc /scannow (i wrote that in the description for the attachment ;) )
Tried ngen mscorlib.dll, it said the dll was registered. But As I had already installed the microsoft symbol server, I don't know if it worked
0
julianopolitoAuthor Commented:
Hi everybody! Thank you all. I have done lots of things. Visual Studio has been reinstalled again, I've installed microsoft symbol server, and lots of other stuff. It's a bit slow now compiling or even responding in debug mode but it is working.
Also I discovered that part of the "problem" I was worried about was not a problem at all.
So in my case  think that what resolved was reinstalling. The output will always ask for the .pdb files, and not finding some of them is pretty normal since some libraries are comercial and do not come with one. So after reinstalling for the second time, brekpoint were up and running again.

Thank you all.
0
julianopolitoAuthor Commented:
the solution was not this one, but arcee123 helped me with trying to find where it was. Also I did not found a real solution, just reinstalled everything
0
Evan CutlerVolunteer Chief Information OfficerCommented:
Sorry, I couldn't help.
I was just shooting at stars this point.

Evan
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
.NET Programming

From novice to tech pro — start learning today.