using mac address to recieve a static address from pix ip pool

Hi All,

I have a pix 501 which is giving out dhcp address to the inside interface, vpn client connections and outside interface is also getting a dhcp address from ISP. My setup is 1 - 3 pcs on the inside interface which are using wireless, these are connect to a netgear wireless access point which sends the request on to the pix for a IP address. I would like 1 pc to receive a static IP based on the pc mac address.
The question is HOW, do i need to set up another iplocal pool. not sure. My config looks like this

: Saved
: Written by enable_15 at 19:14:32.443 UTC Tue Jan 12 1993
PIX Version 6.3(5)
interface ethernet0 auto
interface ethernet1 100full
nameif ethernet0 outside security0
nameif ethernet1 inside security100
enable password **** encrypted
passwd ******* encrypted
hostname 501
domain-name jimbo
fixup protocol dns maximum-length 512
fixup protocol ftp 21
fixup protocol h323 h225 1720
fixup protocol h323 ras 1718-1719
fixup protocol http 80
fixup protocol rsh 514
fixup protocol rtsp 554
fixup protocol sip 5060
fixup protocol sip udp 5060
fixup protocol skinny 2000
fixup protocol smtp 25
fixup protocol sqlnet 1521
fixup protocol tftp 69
names
name 192.168.1.0 lan-hugh
access-list intovpn permit ip lan-hugh 255.255.255.0 192.168.12.0 255.255.255.0
pager lines 50
logging on
logging timestamp
logging monitor debugging
logging trap debugging
logging queue 0
logging host inside 192.168.1.3
mtu outside 1500
mtu inside 1500
ip address outside dhcp setroute
ip address inside 192.168.1.1 255.255.255.0
ip audit info action alarm
ip audit attack action alarm
ip local pool ippool 192.168.12.0
pdm logging informational 100
pdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 0 access-list intovpn
nat (inside) 1 0.0.0.0 0.0.0.0 0 0
timeout xlate 0:05:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h225 1:00:00
timeout h323 0:05:00 mgcp 0:05:00 sip 0:30:00 sip_media 0:02:00
timeout sip-disconnect 0:02:00 sip-invite 0:03:00
timeout uauth 0:05:00 absolute
aaa-server TACACS+ protocol tacacs+
aaa-server TACACS+ max-failed-attempts 3
aaa-server TACACS+ deadtime 10
aaa-server RADIUS protocol radius
aaa-server RADIUS max-failed-attempts 3
aaa-server RADIUS deadtime 10
aaa-server LOCAL protocol local
aaa authentication ssh console LOCAL
http server enable
http lan-hugh 255.255.255.0 inside
snmp-server location Germany
snmp-server contact Hugh walsh
snmp-server community walsh
no snmp-server enable traps
tftp-server inside 192.168.1.14 tftp-root
floodguard enable
sysopt connection permit-ipsec
crypto ipsec transform-set myset esp-des esp-md5-hmac
crypto ipsec transform-set sota esp-aes-256 esp-sha-hmac
crypto map myvpn 20 ipsec-isakmp dynamic dynmap
crypto map myvpn interface outside
isakmp enable outside
isakmp identity address
isakmp nat-traversal 20
isakmp policy 20 authentication pre-share
isakmp policy 20 encryption des
isakmp policy 20 hash md5
isakmp policy 20 group 2
isakmp policy 20 lifetime 14400
isakmp policy 50 authentication pre-share
isakmp policy 50 encryption aes-256
isakmp policy 50 hash sha
isakmp policy 50 group 5
isakmp policy 50 lifetime 14400
vpngroup vpn5011 address-pool ippool
vpngroup vpn5011 split-tunnel intovpn
vpngroup vpn5011 idle-time 1800
vpngroup vpn5011 password ******
telnet timeout 5
ssh xxx.xxx.xxx.xxx 255.255.255.240 outside
ssh lan-hugh 255.255.255.0 inside
ssh timeout 15
management-access inside
console timeout 0
dhcpd address 192.168.1.4-192.168.1.15 inside
dhcpd lease 3600
dhcpd ping_timeout 750
dhcpd domain Walsh
dhcpd auto_config outside
dhcpd enable inside
username hugh password ***************** encrypted privilege 15
terminal width 80
Cryptochecksum:bf33323b552321435b1bb3a69feadcd8
: end

So DHCP for clients inide is : dhcpd address 192.168.1.4-192.168.1.15 inside

example : mac xx:xx:xx:xx:xx fixed ip 192.168.1.8

(if this is possible is it also possible that clients dialing in could also recieve a static address)
LVL 1
HuwaAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

batry_boyCommented:
DCHP clients on the inside will not be able to receive a static IP address based on its MAC address.  The 6.x code that runs on the PIX 501 doesn't support this.

However, there is a workaround for VPN users.  You can define a local pool for the VPN users that consists of only one IP address, then associate that pool with a specific VPN group and then give that VPN group out to individual users.  For example:

ip local pool vpnpool 192.168.12.1-192.168.12.1 netmask 255.255.255.0
vpngroup user1 address-pool vpnpool
vpngroup user1 split-tunnel intovpn
vpngroup user1 idle-time 1800
vpngroup user1 password ******

You would then configure a certain VPN user's VPN profile to user the group name "user1" and they would receive 192.168.12.1 when connected to a VPN session.  You could then have a separate set of commands like below to issue 192.168.12.2 to "user2":

ip local pool vpnpool2 192.168.12.2-192.168.12.2 netmask 255.255.255.0
vpngroup user2 address-pool vpnpool2
vpngroup user2 split-tunnel intovpn
vpngroup user2 idle-time 1800
vpngroup user2 password ******

However, I've never seen or figured out a workaround for assigning static IP's via DHCP from the PIX on the inside or other interfaces.  :(
HuwaAuthor Commented:
Hi Batry,

Thanks for the quick reply, If no one proves different by tomorrow I will accept your answer. Is this possible on a small ASA running 7.x IOS version.
batry_boyCommented:
I just checked through the docs for both 7.2x and 8.0x and it doesn't look like those versions support it either....:(

I've wanted to do this in a few situations and wound up having to use another DHCP server to do it.

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
HuwaAuthor Commented:
Ok Thanks, yeah thats the solution I have set up in work backend windows server. using dhcp reservation. This config is just home config for testing purposes. Pity as i didnt want to set a dhcp server at home :-( anyways thx.
batry_boyCommented:
I feel your pain...I would love to be able to do this as well...c'est la vie...
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Cisco

From novice to tech pro — start learning today.