How to configure Network of RHEL4 on VMWARE 6

Hi,
I have installed Red hat Linux Enterprise 4 on VMWARE 6 succesfully However i cannot connect to internet. I specified my static IP address on Linux as 192.168.1.105 with subnet of 255.255.255.0 and gateway of 192.168.1.1 It was already active on my network configuration and I also restarted the Linux. But after that, still I cannot connect to the internet. I have no Firewall settings and I tried to check IFCONFIG and there were no errors found too. Can somebody help me figure out how can i connect this Linux to the internet?
mchuaAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Pétur Ingi EgilssonSoftware Engineer -- ConsultantCommented:
Shut down the OS in vmware.
Click your RHEL4 in vmware and select CONFIGUR\SETTINGS
change the type of your Network to Bridged
Boot vmware and use DHCP for your network adpater.
0
mchuaAuthor Commented:
Hi PeturIngiEgilsson,
thanks for your comment. I did your recommendation but still i cannot connect to the internet. I even tried the other type of network but unfortunately none of them work. Hope somebody can help me on this. Is there something else i need to configure? Im sorry I'm a newbie on this subject.
0
Pétur Ingi EgilssonSoftware Engineer -- ConsultantCommented:
If your using BRIDGE mode, and your guest os nic is configured to use dhcp please do the following

Dump the output of the command `route`
Dump the output of the command `ifconfig` ( might be `/sbin/ifconfig` )

.. you could also try to use the option "Use network address translation NAT" in vmware
0
The Ultimate Tool Kit for Technolgy Solution Provi

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy for valuable how-to assets including sample agreements, checklists, flowcharts, and more!

set256Commented:
check your dns entries for on your network configuration.  you may have an improper entry.  

When using static ips:

1. ensure that your dns entries are the same as your other or host box that can connect to the internet.
2. make sure that your default gateway is correct

check your network configuration utility for eth0.

one of the ways is to use: /usr/sbin/system-control-network

regards,

seth
0
mchuaAuthor Commented:
Hi,
I tried doing the option "Use network address translation NAT" in vmware but still unsuccessful.
I am not sure how to do the dumping of route thing.

I also used my dns settings same as my host dns. and when I issue ifconfig there seems to be no error.
However i still cannot connect to the internet.

do i have to check something on my host file? I have inserted the ip address of my guest OS to my hosts file like this:
192.168.1.105      localhost

anything i missed?

0
mchuaAuthor Commented:
Hi,
I tried editting my network config and issue ifconfig on terminal displaying the results as:

[root@rac1 ~]# ifconfig
eth0      Link encap:Ethernet  HWaddr 00:0C:29:18:FC:77
          inet addr:192.168.1.131  Bcast:192.168.1.255  Mask:255.255.255.0
          inet6 addr: fe80::20c:29ff:fe18:fc77/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:1 errors:0 dropped:0 overruns:0 frame:0
          TX packets:105 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:60 (60.0 b)  TX bytes:4578 (4.4 KiB)
          Interrupt:10 Base address:0x2024

eth1      Link encap:Ethernet  HWaddr 00:0C:29:18:FC:81
          inet addr:10.10.10.31  Bcast:10.10.10.255  Mask:255.255.255.0
          inet6 addr: fe80::20c:29ff:fe18:fc81/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:9 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 b)  TX bytes:546 (546.0 b)
          Interrupt:9 Base address:0x20a4

lo        Link encap:Local Loopback
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:1890 errors:0 dropped:0 overruns:0 frame:0
          TX packets:1890 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:2321943 (2.2 MiB)  TX bytes:2321943 (2.2 MiB)


Do you guys see anything not normal? I have to be honest I cannot interpret the results as above. Can someone help?
0
Pétur Ingi EgilssonSoftware Engineer -- ConsultantCommented:
do i have to check something on my host file? I have inserted the ip address of my guest OS to my hosts file like this:
192.168.1.105      localhost

This should be
127.0.0.1 localhost

type "route" and it will give out the routing table
0
mchuaAuthor Commented:
Hi,

Here is the contents of my hosts file:

127.0.0.1       localhost
192.168.1.131   rac1.mycorp.com rac1
192.168.1.31    rac1-vip.mycorp.com     rac1-vip
10.10.10.31     rac1-priv.mycorp.com    rac1-priv
192.168.1.132   rac2.mycorp.com rac2
192.168.1.32    rac2-vip.mycorp.com     rac2-vip
10.10.10.32     rac2-priv.mycorp.com    rac2-priv

Ive been using virtual IP(vip) for my Oracle RAC configuration and im using eth0 and eth1 network device.


When I checked route here is the results:

[root@rac1 etc]# route
Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
192.168.1.0     *               255.255.255.0   U     0      0        0 eth0
10.10.10.0      *               255.255.255.0   U     0      0        0 eth1
169.254.0.0     *               255.255.0.0     U     0      0        0 eth1
default         192.168.1.1     0.0.0.0         UG    0      0        0 eth0


Anything wrong?  I dont know how to interpret the results I hope someone can tell me if the results are good or not and what to be taken to access my internet from the guest OS.
0
set256Commented:
mchua,

can you ping 192.168.1.1? if this is your router...

if not then ...
is there a possibility that your host firewall might be preventing it from getting out? if so, shut it down temporarily and see if this is part of  the issue.

regards,

seth
0
mchuaAuthor Commented:
Hi Set256,

Here is the result of my ping :
[root@rac1 ~]# ping 192.168.1.1
PING 192.168.1.1 (192.168.1.1) 56(84) bytes of data.
From 192.168.1.131 icmp_seq=0 Destination Host Unreachable
From 192.168.1.131 icmp_seq=1 Destination Host Unreachable
From 192.168.1.131 icmp_seq=2 Destination Host Unreachable

--- 192.168.1.1 ping statistics ---
5 packets transmitted, 0 received, +3 errors, 100% packet loss, time 4014ms
, pipe 4
[root@rac1 ~]# ping 192.168.1.132
PING 192.168.1.132 (192.168.1.132) 56(84) bytes of data.
64 bytes from 192.168.1.132: icmp_seq=0 ttl=64 time=9.84 ms
64 bytes from 192.168.1.132: icmp_seq=1 ttl=64 time=0.548 ms
64 bytes from 192.168.1.132: icmp_seq=2 ttl=64 time=0.413 ms

--- 192.168.1.132 ping statistics ---
3 packets transmitted, 3 received, 0% packet loss, time 2006ms
rtt min/avg/max/mdev = 0.413/3.602/9.845/4.414 ms, pipe 2
[root@rac1 ~]# ping localhost
PING localhost (127.0.0.1) 56(84) bytes of data.
64 bytes from localhost (127.0.0.1): icmp_seq=0 ttl=64 time=0.688 ms
64 bytes from localhost (127.0.0.1): icmp_seq=1 ttl=64 time=0.091 ms
64 bytes from localhost (127.0.0.1): icmp_seq=2 ttl=64 time=0.207 ms

--- localhost ping statistics ---
3 packets transmitted, 3 received, 0% packet loss, time 2001ms
rtt min/avg/max/mdev = 0.091/0.328/0.688/0.259 ms, pipe 2
[root@rac1 ~]#


I removed my firewall and ping the gateway but the result is unreachable.
I tried to ping the other guest OS with IP of 192.168.1.132 and that is reachable.
Doing the ping in guest OS bothways is reachable. I ping the Local host and as expected it is reachable.

Since  I cannot ping my gateway this seems to block me to access the internet.
Any Idea why i can't access my gateway?  I am using Bridged as network settings to my guest OS in VMware.
0
set256Commented:
mchua,

sorry about the delay; try adding another virtual adapter, set it to bridged, and when the system comes back up and detects the card,  configure  it to dhcp.  then see if you can ping your router - if it is not set to block icmp.

lets see if that works...

regards,

seth
0
set256Commented:
mchua,

any luck?

regards,

seth
0
mchuaAuthor Commented:
Hi set256,

I'm sorry for my late reply. I did  your suggestion but still no luck.
Now I had 3 ethernet the third one was the DHCP one  but i was not succesful to connect thru internet.
I appreciate ur assistance.
0
set256Commented:
mchua,

Sorry about the lengthy delay,

I was able to replicate a similar problem to this.  It took a little bit of trying but I finally had "success".  Then it took me almost as long to fix.  I simply:
1. Removed a virtual adapter
2. Started up the vm.
3. Removed the configuration.  
4. Shut down the system and added the card back.
5.  Brought the system  back up configured the card.

 I did this with ALL of the adapters individually and finally got connected. As long as your virtual networks are for the most part unchanged, this may work for you.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Linux

From novice to tech pro — start learning today.