Can't print test page locally to network printers, new server

I have recently setup a Dell PowerEdge 2900 with W2K3R2 SBS Prem Server (fully patched) at a small office.  They currently use a Win 98 machine as their print server for 2 network printers, which works fine.  I am having trouble getting anything to print from the new server to the current network printers and the new 4240n we just added.  This is the story so far:

Setup:

- Basic network = 192.168.1.0  /24  (i know, but the network addressing could not change)
- Added networked HP 4240n printer as local printer on the server with Standard TCP/IP port, using latest drivers from HP
- 'Add Printer' Wizard detects an HP Jet Direct NIC on the other end (ie. the HP 4240n)
- I am able to ping the static IP of the printer (192.168.1.200) and verified the subnet mask is correct

Issue:

- When I try to print a test page from the server itself it fails immediately and says "The test page failed to printer. Would you like to open printer troubleshooter?
- Try to print from Notepad = "Handle is Invalid" Error
- Try to print from WordPad = No error, but nothing happens, no job sent to printer queue
- No errors in the Event Log

What I Have Done:

- Went through printer troubleshooter just in case
- Print spooler has been restarted multiple times
- Server has been rebooted
- Different drivers installed, including HP Universal Drivers
- Tried multiple other driver variations with no success

I am having the same issue with the two other printers as well, a HP 5Si and a HP LaserJet 4 so it seems to be something affecting the printing subsystem on the server although I do not know what.  Their current print server (Win 98 machine) has no issues so it's not the printers themselves.  The install of the OS was uneventful and there are no other indications of problems beyond printing.  I have setup multiple servers to act as print servers and have never come across this issue before.  I have only been on site once to begin the initial server setup so I have not had a chance to connect a printer directly to a USB port which is my next step.  I need to resolve this ASAP as the customer has software teams ready to go for the next stage of their software install so any help is appreciated.  Thanks.

-Brian
LVL 4
jsbushAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

lamaslanyCommented:
I'd try the Spooler Cleaner (cleanspl.exe) from the Windows Server 2003 Resource Kit Tools (http://www.microsoft.com/downloads/details.aspx?FamilyID=9D467A69-57FF-4AE7-96EE-B18C4790CFFD&displaylang=en).

This should clear out any corrupt/incorrect drivers, printers, printer drivers and jobs.


0
lamaslanyCommented:
PS:  Personally I'd steer clear of the Universal Print Drivers as these have caused me nothing but trouble.  That said I've not tried them for about a year so they may have improved... I'm just not prepared to risk it yet!
0
kevo04Commented:
Can you remotely hit the new HP printer via a web browser?  In the address bar of IE or Mozilla, type the IP of the printer, just the IP.  You should see a web browser type interface.

If you can then you know you have connectivity.  If no connectivity, I would try a laptop with a static IP and a crossover cable or another PC just to narrow the problem either to the server or not.  So maybe on another PC in the network add the printer like you would on the server using TCP/IP and then see what happens.  If the PC can print then we can troubleshoot the server, if the PC cannot print then we have a printer problem.

Let me know
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
jsbushAuthor Commented:
Thanks for all your input.  I have this issue resolved but it was very bizarre.  I could ping HP 4240n but I count not get to the web admin portion of it.  I printed a configuration page and it showed the IP address for the printer being 0.0.0.0, but if you enter the configuration menus on the printer it showed up correctly as 192.168.1.200.  However, the HP was showing as valid IP address on the network ie. I could ping it and there was nothing else on the network that could have had the same IP address.  Another power cycle of the printer brought everything back to normal in regards to the HP 4240n.

As for the underlying issue I simply had to remove the printers I had created on the server, delete all their drivers then restart the print spooler service.  After that I was able to add printers and print test pages successfully.  I must have been looking at it for too long since I tried everything except going back to square one. Thanks for the quick responses, I will hand out points shortly.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Printers and Scanners

From novice to tech pro — start learning today.