How do I create the Free/Busy folders?

I was having some problems with my Public Folders so I deleted the database and recreated it. Now I need to create the Free/Busy folders that go in the database. How can I do this?
dustinwkAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

dmorrisroeCommented:
this is your only Exchange server, right?  There was no migration to Exchange 2007?

Take a look at this link, http://blog.stealthpuppy.com/exchange/exchange-server-2007-and-public-folder-replicas and try the cmdlets mentioned.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
dustinwkAuthor Commented:
Yes it is the only one. There was no migration.
0
dmorrisroeCommented:
and you're still using outlook 2003 or earlier?  If your using Outlook 2007 there is no need to worry about the free/busy folder as Exchange 2007 now has the Exchange Availability Service, which polls the Mailboxes in realtime for the free/busy info (with no need to rely on a Public Folder)
0
Problems using Powershell and Active Directory?

Managing Active Directory does not always have to be complicated.  If you are spending more time trying instead of doing, then it's time to look at something else. For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why

dustinwkAuthor Commented:
Yes in fact most users still have 2003 only a hand full of users use 2007.
0
dmorrisroeCommented:
try creating one appointment in the calendar for everyone, seemed to work here:
http://www.experts-exchange.com/Software/Server_Software/Email_Servers/Exchange/Q_22716885.html
0
dustinwkAuthor Commented:
I have tried sending an appointment and acepting it but this has not helped. Also I have been trying the commands from your first post but I keep getting an error.

________
Command
________
[PS] C:\Documents and Settings\dustinwkadmin>Set-PublicFolder -Identity "\NON_IP
M_SUBTREE\SCHEDULE+ FREE BUSY\EX:/o=MOG/ou=First Administrative Group" -Replicas
 "exchange\Public Folder Database"

_____
Result
_____
Set-PublicFolder : There is no existing PublicFolder that matches the following
 Identity: '\NON_IPM_SUBTREE\SCHEDULE+ FREE BUSY\EX:/o=MOG/ou=First Administrat
ive Group'. Please make sure that you specified the correct PublicFolder Identi
ty and that you have the necessary permissions to view PublicFolder.
At line:1 char:17
+ Set-PublicFolder  <<<< -Identity "\NON_IPM_SUBTREE\SCHEDULE+ FREE BUSY\EX:/o=
MOG/ou=First Administrative Group" -Replicas "exchange\Public Folder Database"

_______
Comand
_______
[PS] C:\Documents and Settings\dustinwkadmin>Set-PublicFolder -Identity "\NON_IP
M_SUBTREE\SCHEDULE+ FREE BUSY\EX:/o=Exchange Administrative Group (FYDIBOHF23SPD
LT)" -Replicas "exchange\Public Folder Database"


_____
Result
_____
Set-PublicFolder : There is no existing PublicFolder that matches the following
 Identity: '\NON_IPM_SUBTREE\SCHEDULE+ FREE BUSY\EX:/o=Exchange Administrative
Group (FYDIBOHF23SPDLT)'. Please make sure that you specified the correct Publi
cFolder Identity and that you have the necessary permissions to view PublicFold
er.
At line:1 char:17
+ Set-PublicFolder  <<<< -Identity "\NON_IPM_SUBTREE\SCHEDULE+ FREE BUSY\EX:/o=
Exchange Administrative Group (FYDIBOHF23SPDLT)" -Replicas "exchange\Public Fol
der Database"

0
dmorrisroeCommented:
is SP1 installed for Exchange 2007?
0
dustinwkAuthor Commented:
Maby I am putting the comand in wrong this is what I get from the first one that lists
----------
Comand
----------
[PS] C:\Documents and Settings\dustinwkadmin>Get-PublicFolder -server exchange "\non_ipm_subtre
e\schedule+ free busy" -recurse | Format-list

--------
Result
--------
AgeLimit                       :
EntryId                        : 000000001A447390AA6611CD9BC800AA002FC45A030053C9466E154AD8479
                                 7DFBDC96DB3C6BD0000000000040000
HasSubFolders                  : True
HiddenFromAddressListsEnabled  : False
LocalReplicaAgeLimit           :
MailEnabled                    : False
MaxItemSize                    :
Name                           : SCHEDULE+ FREE BUSY
ParentPath                     : \NON_IPM_SUBTREE
PerUserReadStateEnabled        : True
PostStorageQuota               :
Replicas                       : {}
ReplicationSchedule            : {}
RetainDeletedItemsFor          :
StorageQuota                   :
UseDatabaseAgeDefaults         : True
UseDatabaseQuotaDefaults       : True
UseDatabaseReplicationSchedule : True
UseDatabaseRetentionDefaults   : True
Identity                       : \NON_IPM_SUBTREE\SCHEDULE+ FREE BUSY
IsValid                        : True
OriginatingServer              : exchange.disney.local

AgeLimit                       : 100.00:00:00
EntryId                        : 000000001A447390AA6611CD9BC800AA002FC45A0300451674AB104B4981A
                                 1793B98176CDD930000000000070000
HasSubFolders                  : False
HiddenFromAddressListsEnabled  : True
LocalReplicaAgeLimit           :
MailEnabled                    : False
MaxItemSize                    :
Name                           : EX:/o=MOG/ou=Exchange Administrative Group (FYDIBOHF23SPDLT)
ParentPath                     : \NON_IPM_SUBTREE\SCHEDULE+ FREE BUSY
PerUserReadStateEnabled        : True
PostStorageQuota               :
Replicas                       : {Public Folder Database}
ReplicationSchedule            : {}
RetainDeletedItemsFor          :
StorageQuota                   :
UseDatabaseAgeDefaults         : False
UseDatabaseQuotaDefaults       : True
UseDatabaseReplicationSchedule : True
UseDatabaseRetentionDefaults   : True
Identity                       : \NON_IPM_SUBTREE\SCHEDULE+ FREE BUSY\EX:/o=MOG/ou=Exchange Ad
                                 ministrative Group (FYDIBOHF23SPDLT)
IsValid                        : True
OriginatingServer              : exchange.disney.local
0
dustinwkAuthor Commented:
yes it is
0
dmorrisroeCommented:
well, it's getting kind of late for me.  You mentioned that you might have put the first line in wrong, which might be the case.

Your original:
Set-PublicFolder -Identity "\NON_IPM_SUBTREE\SCHEDULE+ FREE BUSY\EX:/o=MOG/ou=First Administrative Group" -Replicas
 "exchange\Public Folder Database"

I think the First Administrative Group might be the problem.  Exchange 2007 has Public folders in the Second Administrative Group by default.  

I know this one also mentions migration so I'm not sure how much applies to you...
http://support.microsoft.com/kb/945602

set-publicfolder -Identity "\NON_IPM_SUBTREE\SCHEDULE+ FREE BUSY\EX:/o=ORG NAME/ou=Legacy Administrative Group" -replicas "Server\Second Storage Group\Public Folder Database"
Note This command syntax assumes that the Exchange Server 2007 public folder database is in the default location under the second storage group.

I'll check back tomorrow, maybe someone else will chime in if they have had a similar issue.  Good luck!
0
dustinwkAuthor Commented:
Having a bit of a problem now that is more important than this but probably related. After deleting the database and recreating it, any accounts that were previously set up work. But any that were set up to use Outlook Anywhere Prompt for a username and password even from within the office. In addition to this I cannot setup new users. This applies to 2003 and 2007 Outlook. When I try to set up a new profile. I get the following error

---------------------------
Microsoft Office Outlook
---------------------------
The action cannot be completed.  The connection to Microsoft Exchange is unavailable. Outlook must be online or connected to complete this action.
---------------------------
OK  
---------------------------
0
dmorrisroeCommented:
Do you have a GC setup?
0
dustinwkAuthor Commented:
Ok that was scarry but there bust have been a service that stoped because i rebooted the Exchange server and now that problem is gone.  Idont know which service it was though or why it would have stoped.
0
dustinwkAuthor Commented:
Well I seem to have Free/Busy info available for most people now but I am still having problems in the event log about not being able to publish Free/busy info. Im going to just ignore this and upgrade everyone to Outlook 2007 and remove my public folders.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Exchange

From novice to tech pro — start learning today.