How to find/install "unidentified"driver? Causes BSOD unless I allow the OS to check every boot. Loop!

How to install after identifying an "unidentified " driver. Vista Premium.
PC will boot to OS, then I get the nag to install the driver, which doesn't happen as I don't know what the device is to get that driver. If I disable that "undentified" drive rin Device Mgr., then on re-boot I get the BSOD.
If I choose to not see the driver search pop-up, I get the same BSOD.
The error code is: 0x81000101, which I searched but that doesn't tell me which device I need to get a driver for.
So, the process to get a stable boot to OS now if I get a BSOD: is
to choose Last Known Good Config., gets a boot to OS, then that demand to find an unidentified driver (failure procedure).
I think the uunidentified driver may have relationship with Acronis True Image Recovery Process. I created a safe partition to boot from if no boot to OS. That partition is a FAT32; my OS is NTFS.
This is just a theory to my "intermediate knowledge level small" brain.

The issues started after I install a new printer driver, but I deleted that & now have no printer.

I tried Sys. Restore, but that didn't help.

I don't want to perform a clean install.

I will hire a tech. support but the cost is $95.00 per hr.
I'd like to fix this myself.
Thanks,
Jim
LVL 1
jamesg1940Asked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

scrathcyboyCommented:
you need to get rid of this boot problem.  Boot to safe mode, and remove the driver using device manager and find the driver for the device that is in question and remove it.  Note what it says, under which category in device manager.  Now try to find a driver file on reboot, and feed it a CD or disk or something with the most likely hardware drivers -- or download from system MFG. -- you just need to get beyond this problem.
0
scrathcyboyCommented:
Also, uninstall all acronis software and all printer drivers.  Then reboot.  If the problem perisists, and iIf you are game, set a restore point, at this time, and then run regedit.exe from start, run --

search for acronis and delete all entires related to it, but nothing else.  Then search for the printer you had added, and find its name, and delete any entries related to it.  DO NOT delete anything else from the REG.

Now reboot.  Is it stable???
0
ded9Commented:
Hi,

Install windows debugging tools and click file--> open crash dump files and go to windows --> minidump folder and open the log and check which driver is creating the problem.


http://www.microsoft.com/whdc/devtools/debugging/installx86.mspx



Ded9
0
Cloud Class® Course: CompTIA Cloud+

The CompTIA Cloud+ Basic training course will teach you about cloud concepts and models, data storage, networking, and network infrastructure.

nobusCommented:
Try this :
Start-Programs-Accessories-System Tools-System Information.
Click on "components" and highlight "problem devices".
Any hardware device with a driver problem will be listed here.
Make a note of the first line of the entry. It will contain a Vendor number and a Device number (VEN. . . . DEV. . . .) both four digits long.
Look up those numbers here:   http://www.pcidatabase.com/index.php

This will tell you the manufacturer and the chip number.  Check the manufacturer's website first
0
jamesg1940Author Commented:
Hello:
Here are the steps I've attempted to correct the issue of the OS request at boot into the desktop:
"install driver for unidentified device". I haven't tried to run that check for a driver, as it has resulted in no find, plus results in that "unidentified" drive to be listed in Device Maganger. I've both disabled that entry & have uninstalled that entry, with the result in a BSOD (0X0000007B  0XC000000E 0X00000000).

1. Ran debugging tools: no entry in mini-dump.

2.Checked Sys. Info. Error Reports: saw quite a few errors, but do not know what they indicate so cannot repair if necessary. Reads mostly in "Fault Bucket".
Checked "Problem Devices" & see no entry.

3.Ran "Clean MyPC Registry Cleaner" & deleted 4 minor issues; re-booted to same situation as reported.

4. Checked for all/any Printer entries: device + Programs & nothing there; then searched PC for same & nothing entry. Obviously, Printer is not connected to PC.

5.  Ran "Driver Detective" Program & note no new entries to either update nor drivers not installed.

6. Unchecked all Acronis T.I. startup entires * re-booted to same issue as reported.
I have not un-installed Acronis because I have not been able to create a Sys. Restore Point!!!
Get an error message of timed out can't perform. Tried to create a restore point in Safe mode with not able to do so.
This issue concerns me. I won't un-install Acronis until I have the ability to perform a restore function.

7. Tried to run a Windows Memory Test (both from Safe Mode & from normal OS desktop) and from CD-ROM Boot Manager!!!, but got message:
"\boot\memtest.exe 0XC000225 application is missing or corrupt".

8. Ran a complete AVG anti-virus scan with zero faults.

9. Ran Chkdsk (complete! takes forever) with no errors.

10. Checked BIOS re. CPU & RAM set to default. See all devices are recognized.

CONCLUSION:

PC does boot to desktop with that annoying request to install driver(s) (2).
Too many error reports.

Have tried Sys. Restore via OS install disk, but that didn't correct the "unidentified" driver issue.
So, even a clean install might result in that same un-indentified driver issue?

What I could do is try to attach files that will assist you. I'm not great about that, but know I can do it,
with lot's of effort.

I'll remain patient re. seeking your advice, but eventually I'll have to accept costly local tech. support & mark this E-E query as not "solved". What I'd then do after a repair is report back as to what was done to correct.

Thank u for your continued support.
Jim aka Vineyaedtechie
0
scrathcyboyCommented:
"So, even a clean install might result in that same un-indentified driver issue?"

and probably will, since vista driver support is bad in some places right now.

Remember, though that every driver is registered with the system.  I wold edit them out of the registry until you find the conflicting one.  Try this, but set a restore point first before you edit the registry --

start, run regedit.exe -- when in regedit, do F3 search for -- RunOnce -- at least in the XP registry, the key -- Run -- is just above it.  That is where all the system drivers load on start up.  Go through the list carefully, trying to identify which one is the most likely culprit, based on what you installed when it happened.

Before you delete that entry, right click on it, and copy that key's information, then paste it into Notepad and save.  Then delete that registry entry.  Close regedit, and reboot.  If you have enough patience, and do this one at a time, probably starting at the bottom of the RUN list, you will find and remove the problem
0
jamesg1940Author Commented:
Scrathcyboy,
I checked out those gazillion files. Too arcane for me. Maybe I'm not an "intermediate" re. what E-E defines as such level. Maybe a Newbie.
So, I'm not going to pursue that procedure, as too dangerous with my limited understanding.

I installed Windows Installer Clean-up.exe & saw no Program re. Printers, so that is good.
I'm thinking about un-installing & re-installing Acronis, but that is allot of work, as I'm to go into hidden files & delete all, etc. after the usual deleted from Control Ctr./Programs.

I'm going to call my Local Pro Tech. friend for his $upport.
I'll get back to you all, but he may not take this on right off.

Thanks,
Jim
0
scrathcyboyCommented:
removing acronis is only 1 minute's work, then remove the entire acronis directory under program files, that is less than 1 minute's work.  I think acronis is likely to be the problem -- the low level disk drivers are simply not compatible with vista.  I will wait for a response from the uninstall, and then have to go.
0
jamesg1940Author Commented:
Scrathcyboy:
I un-installed Acronis: from Control Panel, then to Win. Installer Cleanup (found no files there), then to %temp% didn't find any obvious files, re-boot; then installed Acronis.
Now what happens: I lost a part of Acronis (try & decide a virtual Program). I did see that previous restore points were there, but that may have to do with the Acronis Save Management Program, which is a safe Partition on C drive to boot from F11.
So maybe I didn't do the 100% un-install.

Anyway, those two "un-identified" drivers still pop-up to be installed at boot to OS. I just click see later.
Not much fun in that. LOL

BTW: System Restore still does not create a restore point; I set that service to "auto" from "manual" to no different effect.

Looks like I should consult my local Pro.
I've done most of the suggestions posted on this issue plus more.
I'll get back to you all later.
I'm trying to not re-install the OS, as I'd have to burn all sorts of files to re-install, but then I maybe able to restore from the F drive which contains the Acronis Image; I'd just pick & choose files.
Thanks,
Jim
0
scrathcyboyCommented:
"BTW: System Restore still does not create a restore point;"

That is because Acronis is trying to take control of the system restore over windows (a huge mistake) and the version you have is not working right with Vista.  Why did you immediately reinstall Acronis???  The idea was to get RID of it, and let windows do its normal backup.  Until you eliminate Acronis from the system completely, you will not know how to fix the problem.  This is all your local "PRO" will do.  Most of us here have more experience than local "pros".  I can't help further, because you are not doing what I suggest to remove the problem programs and all their drivers so you can get the system back to normal.  Good luck.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
jamesg1940Author Commented:
Scrathcyboy:
I'm sorry if I upset you.

I did try to enable/set a Win. Sys. Restore Point, but it didn't work: same reason- timed out as corrupt

This WAS BEFORE re-installing Acronis. I did want to see if Acronis was interfering with the Vista Sys. Restore. I have to have a backup/restore feature; or I face a required clean install.

BTW: Win. Sys.Restore did work WITH Acronis before these problems started. So you are incorrect that these two Backup/Restore Programs are not compatible in Vista. I liked the fact that Sys. Restore was faster, than the Acronis Restore. As you know Acronis re-installs all those files like email, etc. that Sys. Restore does not!; thus the lengthy restore.

As to totally removing Acronis, I did attempt that. In fact, after the re-install, I again looked for temp. files for Acronis & couldn't identify them.

When I searched %temp% for Acronis; no (Acronis) files came up after I had performed the un-install.

My Pro tech friend usually  performs acorrective processes, but he also encourages a bi-annual clean install. I did that once & noticed he was right, that the System speeded up by about 25%,
but it was a huge investment of time. I think he has a procedure he uses to speed up his re-install; I think other than a full backup, as that would just re-install the same problems.
Unfortunately, he does not like to tutor me, as he operates at warp speed.

Back to you later.
We'll all see what the problem is, as I won't do a clean install until the present issues are known.
But I'm open for more suggestions from E-E, as I don't think my tech. guy is coming right over. LOL
Thanks,

Jim

0
jamesg1940Author Commented:
Experts:
I forgot to say:
I will award Points for the suggestions that prove to resolve the issues I listed.
Even if applied locally by paid tech. support.
So,if you are right then you get the whole 500 pts.

I'm a paid Member, who is in no need to "horde" points.
I usually reward almost all commentators, as all deserve appreciation (except for no-brainers).
Jim
0
jamesg1940Author Commented:
It's hard to remember every detail; I'll try to write each process I do).

I wanted to also verify that:
I did un-install Acronis, then I re-booted to OS.
Those pop-up for install drivers did appear, so Acronis is
UNRELATED
to the "un-indentified driver" issue.. Then as I said, I tried Win. Sys Restore, etc.

Only question is whether I totally un-installled Acronis; I did more than most Users do.
I don't think the driver issue is related to Acronis.
We'll see about that.
Jim
0
jamesg1940Author Commented:
Hello Experts,
Thank u for your assistance.
I performed a "clean Install",
which obviously corrected all of the mentioned issues re. my question.

Since no one took the "easy way out" answer to do the re-install,
I know that I did all the work on this.
I did have the confidence of a free offer from my tech. friend to assits  if
it didn't go well.

I'll assign points, but have to assign a "grade C" as
none of the probelms were corrected due to the suggestions.
I assign points in this case as I wish to continue to support & do not
want to be "Black Listed" as on who begs for your time, but then
does his own process irregardless of suggestions.

It should have been obvious after I listed all the processes I tried to run,
that this POS was too corrupted to go further on wasting all
of our time/efforts.

Thanks & please offer to assit me in the future,
Jim


0
jamesg1940Author Commented:
Sorry, but...
0
scrathcyboyCommented:
We always try here on EE to AVOID the "clean install" at all costs, it wipes out a person's data, and it is not really a solution to the problem -- just a last resort.  Sorry you had to do it.
0
jamesg1940Author Commented:
Thanks for your understanding. That's why I appreciated your effort. I think tech. support has gotten away from the 2 minute advice to re-install on whatever the schematic didn't show the route to take.

My tech. friend told me he was having a hard time not laughing out loud when he visited a tech. support site & the staff were "parroting" the schematic" to the client: result no one even got to first base.
Of course, not all tech. support is created equal.

My clean install has gone totally well as I have backup on all I desire.
Cost was zero $.
Jim
0
davemicklewoodCommented:
I had this problem at a customers house recently (The exact same thing) and this is how i fixed it!!! It worked 100%

Firslty i Uninstalled Acronis and removed all the registry entries assosiating to acronis through safe mode.

after this i rebooted back into Windows However this still did not repair the problem with an Unknown driver. However i am convinced that this driver is assosiated to acronis.

Anyhow to get rid of this driver problem i did this:::

Step 1: Hit Win+f { Hold Windows Key and simultaneously press f} and
click on Advanced Search.

Step 2: In "Locations" Select the drive where Vista is installed and
remember to tick mark the "Include non-indexed, hidden, and system files
(might be slow" check box.

Step 3: In the highlighted search box, type "volume*.*" [Obviously,
without the quotes] and wait for the search to get completed. Then
select that file which resides in
"C:\Windows\System32\DriverStore\FileRepositor y". It is highlighted
here:

Btw, If you cant see the folder column, right click on "Name" and u'll
be able to select the Folder option from a menu.

Step 4: Once u have located the volume.inf file, copy it and paste it
in "C:\Windows\Inf" folder.

Step 5: Now close everything and come back to desktop. Click on start
and type cmd in the Start search box BUT do not click on it or press
enter. Instead, right click it and select run as administrator. The
Window of Command prompt MUST read "Administrator: Command Prompt".

Step 6: Now type:

set devmgr_show_nonpresent_devices=1

and press enter. Now in that same window type:

devmgmt.msc

and press enter. Device manager should now open. Now click on View menu
and click on show hidden devices menu.

Step 7: Expand the storage volumes entry and u should find ur Unknown
disk in disabled state. right click it and uninstall it. After
uninstalling, restart the PC and voila! The system finds
the drivers! Generic Volume drivers willl be installed

NOTE: For any reason Whatso ever, if Windows Still asks for drivers,
Select "I wanna search and locate drivers myself" and specify ur Vista
installation drive. That should do the trick!.

No more BSOD and system stable.

System Restore works 100%

Credit to Dragor for his help with this!
0
jamesg1940Author Commented:
Dear Davemicklewood:
Thank u for taking the time to clearly delineate your solution to this issue.
I have added it to my knowledge base of E-E, to access from another PC if this issue should occur again
on my primary PC.
I think the clean install is an OK option IF DATA BACKUPS HAVE BEEN CREATED on either CD-ROM or another drive. I found a Czech Program that saves the profiles of Firefox & Thunderbird to very easily restore such data on the new install OS Mozilla Programs.
That was a big concern of mine as previously, I had to spend many hours trying to re-create such files. My other pics, .docs were accessed from burned CD, etc.
Re. Acronis: the above issue of corrupted "unidentified driver" resulted in my re-installing Acronis so that the new feature of "test it on virtual mode" would work. The re-install of Acronis wasn't well done it seems.
I have now re-installed Acronis on the clean install, BUT I still am not able to use that "virtual" Program,
& you guessed it: I will not be un-installing & re-installing Acronis. The through procedure to do so is quite a lengthy process & still may not be done correctly. For $35. Acronis Support will take on the issue, but if they screw up I doubt they will assist in other than Acronis issues.

Best to you,
Jim
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows Vista

From novice to tech pro — start learning today.