We help IT Professionals succeed at work.

Windows SBS 2003 Server Error in '/Remote' Application

Cannot access Remote Web Work place. Company website is fine, so is Outlook Web Access. This is the erroe I receive:

Server Error in '/Remote' Application.
--------------------------------------------------------------------------------

Runtime Error
Description: An application error occurred on the server. The current custom error settings for this application prevent the details of the application error from being viewed.

Details: To enable the details of this specific error message to be viewable on the local server machine, please create a <customErrors> tag within a "web.config" configuration file located in the root directory of the current web application. This <customErrors> tag should then have its "mode" attribute set to "RemoteOnly". To enable the details to be viewable on remote machines, please set "mode" to "Off".


<!-- Web.Config Configuration File -->

<configuration>
    <system.web>
        <customErrors mode="RemoteOnly"/>
    </system.web>
</configuration>
 

Notes: The current error page you are seeing can be replaced by a custom error page by modifying the "defaultRedirect" attribute of the application's <customErrors> configuration tag to point to a custom error page URL.


<!-- Web.Config Configuration File -->

<configuration>
    <system.web>
        <customErrors mode="On" defaultRedirect="mycustompage.htm"/>
    </system.web>
</configuration>
Comment
Watch Question

Try the following and lets e3e if it slves your problem:

Run ICW again, don't change any settings.  (Does it work)
Make a backup of your IIS metabase and rebuild the IIS virtual directories.

Pierre
Over and above running the Internet Cobnnection Wizard (To Do List> point 2) you need to run the remote access wizard again. (To Do List>point 3).
You also need ports 4125 and 444 open on your router.
Please let us know if you need help with the wizards.
Hope that helps
Olaf

Author

Commented:
If I Run ICW and Remote Access Wizard, is it going to change anything with Exchange 2003, OWA or Remote Access?
No as long as you don't change any of the settings, will keep your current settings and re-configure them.  A question, I take it you cannot access /Remote externally as well as internally?  In otherwords does \\servername\remote work?

Author

Commented:
I cannot access through share point (i believe its called) internally or externally, I can access the Server and clients with RDC (does that answaer your question).
Ok I think I understand you, Share Point points to the link your company's internal website, this should by default not be available externally, however Remote Web Workplace (RWW - /Remote) and Outlook Web Access (OWA - /Exchange) should be.  Try following the above steps and check the outcome; if it still does not work we can take a closer look, but running the ICW usually resolves a lot of the issues around RWW and OWA.

Commented:
I am having the same problem.

I have already re-reun CEICW and remote access wizards. /exchange and company/default.aspx work great.

OWA works externally and //companyweb works fine internally.

RWW gives the same error externally or even on the SBS itself.

All ports are open and forwarded correctly on the router.

Please advise =)

Commented:
Hello...a bit more insight =)

Configuration Error
Description: An error occurred during the processing of a configuration file required to service this request. Please review the specific error details below and modify your configuration file appropriately.

Parser Error Message: Unrecognized attribute 'processRequestInApplicationTrust'.

Source Error:


Line 70:       </namespaces>
Line 71:     </pages>
Line 72:     <trust level="WSS_Minimal" originUrl="" processRequestInApplicationTrust="false" />
Line 73:     <machineKey validationKey="972BADBBED4409BCDDE53E9AD85A485BF41FCD16FC18E8E4" decryptionKey="11CBE7C60EB0707F8A4583B349ED33E73C93A478B9F685C6" validation="SHA1" />
Line 74:   </system.web>
 

Source File: c:\inetpub\wwwroot\web.config    Line: 72



...Yep.
Can you please check the following:
User trying to access RWW need to be part of the "mobile users"
From inside the network use/ try: https://your server IP address or servername/remote and see if that works.
If it works from inside than you must have something wrong with the certificate. Create a new one using your external IP address just for testing reasons. Also rerun the Remote access wizard.
Please let us know when you have tried alll of this.
Regards
Olaf
There must be an error about this in the eventlog. Can you please check?
Olaf

Commented:
olafdc,


https://servername or IP/remote does not work internally. Either from administrator or mobile user templated accounts.

I have re-run CEICW as posted before, still receiving the same error.


Parser Error Message: Unrecognized attribute 'processRequestInApplicationTrust'.


Commented:
Have I commandeered someones post?

Commented:
I'm having the exact same issue.  Has there been any movement on this problem?

Commented:
Hello,

I think I solved my issue here by running... well, various things, but I believe what did it for me was to make sure that /remote has all the correct home directory, directory security, ASP.net settings in IIS.

I did an IIS reset as well, but first you could look at /remote under the default website in IIS and make sure it is all sound.
PAQed with points refunded (500)

Computer101
EE Admin

Explore More ContentExplore courses, solutions, and other research materials related to this topic.