After upgrading ios from 6.3 to 7.0 i am not able to receive email on exchange from outside

Recetly i have upgraded my cisco PIX ios to 7.0 but i got one problem now i can't receive any email on exchnage server from outside . Please help me it's urgent
dat5904Asked:
Who is Participating?
 
stuknhawaiiConnect With a Mentor Commented:
try the following:
no access-list smtp_in extended permit tcp any host MailServer2 eq smtp
access-list smtp_in extended permit tcp any host 201.201.201.201 eq smtp
Because currently your ACL is allowing access to MailServer2 (which I suppose is the 192.168.1.5).

also I see the "access-group smtp in interface outside"
shouldn't that be:
access-group smtp_in in interface outside
0
 
stuknhawaiiCommented:
CHeck to make sure you still have a rule allowing SMTP inbound. Also check for your static NAT statement (if you were using one). If you post a sanitized config I can take a look at it.
0
 
dat5904Author Commented:
This is access list and NAT config and my mail server IP address is 192.168.1.5


access-list 101 extended permit ip 192.168.1.0 255.255.255.0 192.168.100.0 255.2
55.255.0
access-list outside_access_in extended deny ip any any
access-list 80 extended permit ip any 192.168.1.0 255.255.255.0
access-list smtp extended permit tcp any host 201.201.201.201 eq smtp
access-list smtp_in extended permit tcp any host MailServer2 eq smtp

nat-control
global (outside) 1 interface
nat (inside) 0 access-list 101
nat (inside) 1 0.0.0.0 0.0.0.0
static (inside,outside) tcp 201.201.201.201 smtp MailServer2 smtp netmask 255.255
.255.255
access-group smtp in interface outside
0
SMB Security Just Got a Layer Stronger

WatchGuard acquires Percipient Networks to extend protection to the DNS layer, further increasing the value of Total Security Suite.  Learn more about what this means for you and how you can improve your security with WatchGuard today!

 
rsivanandanCommented:
Is esmtp inspection disabled? If not try disabling it.

Yet having the problem, then post the config.

Cheers,
Rajesh
0
 
dat5904Author Commented:
Now problem is solved one of the my freind suggest me solution

Could you please issue the following commands:
  no static (inside,outside) tcp <public_ip> smtp MailServer2 smtp
 netmask 255.255.255.255
  static (inside,outside) tcp interface smtp MailServer2 smtp netmask
 255.255.255.255

If you're using the interface IP address on static NAT entry, you're
 required to use the "interface" keyword instead of the IP address (as you
 can see in the command reference:
http://www.cisco.com/en/US/docs/security/asa/asa70/command/reference/s.html#wp1540284)
"Note You must use the interface keyword instead of specifying the
 actual IP address when you want to include the IP address of an interface
 in a static PAT entry."
0
 
rsivanandanCommented:
:-) that is the reason I asked to post the config. Not just there, you need to make changes to the acl as well;

Your acl should read as below;

access-list smtp_in extended permit tcp any host interface outside eq smtp


Cheers,
Rajesh
0
All Courses

From novice to tech pro — start learning today.