How do I get my Sony HDR-SR5 camcorder to talk with Vista Ultimate?

I recently bought a HDR-SR5 camera, and have been struggling to get it to talk via USB to my desktop computer...

It has no problems whatsoever connecting to my laptop, which runs Vista Home Premium, with all the latest windows updates.

However, if I try and connect it to my desktop running Vista Ultimate, it tries to install drivers, one of which is for what is described as "unknown device". It fails to automatically find a driver for this, and that's the end of that. This Vista Ultimate desktop also has all the latest windows updates.

I've checked the Sony website, and the best I can find is that Vista should automatically recognise my camera, and have all the drivers already installed.

I thought perhaps it had been caused by me maybe not doing things right the first time I connected the camera, so I did a system restore to a few restore points before the day I got the camera, and tried installing it again. Still no luck.

Can anybody please tell me how to make Vista Ultimate talk to my camera?
JimR123bAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

f-kingIT support technicianCommented:
Hi
so you didnt have to install any software for home premium?
Is the ultimate version 32bit or 64bit?
0
f-kingIT support technicianCommented:
This is what Sony has to say about connection errors;
0
f-kingIT support technicianCommented:
sorry forgot to post

The drivers required to connect most Sony® cameras and camcorders to a computer are built in to the Microsoft® Windows® XP and Microsoft® Windows Vista" operating systems. Using the drivers provided with the operating system will provide the basic functionality necessary to transfer files stored on the camera to the computer.

In some rare instances, the camera or camcorder may not be recognized by the computer when connected. In this instance, it may be necessary to download the driver for your model camera or camcorder from the Software/Drivers section on the Sony® eSupport Web site at http://esupport.sony.com.

IMPORTANT: Some functions specific to the camera or camcorder may not be available unless the original software bundle that came with your camera or camcorder is installed on the computer.

but since there are no drivers available from Sony you must have a hardware or software problem.

If your system is 64 bit then it wont work according to sony "Starter and 64-bit versions of the Windows Vista and Windows XP operating systems are not supported. "
0
INTRODUCING: WatchGuard's New MFA Solution

WatchGuard is proud to announce the launch of AuthPoint, a powerful, yet simple, Cloud-based MFA service designed to eliminate the vulnerabilities that put your data, systems, and users at risk.

JimR123bAuthor Commented:
32-bit Vista Ultimate.

Vista Home Premium did not require installation of any software, at least not from a CD. When it "found new hardware", it found all the necessary drivers for itself (from Windows Update, I think).

On the Sony eSupport web site, there are "no files currently posted for your model"...

http://esupport.sony.com/US/perl/swu-list.pl?mdl=HDRSR5

Sony do not seem to provide any drivers at all, only the software to get data from the camcorder after Windows automatically detects and installs its own drivers for it.
0
f-kingIT support technicianCommented:
remove all usb devices from device manager and then reboot so windows can reinstall them, then replug the device.

http://kb.wisc.edu/helpdesk/page.php?id=5183
0
JimR123bAuthor Commented:
How do I know which of the items in device manager are USB devices? Are they all under "Universal Serial Bus controllers"?

My keyboard and mouse are USB too. Do I have to uninstall them too?
0
f-kingIT support technicianCommented:
remove everything from "Universal Serial Bus controllers"?
windows will reinstall everything again, make sure the camera is not plugged in.
0
JimR123bAuthor Commented:
I have uninstalled all my USB devices, turned the computer off, unplugged all my USB devices (including hubs) so that nothing whatsoever is plugged into a USB port.

I then start the computer, and after started, plug in my camcorder directly using the USB cable (and not via a USB hub).

Exactly the same problem as before, Vista tries to install drivers, but is unable to find the files.
0
f-kingIT support technicianCommented:
and windows reinstalled all the other drivers correctly that you removed
0
JimR123bAuthor Commented:
Yes, as far as I can tell. All the USB devices that I now have plugged in are working correctly, it would seem.
0
JimR123bAuthor Commented:
...apart from the camcorder!
0
JimR123bAuthor Commented:
Can anybody help me?

I've raised the points to 500...
0
f-kingIT support technicianCommented:
It could be a software program thats conflicting with the installation.
Remove all the startup programs using Msconfig;
http://www.netsquirrel.com/msconfig/msconfig_vista.html
and then try again.

0
f-kingIT support technicianCommented:
some people have found a workaround by clicking on the unknown device in device manager then run update driver and manualy pointed it to c:\windows\system32  .

http://forums.microsoft.com/MSDN/ShowPost.aspx?PostID=1286482&SiteID=1

0
JimR123bAuthor Commented:
I have already tried manually pointing to various locations for driver, including c:\windows\system32. Have also tried C:\ and all subfolders, and it can't find a driver anywhere on my hard-disk, or any of the CDs that came with the camcorder.

Have tried removing all other running programs that might be interferring with the installation. I've tried...

- Removing all startup programs (using msconfig), rebooting, and connecting camcorder. Exactly the same results, searches for driver, doesn't find driver.

- Removing all startup programs, plus ALL startup services. Rebooted, connected camcorder, nothing happened. Occurred to me that I'd removed the "detect new devices" service.

- Removing all startup programs, plus MOST but not all services. Rebooted, connected camcorder, usual results. Detects connection, searches for driver, doesn't find driver.

It occurred to me that maybe Windows Defender or the Windows Firewall may have been getting in the way, so I also tried a reboot with both of those disabled. Same results, couldn't find driver.

One thing that I've noticed is that the hard-disk of the camcorder (which I'm trying to get to) shows up in the "Disk Management" section of "Computer Management". However, if I try and do anything with it, it comes up with an error something along the lines of "this device is not properly installed" (but not those exacty words).
0
f-kingIT support technicianCommented:
any chance of backing up files and doing a complete reinstall?
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
f-kingIT support technicianCommented:
that way we can rule out if its hardware.
0
JimR123bAuthor Commented:
I'd rather not reinstall Vista, but then it's starting to look like it's the only option!

What concerns me is that I could do a complete re-install of Vista to find that it still doesn't work with Ultimate. I guess I could try putting a new Vista installation on an old hard-disk just to try it.

Still, I'd be interested to hear any more suggestions anybody might have as to how to get my existing Vista installation talking to my camcorder...
0
JimR123bAuthor Commented:
At least I know it's not the camera that's the problem (or so it seems) as it still works on my Home Premium laptop...

What other hardware could be the problem, if any?
0
f-kingIT support technicianCommented:
The usb ports on the motherboard which could mean bad motherboard.
0
JimR123bAuthor Commented:
All the USB ports seem to work fine for all my other devices that I've ever had, and I've tried plugging the camera into every one of them, just in case some are different.

Could there still be a problem with my USB ports or my motherboard?
0
f-kingIT support technicianCommented:
how old is the board?
are you using same usb cable when connecting to laptop?
we wont know if its a hardware problem till we do a format on an old drive.
0
f-kingIT support technicianCommented:
als try downloading latest chipset drivers for your board.
0
JimR123bAuthor Commented:
OK, just swapped the hard-disk for another, and done a new install of Vista Ultimate on it (using the same CD as I used with my problematic installation).

Everything works absolutely fine. The camcorder gets detected and installed, and interestingly, only 2 USB "devices" get installed, unlike with my problematic installation of Ultimate where it tries to install 3 USB devices, with the 3rd being the problem.

It does it really quick too, which may just be because there isn't many files on the hard-disk.

This appears to be doing the exactly the same as when I plugged it into my laptop for the first time, which is promising...

Now I've just got to make my full Vista installation (the one with all my other stuff installed) work the same, or do a full backup (of my 250gb hd) and reinstall Vista, and all the software, and probably get problems with licensing, DRM and so on in the process :(

In answer to your questions...

The board is probably about 3 or 4 years old. The computer is a HP Compaq 7100 SFF. I think that's right.

I did use the same cable as with the laptop, and am sticking to using that same cable as it came with the camcorder.
0
f-kingIT support technicianCommented:
since the format worked its not a hardware problem.
did vista install all the drivers automatically for it or did you download them?
I can t find it on the Compaq site which of these is it, look at the back of the computer for the serial number.
http://h10025.www1.hp.com/ewfrf/wc/pfinder?lc=en&dlc=en&cc=us&query=7100&dest_page=softwareCategory&tool=softwareCategory
0
JimR123bAuthor Commented:
I've decided to bite the bullet and go for a re-install, by moving all my old files into a sub-folder of my hard-disk, and doing a brand new installation of Vista Ultimate.

The camcorder was the first thing that I got working, to make sure it did, and everything else seems to work now too.

I guess maybe something could have got corrupted along the lines, or there was something running which was stopping the camcorder from running, but I couldn't fathom out what the cause of the problem was.

f-king, many thanks for all your attempts to help me...
0
JimR123bAuthor Commented:
Thanks for all your help!
0
f-kingIT support technicianCommented:
glad to help out
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Digital Cameras / Camcorders

From novice to tech pro — start learning today.