2811 router FXS port issue

Scenario:
Router A- PSTN lines terminate on this. FXO ports are available to connect the PSTN lines.
Router B-2811with 2 VIC 4FXS modules installed
Calls are received on router A and forwarded to Router B.
Only 1 line gives a problem when analog phone is connected to the FXS port on router B.
Problems:
1. No diale tone for outgoing calls
2. Analog phone rings but only calling party can hear the called party's voice.
 Called party does not hear naything.

Tried Solution:
There is no issue for other lines with same configuration setup
Debug output shows call being received for the respective dial peer and port configured.
if dial peer is configured on another port of same module , it works.
IsayeedAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

jdechiaroCommented:
sounds like a nat issue. What voip protocol are you running?
0
bfasonCommented:
I know it sounds pretty simple but I ran into this with a 7940 phone and it was the handset on the phone, swapped it with one from another phone and it worked fine.
0
IsayeedAuthor Commented:
I seriously doubt it to be a port issue as the same configuration works when i configure the dial peer to be used with another port of the same FXS module.

I do not have a spare 4FXS VIC to confirm on that though.
I would still like comments on verifying codec issues and physical voice port issues for backing up my reasoning of the problem.

Thanks All
0
Powerful Yet Easy-to-Use Network Monitoring

Identify excessive bandwidth utilization or unexpected application traffic with SolarWinds Bandwidth Analyzer Pack.

bfasonCommented:
have you tried another device on that port?

There is sometimes an issue with cut through on analog devices that can be fixed with the "voice rtp send-recv" but I doubt that is the problem since you would expect it across all ports.
0
IsayeedAuthor Commented:
Reasons why I doubt it to be port issue:

By default FXS ports provide dial tone and in our case it is not doing so.
Also when I configured dial-peer for the problem line to another port it works fine.
There is no issue with device as it is working when used with other ports.
I am going to change Module and check.
0
IsayeedAuthor Commented:
Changing module solved my problem.
Thanks to all for trying to help me.
Isayeed.
0
IsayeedAuthor Commented:
Greetings Experts Admin
I would request you to close this Question.
Thanks.
0
Computer101Commented:
PAQed with points refunded (500)

Computer101
EE Admin
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Network Operations

From novice to tech pro — start learning today.