Cannot Browse Network on Clients (the list of servers for this workgroup is not available)

I have a Domain with a single Windows Server 2003 machine, doing Active Directory, & DHCP, and minimum functions.  (NOTE we do not have a WINS service set up on the server..we only have windows xp clients, so assume that DNS is sufficient)

Work occured whilst I was away, and when i returned I had found to my dismay that a planned upgrade from Windows Server 2000 (browsing network working perfectly) to Windows Server 2003, had occured without migration. The person involved simply created a new server, and copied all profiles on the clients to the "default profile", left the domain, and rejoined, creating a new profile in the process gaining the default profile.

So, despite all of this, everything is working perfectly, apart from the fact that we CANNOT browse the network on any of the clients (we CAN browse the network from the Windows 2003 server). The error thrown is:

Domain is not accessible. You might not have permission to use this network resource. Contact the   administrator of this server to find out if you have access permissions.

The list of servers for this workgroup cannot be found.


-

Now, I have enabled TRUE under the redistry settings for entry IsDomainServer inside HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Browser\Parameters on the Windows 2003 Server.

NetBIOS setting on each client is set to Default - Use NetBIOS setting from the DHCP Server.
Windows Firewall is turned OFF on all clients and on the server.

One thing I want to make very clear. I do NOT consider adding the IPX/SPX protocol to every computer as a solution. It should be able to function with out this.
ArkdogAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

cedarghostCommented:
Look in event viewer on your servers, but I bet you have some errors in there complaining that a certain machine on your network would not allow your server to become the master browser for the network and it may say that an election has been forced. There is a registry string that says IsMasterBrowser. Make sure the value for this is set to Yes on your DC. Here is a link that shows how to do this step by step :
http://www.pctools.com/guides/registry/detail/54/
You may have to delete the computer objects for the clients and rejoin them to the domain. I don't blame you for not wanting to use IPX/SPX...I wouldn't either.
0
DarylxCommented:
Is the DHCP server configured to turn netbios off?  Try manually enabling netbios on a client.
0
ArkdogAuthor Commented:
cedarghost:
If you read my original post I have already enabled that registry entry to be TRUE/YES for the DC.
I wasn't able to locate errors relating to a master browser election, but I may have been looking in the wrong place.

Darylx:
Where in the DHCP server settings would i find whether it has been configured to be turned on/off. I've searched, and I'm not quite sure where that would be.
By "manually enabling netbios on a client" do you mean adding the netbios protocol? Thus meaning adding the IPX/SPX protocol which i do not wish to do?
0
Newly released Acronis True Image 2019

In announcing the release of the 15th Anniversary Edition of Acronis True Image 2019, the company revealed that its artificial intelligence-based anti-ransomware technology – stopped more than 200,000 ransomware attacks on 150,000 customers last year.

ArkdogAuthor Commented:
If you browse the network from the DC (windows server 2003) directly, ALL clients are visible.
0
cedarghostCommented:
I think he means go into the TCP/IP properties hit advanced > WINS tab> enable Netbios over TCP/IP
0
ArkdogAuthor Commented:
ah right, thanks.

...well no, that has been tried and does not work.
0
cedarghostCommented:
Does Event Viewer give you any information on the clients? And have you tried deleting the computer account and re-adding the machine to the domain? Also, even though you can't browse the network, can you access the servers by UNC (\\server\share)?
0
ArkdogAuthor Commented:
I have tried deleting the account & re-joining...no luck.

I CAN access servers and other computers via the UNC path, all the computers are also pingable.
0
ArkdogAuthor Commented:
Net view on any of the clients throws the System error 6118 error

Now there is a plethora of resources on this error and how to fix it. One very interesting result had to do with the DHCPNodeType entry in the hklm\system\currentcontrolset\services\netBT\parameters\dhcpnodetype entry. This seems to have solved the problem for alot of people. However NONE of my clients have this entry in their registry. I will attempt to add the entry to a client today as a test.
0
ArkdogAuthor Commented:
Nope, adding the key as per (http://www.richardcleaver.com/?p=15) did not resolve anything at all, no change to the error.

0
ArkdogAuthor Commented:
The Interesting thing is that when i run browmon.exe, and punch in the domain name, it actually reports that my DC is the registered Master Browser. I had assumed previously that it might be a master browser problem
0
ArkdogAuthor Commented:
hmm but if i right click & properties (in browmon.exe), in order to get the list of servers/pc's i get the same standard error "the list of servers for this workgroup is not currently available"
0
ArkdogAuthor Commented:
I've tried adding a WINS Server...no change
0
TekServerCommented:
This is a long shot, and a pain (and well nigh impossible for larger networks), but I have seen it work before:

Shut down every computer on the network.  Then power on the server first, followed by the workstations.  This will force a new NetBIOS Master Browser election and should ensure that the server wins the election.

Worth a try, if you don't have a bazillion workstations.

:)
0
ArkdogAuthor Commented:
TekServer...I tried it tonight, no use!....

Here is a general summary of state of affairs:

Stats:
1x Windows Server 2003 R2, running Active Directory, DHCP, DNS
20x Clients, all running windows XP
1x NAS (never had a problem with this before under previous windows server 2000 DC)
1x Router Netgear FVS318v3, performing nothing other than the internet connection
All Computers have TCP/IP over netbios enabled.
All Computers have firewall turned off.

"Net view" throws the 6118 error "The list of servers for this workgroup is not currently available".
The Server is able to browse the network fine (all computers visible, and is also able to run "net view" command without error.


Things I've Tried:

1.) Installing a WINS Server - No help
2.) Adjusting the DHCPNodeType & NodeType Entry in HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Netbt\Parameters
 - None of the clients actually have this entry, so I tried adding both entries to one client, selecting 8 (i also tried 1) as the entry (as per http://www.richardcleaver.com/?p=15)...restart, no success.

3.) Tried doing a full winsock reset using winsockXPfix.exe...didn't help
4.) I tried adding IPX/SPX protocol to a client..success it worked...however THIS IS NOT A SOLUTION.
5.) using browmon.exe, reports that the Server IS the masterbrowser.
6.) Created a new user and logged in as that user on a client....no luck
7.) Logged into various clients as the Server Adminstrator....nope
8.) Left the domain on a client & Rejoined the Domain.....no luck
9.) Shutdown every single device on the network. Switched on the server, then switch on clients one by one.


IPconfig /all gives: (XX's for privacy)

Windows IP Configuration

        Host Name . . . . . . . . . . . . : XXXXXX
        Primary Dns Suffix  . . . . . . . : XXMyDomainNameXX.local
        Node Type . . . . . . . . . . . . : Unknown
        IP Routing Enabled. . . . . . . . : No
        WINS Proxy Enabled. . . . . . . . : No
        DNS Suffix Search List. . . . . . : XXMyDomainNameXX.local

Ethernet adapter Wireless Network Connection 6:

        Media State . . . . . . . . . . . : Media disconnected
        Description . . . . . . . . . . . : Intel(R) PRO/Wireless 3945
k Connection
        Physical Address. . . . . . . . . : 00-13-02-31-29-53

Ethernet adapter Local Area Connection 2:

        Connection-specific DNS Suffix  . :
        Description . . . . . . . . . . . : Intel(R) PRO/1000 PL Netwo
ion
        Physical Address. . . . . . . . . : 00-15-58-27-A6-E6
        Dhcp Enabled. . . . . . . . . . . : Yes
        Autoconfiguration Enabled . . . . : Yes
        IP Address. . . . . . . . . . . . : 192.168.1.51
        Subnet Mask . . . . . . . . . . . : 255.255.255.0
        Default Gateway . . . . . . . . . : 192.168.1.1
        DHCP Server . . . . . . . . . . . : 192.168.1.204
        DNS Servers . . . . . . . . . . . : 192.168.1.205
        Lease Obtained. . . . . . . . . . : 30 January 2008 00:21:12
        Lease Expires . . . . . . . . . . : 19 February 2008 00:21:12



Things I have not yet tried:
1.) Formatting a Client, and joining the domain etc from scratch...I'll try this tomorrow.
0
ArkdogAuthor Commented:
Today I freshly formatted a client, with a complete fresh install of windows. I joined the domain...and the same ridiculous error occured when i tried to browse the network. I am getting extremely frustrated with this problem. I would assume that if a freshly formatted client, joining the domain has the same problem, then the issue must lie with the server and not with the clients.
0
ArkdogAuthor Commented:
Right ok, so we are getting some where.

It MUST have something to do with the WINS Server. I've noticed that there IS a WINS server installed. I do not think it is correctly configured. We have a multihomed server, and after disabling the WINS server and disabling the Netbios over TCP/IP in the WINS settings on one of the clients...it seemed to work.

Next step...setting up a wins server. If anyone knows of a nice step by step guide (for multi-homed servers)with pictures, i would appreciate it..with points of course.
0
ArkdogAuthor Commented:
this appears to be the solution:
http://support.microsoft.com/kb/242053/en-us

However I can't seem to locate this "mappings" option in the WINS configuration. Where is it? Is the WINS Console the same thing as the WINS Manager?

I also can't seem to locate this "Bindings Tab" in the network options?
0
ArkdogAuthor Commented:
i right click "Network" -> Properties -> Advanced -> Advanced Settings
But I see nothing there about the services (WINS, DNS etc) running on that NIC.
0
ArkdogAuthor Commented:
So through a journey of self-discovery, it appears the problem involved a multi-homed Windows Server 2003, running WINS incorrectly configured over 2 NIC's.

Whilst i could not invoke the microsoft solution (http://support.microsoft.com/kb/242053/en-us) as I could not seem to find the settings and menu options it was referrring to. I simply removed the WINS and other services, and used a single NIC.

I will be reposting a new new question regarding how to effectively setup up a very simple multi-homed server.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
cedarghostCommented:
Glad to see you found the cause.

0
TekServerCommented:
Sorry it took me so long to get back to you; I've been out in the field for most of the last couple of days.

Just FYI, the MS article you mentioned is for NT 4.  That's why you weren't able to follow its instructions; the controls are much different (as I'm sure you know) in 200x.

To get to WINS server controls on 200x, go to Computer Management (right-click My Computer -> Manage), expand "Services and Applications", expand WINS, then click on Active Registrations.  You won't see anything there at first, but if you right-click on "Active Registrations" and select "Find by Name", then enter an asterisk ("*") and click "Find Now", the screen will be populated with all the mappings (including an indication of which ones are static, if any).

I think your solution of removing WINS is probably the simplest.  You shouldn't need it, even on a multi-homed server, especially since all your workstations are XP and should use DNS.  (The reason, IMHO, that the workstations were not resolving names using DNS is probably that name resolution is done in a particular order, with NetBIOS, WINS, and the local HOSTS file all coming before DNS lookup.)

If you like, you can shoot me a message when you post your new question, and I'll see what I can do to help with that one as well.

:)
0
Computer101Commented:
Closed, 500 points refunded.
Computer101
EE Admin
0
ArkdogAuthor Commented:
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows Networking

From novice to tech pro — start learning today.