Trunk dropping packets

I have a trunk that is showing output drops more in one side than the other. What could be the cause?
Here is what I did but without much success:
1. Change the cable...now only one side was dropping packets.
2. Moved the trunk to a different port on both switches, still one side was dropping packets.
3. Disconnected the cable to only use one trunk because they were two trunks. Now the original side that was dropping more packets is dropping.
So the problem is not limited to one switch. Help!!!
4. I rebooted one switch but the problem still there.

One thing that will say is that the packets are being dropped on the forwarding port in the STP. I tried to only allowed some specific VLAN but without much success.

GigabitEthernet2/47 is up, line protocol is up (connected)
  Hardware is Gigabit Ethernet Port, address is 0012.007e.52fe (bia 0012.007e.52fe)
  MTU 1500 bytes, BW 100000 Kbit, DLY 10 usec,
     reliability 255/255, txload 49/255, rxload 41/255
  Encapsulation ARPA, loopback not set
  Keepalive set (10 sec)
  Full-duplex, 100Mb/s, link type is auto, media type is 10/100/1000-TX
  input flow-control is off, output flow-control is off
  ARP type: ARPA, ARP Timeout 04:00:00
  Last input 00:00:00, output never, output hang never
  Last clearing of "show interface" counters 00:37:07
  Input queue: 0/2000/0/0 (size/max/drops/flushes); Total output drops: 6479
  Queueing strategy: fifo
  Output queue: 0/40 (size/max)
  5 minute input rate 16409000 bits/sec, 5312 packets/sec
  5 minute output rate 19564000 bits/sec, 5475 packets/sec
     12451008 packets input, 4789408186 bytes, 0 no buffer
     Received 17949 broadcasts (16605 multicast)
     0 runts, 0 giants, 0 throttles
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
     0 input packets with dribble condition detected
     12727225 packets output, 5575461747 bytes, 0 underruns
     0 output errors, 0 collisions, 0 interface resets
     0 babbles, 0 late collision, 0 deferred
     0 lost carrier, 0 no carrier
     0 output buffer failures, 0 output buffers swapped out

tshi5791Asked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

stuknhawaiiCommented:
Check to make sure both sides are using the same trunking protocol (recommend 802.1q "dot1q") also make sure they're in the same VTP domain and that the core switch is a "VTP Server" and make sure they all have the same vlan's on them.
0
from_expCommented:
please provide show run int gi2/47 output
0
tshi5791Author Commented:
Both switches are configured as "VTP server" and have the same VLAN on both of them. The only thing I see is that VLAN1 on one has a different IP address on the other switch. But when I only allowed some VLAN across the trunk but remove VLAN1, I was still seeing drop packets.
Current configuration : 146 bytes
!
interface GigabitEthernet2/47
 switchport trunk encapsulation dot1q
 switchport mode trunk
 switchport nonegotiate
 speed 100
 duplex full

switchX
VTP Version                     : 2
Configuration Revision          : 1
Maximum VLANs supported locally : 1005
Number of existing VLANs        : 14
VTP Operating Mode              : Server
VTP Domain Name                 : baiwd
VTP Pruning Mode                : Enabled
VTP V2 Mode                     : Disabled
VTP Traps Generation            : Enabled
MD5 digest                      : 0xAC 0xB6 0xC6 0x84 0xB7 0x90 0x47 0x70
Configuration last modified by 216.203.17.138 at 11-12-07 00:04:38
Local updater ID is 10.10.10.1 on interface Vl1 (lowest numbered VLAN interface found)

switchY
VTP Version                     : 2
Configuration Revision          : 1
Maximum VLANs supported locally : 1005
Number of existing VLANs        : 14
VTP Operating Mode              : Server
VTP Domain Name                 : baiwd
VTP Pruning Mode                : Enabled
VTP V2 Mode                     : Disabled
VTP Traps Generation            : Enabled
MD5 digest                      : 0xAC 0xB6 0xC6 0x84 0xB7 0x90 0x47 0x70
Configuration last modified by 216.203.17.138 at 11-12-07 00:04:38
Local updater ID is 216.203.17.138 on interface Vl1 (lowest numbered VLAN interface found)




0
Introduction to R

R is considered the predominant language for data scientist and statisticians. Learn how to use R for your own data science projects.

stuknhawaiiCommented:
Can you provide a "show run" for the switchY port that switchX is connected to (the other side of the trunk)? Thanks.
0
tshi5791Author Commented:
switchx#sh run int g2/47
Building configuration...

Current configuration : 146 bytes
!
interface GigabitEthernet2/47
 switchport trunk encapsulation dot1q
 switchport mode trunk
 switchport nonegotiate
 speed 100
 duplex full
end

switchx#sh run int vlan1
Building configuration...

Current configuration : 60 bytes
!
interface Vlan1
 ip address 10.10.10.1 255.255.255.0
end


switchy#sh run int g2/47
Building configuration...

Current configuration : 146 bytes
!
interface GigabitEthernet2/47
 switchport trunk encapsulation dot1q
 switchport mode trunk
 switchport nonegotiate
 speed 100
 duplex full
end

switchy#sh run int vlan1
Building configuration...

Current configuration : 64 bytes
!
interface Vlan1
 ip address 216.203.17.138 255.255.255.0
end



0
from_expCommented:
btw, why do you have two gig ports running at 100mbps?
0
tshi5791Author Commented:
I wish I could answer that question but I just started here and don't have much of leverage to change things around. I did recommend changing the line speed to 1000 but that did not go far.
0
from_expCommented:
when do you see errors and packet loss? it is possible, that link is overloaded during busy business hours
0
tshi5791Author Commented:
This happens even on weekend when traffic is relative low
0
from_expCommented:
can try to set ports to autonegotiate speeds with
no switchport nonegotiate
no speed 100
no duplex full
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
tshi5791Author Commented:
I was unable to change the line speed on the trunk ports. The following scenario happened:
1. Set speed to 1000/full, the trunk interfaces showed in a down state.
2. Set the speed to auto, the trunk interfaces showded in a down state.
3. Set the speed back to 100/full. Back to square one (i.e. interface is up and packets drop).

p.s. Yes, I used no switchport nonegotiate
0
from_expCommented:
very strange.
can you describe your configuration: distance between switches, media types used, etc
0
tshi5791Author Commented:
It is very strange as you put it...The switches are in two separate cabinets. So there are directly connected with an Ethernet cable. However, I am not sure of the cable type used (i.e. cat 5, 5e, 6). The other problem is that the devices are located at a data center in another state. I am at lost of ideas.
0
from_expCommented:
it is possible, that cable is an issue, try to change it
0
tshi5791Author Commented:
I wonder if the x-over are CAT5, that might explain why the interfaces showed down.
0
from_expCommented:
possible
try to change the cable and report back, please
0
tshi5791Author Commented:
Well, changing the cable to CAT5e and setting the speed to 1000Mbps seemed to have fix the issue.
0
from_expCommented:
nice!
what was the pervious cable?
0
tshi5791Author Commented:
I only can assume that it was a CAT5 cable...the devices are actually located at a data center in another state. But, I thought the cable was CAT5 because when I first tried to set the speed to 1000Mbps, the switch port will go down. So changing it from CAT5 to CAT5e solved. Not easy to make change when you are new...takes time...
0
from_expCommented:
can understand you perfectly.
have we solved your problem?
0
tshi5791Author Commented:
yes...how do we share points since I was thining about changing the line speed to 1000Mbps but was looking for something else on the forum?
0
from_expCommented:
i think you should ask moderator to do that.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Switches / Hubs

From novice to tech pro — start learning today.