We help IT Professionals succeed at work.

(Local) Client drives not mapped when using web interface

p_reah
p_reah asked
on
I'm using Presentation Server 4 with roll-up 4 and all hotfixes issued since, on windows 2000 servers.

When users connect to published applications from Program Neighbourhood their local drives are mapped. (Usually "C$ on client" maps to T:)

If the same user connects to the same published application from the same machine via the web interface, their local drives aren't mapped.

How do I allow/force that?
Comment
Watch Question

CERTIFIED EXPERT

Commented:
Check for a Citrix Policy disabling or enabling the client drive mapping.
Policy may be filtered by i.e. IP address, so it can apply to clients going directly to your server and not apply to clients going through Web Interface/Secure gateway, depending on your config.
Also verify that you aren't starting the Java client.

Author

Commented:
Thanks for the ideas -  there are no policies active but I don't know whether it's the java client. It hadn't occurred to me to check.

I'll check in the morning when the users are back in the office.

Author

Commented:
I've confirmed they're not running the java client.

Any other ideas?
CERTIFIED EXPERT
Commented:
Please post the webica.ini file you should find under C:\windows on the client (may be empty).
If you have ICA Client 10.1 the file is located under C:\Document and Settings\<user name>\Application Data\ICAClient

I've found troubleshooting tips from Citrix: http://support.citrix.com/article/ctx238200

Author

Commented:
Thanks for the link!

That machine was showing disabledrives= A,B,C,D,E,F in modules.ini. Removing them appears to allow it to work.

Explore More ContentExplore courses, solutions, and other research materials related to this topic.