Routing Table / Network Troubleshooting (Vyatta router)

hi, i've set up a Vyatta router on a spare computer in my home office for testing purposes. I can't connect to the internet from inside the router and I can't figure out why as my setup seems to be fine. Can you go over my setup below (IP's and Routing Table) and let me know if you see any errors?

So,  here's my current setup:
Gateway (Buffalo): 192.168.11.99 (this connects to our DSL)
Vyatta Router: eth0=192.168.11.1, eth1=192.168.13.1 (this sits behind my Buffalo gateway router)

Internet --> Buffalo/Gateway --> Vyatta --> Clients in 192.168.13.0/24 network; can't see the internet or the 192.168.11.0/24 subnet. Clients behind the Buffalo gateway in the .11 subnet can see the internet fine.

Here's my routing table on the Vyatta:
Routes: 4/4, Paths: 4/4
0.0.0.0/0                [static(1)]        > to 192.168.11.99        via eth0
127.0.0.0/8                [connected(0)]        > to 127.0.0.1                via lo
192.168.11.0/24                [connected(0)]        > to 192.168.11.1        via eth0
192.168.13.0/24                [connected(0)]        > to 192.168.13.1        via eth1

What gives? Anyone have any suggestions why clients behind my Vyatta can't see anything outside the .13 subnet? thanks!
goldylamontAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

MoorelockCommented:
Looks like your .13 subnet needs to hit the .11 subnet to get to the gateway.  The routes show that your .13 is trying to bypass the eth0 interface.  So, next hop for .13 would be eth0 on the Vyatta, but you have it pointed to the Buffalo router interface, which it cannot see.

Make sense?

0
from_expCommented:
it is clear, that your buffalo is unaware about .13 subnet.
please point your buffalo, that 13th subnet is behind 11.1
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
goldylamontAuthor Commented:
thank you! so, how would i fix this? i thought the third line on the routing table...
192.168.11.0/24                [connected(0)]        > to 192.168.11.1        via eth0
...was saying to clients on .13 "if you need to connect to anything on .11 then use eht0=192.168.11.1"; but apparently not. what does this line do then?

should i update my static route to point to 192.168.11.1? would i add ANOTHER static route to do this? any help appreciated
0
Powerful Yet Easy-to-Use Network Monitoring

Identify excessive bandwidth utilization or unexpected application traffic with SolarWinds Bandwidth Analyzer Pack.

goldylamontAuthor Commented:
just saw the second comment from "from_exp", how would i make the buffalo "aware" of the .13 network? do i add a static route to the buffalo? if so what would the routing entry look like?
0
MoorelockCommented:
The line:

192.168.11.0/24                [connected(0)]        > to 192.168.11.1        via eth0

is stating that anything on the 192.168.11.0 network use 192.168.11.1

your static route of 0.0.0.0      192.168.11.99 is saying for any network, use 192.168.11.99.

You should probably have another statement in there that looks like this:

192.168.13.0/24           to          192.168.11.0/24                        via eth0
0
goldylamontAuthor Commented:
ok, i'll try this when i get home. is there anything i need to do on my gateway (buffalo) router?
0
MoorelockCommented:
From what you explained It sounds like eth0 is connected to Buffalo and eth1 (the .13 subnet) is connected elsewhere, so you can't really make the Buffalo router aware of the .13...

Short answer is no in my opinion.
0
goldylamontAuthor Commented:
so far, nothing has worked. Moorelock, i tried adding an extra static route between .11 and .13 as you suggested and this just stopped the router from working (needed to reboot and revert back to where i was). any ideas on why the router isn't working?
0
giltjrCommented:
Can the hosts in 192.168.11.0/24 ping 192.168.11.1?
What do your clients have as their default route?
What do they have as their route to 192.168.13.0/24?

Can the host in 192.168.13.0/24 ping 192.168.13.1?
What do the hosts in 192.168.13.0/24 have as their default route?
What do the hosts in 192.168.13.0/24 have as their route to 192.168.11.0/24

I would verify that the /proc/sys/net/ipv4/ip_forward as a value of 1 in it.
0
goldylamontAuthor Commented:
I/we fixed it!! The comment from "from_exp" was totally correct. This is what I did:

I added this static route to my Buffalo Gateway:
Destination      Subnet Mask             Gateway                Metric
192.168.13.0       255.255.255.0       192.168.11.1           1

so, I needed to tell the Buffalo router to send any traffic destined for .13 subnet to the Vyatta's eth0/11.1 interface. I'm surfing the net now on .13 subnet!

Also, "giltjr", it was your question "What do they [.11 clients] have as their route to 192.168.13.0/24?" that made me revisit what "from_exp" was trying to point out.

Moorelock, I appreciate your participation however the answers were incorrect

Thank you everybody!
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Routers

From novice to tech pro — start learning today.