Can't install Forefront Client Security

I have a clean install of W2K3R2 x86 and have installed WSUS 3 on top.
MMC 3.0 is installed, as is GPMC with SP1.
SQL Server 2005 Developer Edition is installed with all options including Reporting Services.
I'm attempting to install Forefront on this server from the CD, and am trying to put all server roles (management, collection server, collection database, reporting server/database, and distribution server) on this box.  When I go through the process, I specify the DAS account and leave everything pretty much at default.  During the verify settings and requirements phase, everything goes well except a warning about wanting 2 processors being recommended.  But when it gets to verifying URL's for reports, it throws an error:  Could not access this address:  http://servername/Reports and http://servername/ReportServer.  It says the remote server returned an error (500) Internal Server Error.
The Application log shows a warning:  ASP.NET error 1310, configuration error.
Any clues, pointers, hunches or suggestions would be greatly appreciated.  thanks, Bob
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.


did you download and install the ASP.NET framework? (from

BobHerringAuthor Commented:
When I go to Add/remove programs, it shows .Net Framework service pack 1 and service pack 2 installed.  In Add/remove Windows components, under Application Server, it shows ASP.Net installed.  Also under Windows components, it shows Microsoft .NET Framework 2.0 installed.  Let me check the URL you provided and see if there is more to download.  I thought the R2 edition of W2K3, plus every available update, would include every component I would need.  Thank you!
BobHerringAuthor Commented:
I went to and downloaded .NET 3.5, then re-booted the server, then tried reinstalling Forefront.  I get the same problem as before:  everything is fine except when it gets to verifying URL's for reporting, it throws an error:  Could not access this address:  http://servername/Reports and http://servername/ReportServer.  The application log shows an error:  first, a Windows Server Update as Source, Event ID 13042, "Self-update is not working".  Then, a Warning:  ASP.NET 2.0.50727.0, category Web Event, Event ID 1310, "A configuration error has occurred".

Should I uninstall/reinstall ASP.NET 2.0?  Thanks for your help.  Bob
The Ultimate Tool Kit for Technolgy Solution Provi

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy for valuable how-to assets including sample agreements, checklists, flowcharts, and more!

Hi Bob,

it does seem like there is something up with the install.  Try "aspnet_regiis.exe -i" from a cmd shell first, if that fails, then uninstall everything and then put it back in order:  IIS, ASP.NET, Forefront

Do you have installed under IIS?  Thats a biggie.

I had this same exact problem originally.  I removed everything, reinstalled SQL server and it was fine.  For whatever reason it did not create my reportserver webistes.

Do you see your report server websites listed under your IIS Setup?  Can you go to the url http://servername/reportserver?  If not, then the problem is with your IIS and SQL setup.  It also requires a few other SQL services besides just the reporting svcs.  If your websites dont work, I would start with a SQL reinstall.

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
BobHerringAuthor Commented:
this sounds like the ticket.
I will try it at the first opportunity.
Thank you for your time/attention.
There are two IIS sites related to Reportig Services. You must have .NET 2.0 installed and you must go into the properties of each of these sub sites and verify they are set to use the correct version of .NET on the .NET tab. I had the same issue and, in my case, the sites were set to use .NET 1.1. Changed them and applied and tried againa and everything worked.
shenson69, your suggestion worked for me.  One of my sites listed .NET  I changed the version as you suggested and everything was working within seconds.
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Microsoft IIS Web Server

From novice to tech pro — start learning today.