Help with setting up vlans

Currently we have one 6509 and 16 switches (3750's), 9 floors, 2 switches per floor except on the 3rd floor where the 6509 is located. The switches each have 1 IP with the secondary switch attached using the stackwise cable. Currently we run one vlan for all the switches on every floor, what i'd like to do is break that down to one vlan per floor so that the 1st floor is VID 100, second VID 200, etc. I'm finding bits and pieces of how this is done and i know a little bit, but i guess my confusion is in the changes/adjustments that may need to be made on the 6509.  I've read I may need to set a trunk but I'm looking for a good example of a config for that.  It sounds fairly easy but it's one of those things i need to research thoroughly before attempting as it's a live network and want to make sure it's as solid as possible before  giving it a go.  All ports on switch 1 will be in vlan 100, and I'm assuming the port on the 6509 where it connects needs to know that so that switch 2 on the second floor in vlan 200 can still see it and share data, etc.  I'm not as knowledgeable on this as I'd like to be and having no luck finding stuff on the sites I'm cruising&
LVL 19
darron_chapmanAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

MoorelockCommented:
If you've got the stackwise enabled on the 3750s the pairs should show as one switch stack.  What you'll need to do is configure the port connecting the 3750 stacks to the 6500s into trunk ports.  the config should look like this:

switchport trunk encapsulation dot1q
switchport mode trunk
speed xxx
duplex xxx

You need to do this on both sides, i.e. the port on the 3750 stack and the port on the 6500.  YOu can do this without affecting the current configuration as the links will still carry the current traffic with no problem.  Basically the trunk ports are able to carry multiple VLAN information.

Second thing to make sure is that you have IP routing on in the 6500.  I would configure the VLANs in the 6500 and create a VTP domain to add your 3750 switches into.  If you don't want to go this route, configure the VLAN IPs on the 6500 side so that it is the one doing the routing and you need not enable routing on the 3750s, but you still have to create the VLANs on both sides.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
darron_chapmanAuthor Commented:
cool, sounds doable without messing up the current config...  here's the current config
 
interface GigabitEthernet1/0/49
description ### Link to 300-6509-1:G5/1 ###
switchport access vlan 30
switchport mode access
 
And you say i'd just need to make the switch side say:
 
interface GigabitEthernet1/0/49
description ### Link to 300-6509-1:G5/1 ###
switchport trunk encapsulation dot1q
switchport mode trunk
 
(can't set duplex and speed on the gig links, static 1gb)
 
and then just put all of the other ports on the switch to switchport access vlan 100, right?  
 
Then on the 6509 side, which looks like this currently:
 
 
interface GigabitEthernet5/1
description ### Link to 100-3750-1:G1/0/49 ###
switchport
switchport access vlan 30
switchport mode access
no ip address

And would look like this afterward... ?
interface GigabitEthernet5/1
description ### Link to 100-3750-1:G1/0/49 ###
switchport trunk encapsulation dot1q
switchport access vlan 100
switchport mode trunk
ip address x.x.x.x

VTP mode is transparent on the 6509, so i'm guessing it should be server?  I'll read up more on vtp before pulling any triggers though, but sound like i'm on the right track?
0
MoorelockCommented:
Well, you're not going to have an IP address on the 6509 side interface and you will also have this interface as switchport mode trunk.  Like this:

interface GigabitEthernet5/1
description ### Link to 100-3750-1:G1/0/49 ###
switchport trunk encapsulation dot1q
switchport mode trunk


 The IP you're going to use is going to be assigned to the vlan interface, so in your example 100.  Should look like this on the 6509 side:

Interface VLAN 100
ip address x.x.x.x

Interface VLAN 200
ip address x.x.x.x

Remember that your VLAN interface is going to become the gateway for the clients in that VLAN so you'll probably want to use a .1 or .254, not sure how you guys run.

The 3750 looks good, and yes once you get everything set up you do the switchport access vlan 100 command on the interfaces that are non trunked.  I'd set up the VLANs and trunking and then do a test on one port before you move forward.

To answer your last question, yes, the 6509 will be the VTP server, however it will propogate ALL VLAN information to all of the client switches.  The VLANs won't carry information unless the switchports are members of the VLAN though so don't worry about that if that is the method you choose.
0
Determine the Perfect Price for Your IT Services

Do you wonder if your IT business is truly profitable or if you should raise your prices? Learn how to calculate your overhead burden with our free interactive tool and use it to determine the right price for your IT services. Download your free eBook now!

Feroz AhmedSenior Network EngineerCommented:
Hi,
You can do this if you configure it on switch which is present on 3rd floor by configuring switching ,as 3rd floor switch is 6509 series switch,configure VLAN on it in such a manner create a group and add them together and configure as one .
0
darron_chapmanAuthor Commented:
@sm_feroz: thank you for your response.  I am aware that it is possible, I'm more interested in the steps needed to make this happen.

@Moorelock:  Thank you for your detailed response.  I haven't had time to test out what you have sent me, but as soon as I do, I will let you know.
0
darron_chapmanAuthor Commented:
Thanks for your help.  I'm sure I'll have more questions later.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Switches / Hubs

From novice to tech pro — start learning today.