DCOM Server Process Launcher" stuck in 'starting' status

com+ issues
when accessing com+ from
      - control panel
      - admin tools
      - component services
      + computers
      + my computer
      + com+applications

i get the following error
********
title - Catalog Error
****
an error occured while processing the last operation.
error code 80040154 - class not registered
****
buttons - OK
********

from eventviewer i don't have any com+/dcom errors
in services i have "DCOM Server Process Launcher" stuck in 'starting' status

more things to note.
this may or may not be related to an existing question i have open
http://www.experts-exchange.com/OS/Microsoft_Operating_Systems/Q_23067911.html
Hardware is Dell optiplex755 2.33ghz, 2g Ram
i am running windows xp SP1 with a several updates and hotfixes.  (no i can't upgrade to SP2, I have 2500 Gateway machines working fine with the ~same configuration and we have custom application not yet upgraded to work with SP2)
company was bought out, we're moving to Dell's now
i have to deploy 250 identical machines with this configuration in the next few weeks.

LVL 19
William ElliottSr Tech GuruAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

snagsy1980Commented:
Have you tried
re-registering comadmin.dll (\windows\system32\com) ?
0
snagsy1980Commented:
0
William ElliottSr Tech GuruAuthor Commented:
registered comaddin.dll (assuming that is what you meant.)
deleted the com3 key from the registry (from the article)

now i am getting

Sub-component COM+ raised an exception while processing the OC_COMPLETE_INSTALLATION setup message.
d:\nt\com\com1x\src\complussetup\comsetup\ccompluscore.cpp (line 3406)
Error Code = 0x8007007f
Interface not registered
The COM+ event classes could not be registered.

...catsrv.dll

0
Cloud Class® Course: C++ 11 Fundamentals

This course will introduce you to C++ 11 and teach you about syntax fundamentals.

snagsy1980Commented:
Reinstall the COM+ service (using install windows components
Reinstall  IIS and use.The tool  aspnet_regiis.exe and it shoud be used with the parameter -i to get scriptmaps and metabase correctly installed.

0
William ElliottSr Tech GuruAuthor Commented:
i saw that article too.. :)

can't reinstall com+ because i'm getting the error i listed above when i try to do so.
i'm not using IIS on this box... and even when i try to install it i get the same
catsrv.dll doesn't like you message..
0
William ElliottSr Tech GuruAuthor Commented:
fixed it.. copied files from a working machine to this machine and registered them. thse resolved the issue.
net use y: \\myserver\myfix
del C:\WINDOWS\System32\clbcatq.dll
copy Y:\test\clbcatq.dll C:\WINDOWS\System32\clbcatq.dll
copy Y:\test\comsnap.dll C:\WINDOWS\System32\comsnap.dll
copy Y:\test\comuid.dll C:\WINDOWS\System32\comuid.dll
del C:\WINDOWS\System32\comsvcs.dll
copy Y:\test\comsvcs.dll C:\WINDOWS\System32\comsvcs.dll
copy Y:\test\catsrv.dll C:\WINDOWS\System32\catsrv.dll
copy Y:\test\catsrvut.dll C:\WINDOWS\System32\catsrvut.dll
copy Y:\test\clbcatex.dll C:\WINDOWS\System32\clbcatex.dll
copy Y:\test\catsrvps.dll C:\WINDOWS\System32\catsrvps.dll
copy Y:\test\stclient.dll C:\WINDOWS\System32\stclient.dll
copy Y:\test\comrepl.dll C:\WINDOWS\System32\comrepl.dll
copy Y:\test\comaddin.dll C:\WINDOWS\System32\comaddin.dll
del C:\WINDOWS\System32\colbact.dll
copy Y:\test\colbact.dll C:\WINDOWS\System32\colbact.dll
copy Y:\test\comadmin.dll C:\WINDOWS\System32\Com\comadmin.dll
copy Y:\test\mtxdm.dll C:\WINDOWS\System32\mtxdm.dll
copy Y:\test\mtxex.dll C:\WINDOWS\System32\mtxex.dll
copy Y:\test\mtxlegih.dll C:\WINDOWS\System32\mtxlegih.dll
copy Y:\test\dcomcnfg.exe C:\WINDOWS\System32\dcomcnfg.exe
copy Y:\test\comexp.msc C:\WINDOWS\System32\Com\comexp.msc
copy Y:\test\comrepl.exe C:\WINDOWS\System32\Com\comrepl.exe
copy Y:\test\comempty.dat C:\WINDOWS\System32\Com\comempty.dat
copy Y:\test\comrereg.exe C:\WINDOWS\System32\Com\comrereg.exe
copy Y:\test\migregdb.exe C:\WINDOWS\System32\Com\migregdb.exe
copy Y:\test\mtsadmin.tlb C:\WINDOWS\System32\Com\mtsadmin.tlb
regsvr32 /s C:\WINDOWS\System32\clbcatq.dll
regsvr32 /s C:\WINDOWS\System32\comsnap.dll
regsvr32 /s C:\WINDOWS\System32\comuid.dll
regsvr32 /s C:\WINDOWS\System32\comsvcs.dll
regsvr32 /s C:\WINDOWS\System32\catsrv.dll
regsvr32 /s C:\WINDOWS\System32\catsrvut.dll
regsvr32 /s C:\WINDOWS\System32\clbcatex.dll
regsvr32 /s C:\WINDOWS\System32\catsrvps.dll
regsvr32 /s C:\WINDOWS\System32\stclient.dll
regsvr32 /s C:\WINDOWS\System32\comrepl.dll
regsvr32 /s C:\WINDOWS\System32\comaddin.dll
regsvr32 /s C:\WINDOWS\System32\colbact.dll
regsvr32 /s C:\WINDOWS\System32\Com\comadmin.dll
regsvr32 /s C:\WINDOWS\System32\mtxdm.dll
regsvr32 /s C:\WINDOWS\System32\mtxex.dll
regsvr32 /s C:\WINDOWS\System32\mtxlegih.dll
regsvr32 /s C:\WINDOWS\System32\dcomcnfg.exe
regsvr32 /s C:\WINDOWS\System32\Com\comexp.msc
regsvr32 /s C:\WINDOWS\System32\Com\comrepl.exe
regsvr32 /s C:\WINDOWS\System32\Com\comempty.dat
regsvr32 /s C:\WINDOWS\System32\Com\comrereg.exe
regsvr32 /s C:\WINDOWS\System32\Com\migregdb.exe
regsvr32 /s C:\WINDOWS\System32\Com\mtsadmin.tlb

Open in new window

0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Microsoft Legacy OS

From novice to tech pro — start learning today.