SBS server and XP workstation time incorrect

The time shown by our XP workstations is about 15 minutes slow. The SBS server is also slow by the same amount. I changed the server time manually and the workstations updated to match but there is clearly something wrong with the time server.
What should I do to ensure that the server is obtaining the correct time from the internet?
Thanks.
ArkAdminAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

DrDave242Commented:
Go through the steps in the section of this article titled "Configuring the Windows Time service to use an external time source" and ensure the registry entries are correct:

http://support.microsoft.com/kb/816042

You may want to change the time server(s) when you get to step 4 if you're worried that the ones you're using now are not correct.  Note that you can specify multiple servers here, but they all must have ",0x1" at the ends of their names.
0
Jeffrey Kane - TechSoEasyPrincipal ConsultantCommented:
ArkAdmin,

To make is easy for you, just enter these commands on your SBS:

w32tm /config /manualpeerlist:"0.pool.ntp.org,0x8 1.pool.ntp.org,0x8 2.pool.ntp.org,0x8" /syncfromflags:MANUAL
w32tm /config /update
net stop w32time
net start w32time
w32tm /resync /nowait

Then you can either rerun "w32tm /resync" on all of your workstations, or you can add the following line to your SBS_LOGIN_SCRIPT.bat file and it'll sync each workstation automatically at the next login:

net time \\<servername> /set /y

(replacing <servername> with your actual server's name)


Jeff
TechSoEasy
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
ArkAdminAuthor Commented:
Ok, thanks Jeff, that seems to have fixed it. I already had the login script set up so that part works too.

Do you mind telling me why this requires a command line fix? It seems SBS should have a GUI solution or a GUI configuration. I'm also not really sure why this issue happens in the first place.

Thanks again.
0
Jeffrey Kane - TechSoEasyPrincipal ConsultantCommented:
What you're changing is in the registry.  You could use regedit, but the commands are much quicker since you have to stop and start the service.

The issue happens because time servers are different everywhere.  There is a default used (time.windows.com) but that's not nearly as reliable as these newer "pooled" servers.  

Jeff
TechSoEasy
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
SBS

From novice to tech pro — start learning today.