Remote Desktop not accepting incoming connections

When I first setup SBS 2003 and activated remote access, I had no trouble connecting to the server from home.

Now (two months later)  I continually 'time out' trying to access the server dekstop remotely with a notice stating '...the server might be too busy to accept incoming connections' even though I'm the only one logging in as I have yet to implement SBS in our company.

I can however VPN into and access the server desktop via an intenal IP address without issue. Whilst I'm happy to VPN into the server, this is only convenient on PC's that have been setup for the VPN, such as mine at home.

I haven't reallly been able to find any definitive symptons, I'd appreciate any direction as to some of the more common causes.

Kind Regards

Paul.
ShinglekingAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

TG TranIT guyCommented:
You need to open TCP 4125 on your firewall to SBS box
0
DrDave242Commented:
If you're using Remote Web Workplace, tgtran is correct; however, if you're simply establishing the RDP session directly to your server, TCP 3389 is the port you'll be using...by default, anyway.
0
ShinglekingAuthor Commented:
The port is open as are all other options and requirements in accordance with Microsoft's help file relating to remote access, OWA etc...

It worked two months ago when I initially set it up, but for some reason is not accepting them now.

Regards

Paul
0
Cloud Class® Course: MCSA MCSE Windows Server 2012

This course teaches how to install and configure Windows Server 2012 R2.  It is the first step on your path to becoming a Microsoft Certified Solutions Expert (MCSE).

DrDave242Commented:
Are you able to RDP into the server from inside your network, or do you get the same error?
0
hkunnanaCommented:
It seems that your server has a problem communicating with the outside world, please check your servers TCP/IP specially the gateway, also make sure the firewall doesn't forbid this kind of communcation.

Also, you said you had no trouble 2 month ago, a good practice is to check what have changed since your last successful login. (Starting with the network parameters, firewall settings, internet link parameters).
Last but not least ,if you feel everything is ok internally, a call to your ISP  asking them if they have applied some rules or filtering or changed any related configuration)
0
ShinglekingAuthor Commented:
Yes I can, here at the office no problems, asw mentioned, I can VPN into the server from home and access the desktop just not via RWW.

All other options for the main menu in RWW are functioning ie Outlook for web, Server usage and performance reports and even the help desk, intranet administration, just not logging onto the server desktop.

Regards,

Paul.
0
Jeffrey Kane - TechSoEasyPrincipal ConsultantCommented:
Shingleking,

More than likely the difference is due to installing Windows Server 2003 SP2 on your SBS.

Please see the "Comon Networking Problems after installing SP2" section of http://sbsurl.com/sp2 for a couple of patches you need to apply.  You need to also be sure your NIC drivers are the latest.

Finally, run the SBS Best Practices Analyzer to see about a couple of other things that could be causing this.  http://sbsurl.com/bpa


Jeff
TechSoEasy
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
ShinglekingAuthor Commented:
The only obvious change is that Sever has updated itself automatically.... Current release is SP2

Regards

Paul.
0
Jeffrey Kane - TechSoEasyPrincipal ConsultantCommented:
Shingleking,

So, please see the page I referred you to and apply the appropriate patches as instructed.

Jeff
TechSoEasy
0
TG TranIT guyCommented:
Shingleking,

Please open TCP 4125 on the firewall pointing to your SBS - I encountered the same problem and this was what I did to fix it.
0
Michael WorshamStaff Infrastructure ArchitectCommented:
Since SP2 has been applied, I would re-run the CEIEW and the RRAS wizards. Sometimes the SP2 causes quirks in the server connections.

Also make sure the needed SBS ports are opened on your firewall and pointed to your SBS server:
http://msmvps.com/blogs/bradley/archive/2005/01/21/33537.aspx
0
ShinglekingAuthor Commented:
Thanks for the info Jeff, yet again your assistance has helped me with another solution I was getting bogged down in. Not being an IT professional, it's easy to get inundated with superfluous technical 'stuff' that proliferates all things internet  :thumbs up:
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
SBS

From novice to tech pro — start learning today.