No logon prompt when connecting to Remote Desktop

I have a new SonicWall 2040 Pro firewall installed.

I want a user to be able to connect to the office from his laptop (VPN), and then use Remote Desktop to connect to his office computer.

So, I set up VPN on the SonicWall. Then I installed the latest version of the SonicWall Global VPN client on the remote computer (a laptop running Windows XP Pro SP2)

Using a wireless LAN connection, I am able to:
- Connect to the VPN
- Launch Remote Desktop
- Log into the office computer

However, on that SAME machine, using a Verizon WAN card (instead of the 802 card), I am able to:
- Connect to the VPN
- Launch Remote Desktop

The yellow bar appears at the top of the screen, indicating that I have successfully connected to the office computer using Remote Desktop.

However, the Windows Logon screen never appears.

If I use the laptop's 802.11 connection instead of the Verizon card, then everything works fine.
If I use the laptop's Verizon card, I don't get a Windows logon screen.

I do not have port 3389 open on my firewall because the user is using Remote Desktop AFTER he/she connects to the VPN.

Is the Verizon card too slow to work with a VPN?
(As a test, if I add a firewall rule that allows a user to connect across the Internet to his computer in the office WITHOUT using a VPN connection, Remote Desktop works fine)

Is there something wrong with the SonicWall firewall or VPN software? (SonicWall tech support says no)

I don't suspect anything is wrong with the office PC because if I come in over a wireless LAN connection, I can connect fine. If I try to come in over the Verizon card I never see the logon screen on the office computer.

LVL 10
ecarboneAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

TG TranIT guyCommented:
Nothing wrong with Sonicwall, the problem is bandwidth on the Verizon network
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
ecarboneAuthor Commented:
So this means it is NOT possible to log into a VPN and then connect to a computer via Remote Desktop using a Verizon wireless card?
0
TG TranIT guyCommented:
It appears so!
You may want to open TCP 3389 and test it without VPN
0
Cláudio RodriguesFounder and CEOCommented:
The issue is probably the MTU size. Kind of common issue when using WAN cards. You will need to tweak its size, probably at the TS side but you can try on the local PC with the WAN card.
http://support.microsoft.com/default.aspx?scid=kb;en-us;q314825

Claudio Rodrigues

Microsoft MVP
Windows Server - Terminal Services
0
ecarboneAuthor Commented:
well here's the deal (so far)

test 1: bypass vpn altogether. set up rule in firewall to map a specific public ip to computer "a" on my network. open port 3389. connect to internet with verizon card. works. done.

test 2: delete the rule from test 1. connect to vpn using sonicwall global vpn client. connects fine. launch remote desktop and attempt to connect to computer "a". yellow bar appears across top of screen. windows logon dialog box never appears. arghhhh.

test 3: disable the verizon card (rev 0) that is built into the lenovo laptop. install a new verizon pc card (this one is "rev a"). install driver. same results as test 2 (yellow bar but no logon dialog box appears)

test 4: follow instructions on microsoft's web site (Q314825) as noted above by "tsmvp" (thank you!). tweak registry. NOW i can connect to remote desktop through the vpn ... BUT ... it is VERRRRRRRYYYYY SLOWWWWWW.

test 5: install another wan card but only this time, it is a 3G card by at&t (not verizon). load driver. connect to vpn. launch remote desktop. connect to computer "a" immediately. done. problem solved.

apparently the verizon cards (even their faster "rev a") are too slow to connect.

the at&t card worked flawlessly first shot.

0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Microsoft Server OS

From novice to tech pro — start learning today.