Axis2 Error While consuming WebService on Eclipse

Hi,

I Create a Web Service Client with Eclipse/WTP/Axis2 wizard, and i generate the stub, but when I execute the WebService I obtain the following error:

org.apache.axis2.AxisFault: Error invoking service: Could not read XML stream.. Nested exception is javax.xml.stream.XMLStreamException: ParseError at [row,col]:[0,0]
Message: Unexpected event type 10
      at org.apache.axis2.util.Utils.getInboundFaultFromMessageContext(Utils.java:486)
      at org.apache.axis2.description.OutInAxisOperationClient.handleResponse(OutInAxisOperation.java:343)
      at org.apache.axis2.description.OutInAxisOperationClient.send(OutInAxisOperation.java:389)
      at org.apache.axis2.description.OutInAxisOperationClient.executeImpl(OutInAxisOperation.java:211)
      at org.apache.axis2.client.OperationClient.execute(OperationClient.java:163)
      at com.google.www.api.afa.BroadcasterServiceCcrV1Stub.getSpotDetailReport(BroadcasterServiceCcrV1Stub.java:1126)
      at com.google.www.api.afa.Test.main(Test.java:54)

Any idea?

Thanks

pzaprianovAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

ragerinoCommented:
i had similar expiriences with corrupted files that looked o.k. in the editor. try to copy the content in a text-editor (notepad). delete the file and create a new one. then paste back the content from the editor.

seems that ecllipse produces sometimes corrupt files.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
pzaprianovAuthor Commented:
I downgrade Axis2 version to 1.2 and it works, it seems to be an error with axis2 1.3.

Thanks
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Web Languages and Standards

From novice to tech pro — start learning today.