We help IT Professionals succeed at work.

Windows Firewall still alerts me despite being turned off

I'm running Windows Vista Home Premium on a laptop, and every now and then (eg. when I start an online game or even Skype) I get a Windows Firewall message, giving me the options to "Keep Blocking" or "Unblock".  Again, I say - it's not every time - just sometimes but enough to be annoying.

I have the Windows Firewall OFF as I operate behind a router so don't need it.  I don't have any other firewall software installed.

Does anyone know what is causing this behaviour?

Many thanks,
Steve
Comment
Watch Question

Everytime I've download a patch for Vista - well, almost every time, Microsoft think that my settings are not secure enough and reset them, especially when its a web update, and they especially like an enabled firewall and re-enabling my auto-updates....



Commented:
Even though Windows Firewall isn't a very good firewall I would still recommend that you use it with your router firewall since it does offer a little more protection. Regarding your firewall message I would have to agree with debuggerau since I have since this happen many many times on the computers that I have worked on in the past after getting Windows Updates. Do you have automatic updates turned on? If so I would recommend that you change it download them automatically and then notify you. I normally set all of the computers that I work on to this setting since I don't like the fact that you could receive a Windows Update that causes a system problem and then you really wouldn't know what caused it unless you think to check to see if there was a Windows Update.
CERTIFIED EXPERT
Distinguished Expert 2019

Commented:
Force it to stay off by setting the startup type of the service to disabled.
Top Expert 2007

Commented:
If you want to disable the alerts the Vista firewall keeps throwing out even when the firewall is off, go to the Windows Security Center (type in the Start Menu search box "security center" to find it) and click on the "Change the way Security Center alerts me" link.  Select the last option ("Don't notify me and don't display the icon" and you shouldn't see those alerts anymore.

A bit more info.
http://www.vista4beginners.com/Windows-Vista-Security-Center
CERTIFIED EXPERT
Distinguished Expert 2019

Commented:
Lee, Michko's answer deals with the alerts the security center initiates, that's something different.
CERTIFIED EXPERT
Distinguished Expert 2019

Commented:
"...I get a Windows Firewall message, giving me the options to "Keep Blocking" or "Unblock" " - That is the firewall, not the security center. The firewall is not shutdown although it says it is.
Michko's answer wiould only keep the sec. center from telling you "your firewall is turned off, you bad boy".

Commented:
I've encountered the same issue with the Windows firewall when I have disabled it and it keeps blocking programs, etc. I have not downloaded any updates from Microsoft. In fact, automatic updates are all the way OFF. This might be a Vista bug.

Explore More ContentExplore courses, solutions, and other research materials related to this topic.