[Webinar] Streamline your web hosting managementRegister Today

x
?
Solved

Quirky USB keyboard/mouse issue and disk boot failure

Posted on 2008-01-28
7
Medium Priority
?
424 Views
Last Modified: 2013-12-09
Hello. I built a computer a few months ago. It worked great for that time period. It is an Intel Core 2 Quad, with a P5N32-E SLI PLUS ASUS motherboard and 6 SATA hard drives. Four of the drives are 250 GIG, and are configured in a RAID 0+1 using the motherboards hardware RAID controller. I will get onto the other drive in a bit.

It was working great until I decided to format the thing and triple boot it with windows XP, Linux and Vista 64. So, I made two hardware changes. First, I added another IDE DVD Burner to the current IDE ribbon cable as a slave. Second, I installed (this is that other drive) a 500 GIG HD that is not part of the RAID.

So here is where things get sorta strange. I load the RAID drivers onto a floppy, grab a USB floppy drive and go though the Windows XP setup. Press F6 and all that jazz, load both drivers, press enter get to the screen where I can Press Enter To Install Windows, and BAM. No keyboard. At first I thought the screen was frozen. So I tried again. Same thing. So then I tried without loading the RAID drivers, and it follows though flawlessly  other then the fact it does not see my 500 GB RAID array. So I think that perhaps the RAID drivers are screwing with my USB keyboard. I plug in a PS2 one, restart the install, and it seems to work great now; no freezing, no nothing. Also, in the place where there is a GUI, my USB keyboard/mouse work fine  so I think Im out of the woods on that one&

Wrong. Windows boots up for the first time, lets me use my keyboard/mouse  I install my chipset, turn off my machine, unplug the PS2 keyboard and start it up again. No keyboard/mouse. It just refuses to work, period. So I then re-plug in the PS2 keyboard, install my keyboard drivers, tinker around in my device manager (keyboard only&), and think I have got it working again  after I unplug and plug in my keyboard/mouse combo. It works fine. Until I restart my machine and unplug the PS2 keyboard.

Basically  my USB mouse/keyboard ONLY work when I have a PS2 Keyboard attached.

Now the next issue, I think can be related& I install SP2 fine. Then I take out my installation CD from my DVD drive. I restart my computer. And it wont boot. It says the dreaded DISK BOOT FAILER PLEASE INSERT SYSTEM DISK& so I play around in BIOS for a while, double and triple check each boot related setting  even disable my DVD drive from being in the boot list at all& And yes, I made sure that my RAID array was set higher then my new hard drive& and still no go. If I simply put in my XP disk into the drive, let it do its press any key to boot off of cd and not press anything, then it boots fine. The funny thing is that it tries to boot off of the CD before it boots off my HD, even though thats not how BIOS is configured.

So, here are my two questions: how can I get my keyboard/mouse to work without having a PS2 keyboard plugged in, and how can I get my computer to boot without having the installation disk in&

The ONLY differences with this install and the one I did 3 months ago are: new 500 GIG HD, new DVD drive, and I only partitioned 150 GIG of the 500 GIG of my RAID array.

Perhaps learning what code is executed if you do not press any key to boot off CD will lead me into the right direction&

Thanks for your time
-Nelson
0
Comment
Question by:compumatter
  • 3
  • 2
6 Comments
 
LVL 93

Expert Comment

by:nobus
ID: 20766276
boot to recovery console :    http://support.microsoft.com/kb/314058
and run these :   fixboot      fixmbr      bootcfg         
test after each if it is booting from disk...
0
 
LVL 1

Author Comment

by:compumatter
ID: 20772284
Ok, thanks for the reply. I will be checking it out later today when I get home from work.

However, I would like to know _why_ this is happening? I did not have this issue when I did the first install. When I built the thing it worked without any issue - without any problems. So why an issue now?

Thanks for your help
0
 
LVL 93

Expert Comment

by:nobus
ID: 20775351
i cannot answer the WHY, in order to have the slightest chance, i would need to see what happened at every step
0
Get your problem seen by more experts

Be seen. Boost your question’s priority for more expert views and faster solutions

 
LVL 1

Author Comment

by:compumatter
ID: 20848604
Well its been a while, I forgot to post what happend untill now. Well, the problem was not fixed with those things that you posted. Then I noticed that my new 500 gig drive had a Windows directory on it! That was not right, so as a last resort I physically unplugged the HD, rebuilt the RAID array, and formatted 150 gigs of it with XP - and now it works fine.

The keyboard turned out to be network drivers. I just instead installed the old ones off of the CD, and now they work.

Thanks for your help though.
0
 
LVL 93

Expert Comment

by:nobus
ID: 20849299
no preblem, and close this question please
0
 
LVL 1

Accepted Solution

by:
Computer101 earned 0 total points
ID: 21077404
PAQed with points refunded (500)

Computer101
EE Admin
0

Featured Post

Get your problem seen by more experts

Be seen. Boost your question’s priority for more expert views and faster solutions

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

This article is an update and follow-up of my previous article:   Storage 101: common concepts in the IT enterprise storage This time, I expand on more frequently used storage concepts.
When we purchase storage, we typically are advertised storage of 500GB, 1TB, 2TB and so on. However, when you actually install it into your computer, your 500GB HDD will actually show up as 465GB. Why? It has to do with the way people and computers…
This video Micro Tutorial explains how to clone a hard drive using a commercial software product for Windows systems called Casper from Future Systems Solutions (FSS). Cloning makes an exact, complete copy of one hard disk drive (HDD) onto another d…
Two types of users will appreciate AOMEI Backupper Pro: 1 - Those with PCIe drives (and haven't found cloning software that works on them). 2 - Those who want a fast clone of their boot drive (no re-boots needed) and it can clone your drive wh…
Suggested Courses

591 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question