checking for xauth... no, configure: error: configuring with X but xauth not found - aborting

Hello Experts,

I am trying to install ssh (tried both ssh1 & ssh2) on Cobalt Linux release 6.0 and got the below error while running the. /configure.
checking for xauth... no
configure: error: configuring with X but xauth not found  aborting
xauth is not in /usr/X11R6/bin/ and couldnt find in other paths
I also tried. /configure without x, the configure completed without errors but got error when executed the make.
The purpose of installing ssh is coz our customer implemented the ssh and sent us public key asking to setup sftp on our ftp server. Understood that to have sftp - need ssh1 or ssh2 and if install ssh2 then sftp comes with it, correct me if I am wrong.

Appreciate your advice on this.

Thanks,
ssk77

ssk77Asked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Duncan RoeSoftware DeveloperCommented:
Make sure PATH in your environment includes /usr/X11R6/bin. Also make sure you can execute /usr/X11R6/bin/xauth
0
ssk77Author Commented:
Hi Duncan,

thanks for quick reply..
xauth is not in path /usr/X11R6/bin.  
anyway i have included /usr/X11R6/bin/  in env PATH but still same error.

[root ssh-2.0.13]# echo $PATH
/bin:/sbin:/usr/bin:/usr/sbin:/usr/local/bin:/usr/local/sbin:/usr/bin/X11:/sbin:/usr/sbin:/usr/local/bin:/usr/local/sbin:/usr/include/X11:/usr/lib/X11:/usr/X11R6/bin
additional info:
 i am trying to install ssh-2.0.13.tar.gz. Is this right ssh version for Cobalt Linux release 6.0 (Shinkansen-Decaf) Kernel 2.2.16C33_III on an i586. if not, from where can I dowload the correct version.

thanks,
ssk77



0
Duncan RoeSoftware DeveloperCommented:
Kernel 2.2 is *really old*. Still, building from source may still be OK. Odd about xauth - I thought it "just came" with X. Does your distribution media have it as a separate package?

You shouldn't really need xauth - or X - to build ssh: what was the actual error when you configured without X and tried to build? Please post the actual error and some lies each side of it.
0
The Ultimate Tool Kit for Technolgy Solution Provi

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy for valuable how-to assets including sample agreements, checklists, flowcharts, and more!

Duncan RoeSoftware DeveloperCommented:
Also try "locate xauth"
0
gheistCommented:
Cobalt Linux is Linux once distributed by SUN Microsystems:
http://en.wikipedia.org/wiki/Cobalt_Networks
Remains of support that once existed are here:
http://sunsolve.sun.com/show.do?target=cobalt/index&nav=patchpage

AMD K6 systems like yours do run customized RedHat Linux 9 and can build RedHat source RPM-s as per sun's documentation. It might be able to build Fedora Core SRPMS, on the other hand it may not.
It might be it has sshd installed just has to be started using chkconfig.

try running (as root):
which sshd
which rpmbuild
which rpm
which chkconfig
and post results.

After reading gory details of what happened to Cobalt manufacturing you may end up getting packages from http://BlueQuartz.org or ftp://ftp.cobalt.sun.com/.
Another way is to install some standard todays Linux distribution. Please post (as code attachment) what your dmesg and lspci outputs, so me or another experts can suggest some (small-memory) todays Linux or BSD system.

It looks like your distribution's documentation is slowly wanishing along with remains of support texts. Some releases contained sshd.

It has been at least five years, and let me suggest you get something newer (Sunfire or PC rack server)and then install this old box with NetBSD or OpenBSD time server (SUN has highly accurate motherboard clock chip) along with small staic webserver and/or ftp server. Or just leave this box as souvenir on your desk.

Some others are MIPS-based and .pkg extension suggest either SUN's package management or slackware similarity
0
ssk77Author Commented:
Sorry for a bit late reply&
I was busy with other Producion issues.
If dont mind, how excatly the sftp works.
Do I need to genarate the pub key and send it our partner.
I have placed pub key that we recieved from partner in  user's  home/.ssh2
how to test the connectivity using the sftp.
 
Hi Duncan,

I checked for xauther but I found xauther.h, I was not sure whether it is the one.
Anyway, I have add it in env PATH and re-run the configure. The result is the same- aborting.
So I tried without x ie ./configure without x and the configure completed. Also run make, to my surprise it didnt abort&no errors. So I executed make install  No errors.
I think ssh installed successfully. Then run the sshd daemon.
I am not sure what the implications are by executing --without x in future. Please advice.

Hi gheist,

Thanks for the detailed explanation and advices&
Can I know the procedure to start the ssh using the chkconfig

Below are the results:
which sshd
/usr/local/sbin/sshd
[root users]# which rpmbuild
/usr/bin/which:no rpmbuild in (/bin:/sbin:/usr/bin:/usr/sbin:/usr/local/bin:/usr/local/sbin:/usr/bin/X11:/sbin:/usr/sbin:/usr/local/bin:/usr/local/sbin)
[root users]# which rmp
/usr/bin/which: no rmp in (/bin:/sbin:/usr/bin:/usr/sbin:/usr/local/bin:/usr/local/sbin:/usr/bin/X11:/sbin:/usr/sbin:/usr/local/bin:/usr/local/sbin)

[root users]# which chkconfig
/sbin/chkconfig

Attached is the output of dmesg. Couldnt run the lscpi as it is not in the system.
ok, we will advice our customer to upgrade the server.

Thank you.




dmesg.txt
0
gheistCommented:
1) You have ssh server installed.
2) You mistyped rpm

I'd guess '/etc/init.d/sshd start' will do the thing.
chkconfig sshd on will make change permanent.

You have 20GB IDE HDD and 256MB of ram, so you can run about anything Linux or UNIX even today.
BUT it will be tricky to attach IDE CD-ROM to free IDE port on mainboard and you may end up installing over serial.

Linux kernel 2.6.x does support all of cobalt-specific hardware in your dmesg.
0
GnsCommented:
The only unanswered question would be "what is the implication of building it with out X support"..... The answer: You cannot use the ssh features pertainingf totunneling X traffic and setting X authority automagically. In your caase, it is no loss.

But to further drive home a point I think Andrew made too lightly.... The state of the system you have, with or without SSH, is such that it should under no circumstances be exposed to the internet.
It is a hazard to you as well as to all.... Think "hacker", "malware", "spammers"... Then go look at the multitude of unfixed bugs your system suffers from on any sercurity site (CERT, Secunia ....)...
Having the box as a curiosity on the shelf is perhaps best.

A _much better_ box is next to no money at all, and will run a modern fully patched *nix system (that will include all functions you need, including a fully functioning SSH) with no problem at all.

Just a piece of friendly advice:)

-- Glenn
0
ssk77Author Commented:
Hi Duncan , gheist, Glenn

Thanks for your help and valuable advices&. It helped me a lot in understanding ssh and also for setting it up.

Once again thanks guys&

Cheers,
Ssk77
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Unix OS

From novice to tech pro — start learning today.