Problem with Remote assistance

I am having trouble with a client I cannot connect to in response to a request for Remote Assistance.  I cannot connect in a request sent to the client, either.  It keeps saying that it cannot connect because the remote host name could not be resolved.  I have many successful Remote Assistance sessions with other clients.
I have asked a similar question and tried the advice which was to edt the IP address in the request file, but that makes no difference.  So, I'm looking for any advice on what the problem coule be, other than that.
Thanks in advance.
CRB1609Asked:
Who is Participating?

[Webinar] Streamline your web hosting managementRegister Today

x
 
AJermoConnect With a Mentor Commented:
it's in the KB301527
How to configure Windows Firewall for offer-based Remote Assistance
1. Log on to a domain controller or an administrative workstation as an administrator of the domain, and then open the Active Directory Users and Computers snap-in.
2. Right-click the OU in which the novice user's computer resides, and then click Properties.
3. On the Group Policy tab, click New, and then enter a name for the newly created GPO.

Or, you can skip this step and go to step 4. In this case, use the policy that you created in the "How to configure the Offer Remote Assistance policy setting" section.
4. On the Group Policy tab, select the GPO, and then click Edit.
5. In the navigation pane of the Group Policy Object Editor, expand Computer Configuration, expand Administrative Templates, expand System, expand Network, expand Network Connections, expand Windows Firewall, and then click Domain Profile.
6. In the details pane of the Group Policy Object Editor, click Enabled for the Windows Firewall: Define program exceptions policy.
7. Click Show to display the Show Contents dialog box.
8. Click Add to add the following exceptions:" %WINDIR%\SYSTEM32\Sessmgr.exe:*:Enabled:Remote Assistance
" %WINDIR%\PCHealth\HelpCtr\Binaries\Helpsvc.exe:*:Enabled:Offer Remote Assistance
" %WINDIR%\PCHealth\HelpCtr\Binaries\Helpctr.exe:*:Enabled:Remote Assistance  Windows Messenger and Voice
 
9. Click OK to close the Show Contents dialog box, and then click OK to close the Windows Firewall: Define program exceptions Properties dialog box.
10. In the details pane of the Group Policy Object Editor, click Enabled for the Windows Firewall: Define port exceptions policy.
11. Click Show to display the Show Contents dialog box.
12. Click Add to add the following exception:
"135:TCP:*:Enabled:Offer Remote Assistance"
13. Click OK to close the Show Contents dialog box, and then click OK to close the Windows Firewall: Define program exceptions Properties dialog box.
14. Close the Group Policy Object Editor.
0
 
AJermoCommented:
Depending on how you are getting the remote assistance connection the answer could change. The easiest way to troubleshoot this:
1. At the client, Ensure help and support service is running, as well as Terminal services.
2. In the properties of My computer, Ensure "Allow Remote Assistance invitations to be sent from this computer" and under Advanced, "Allow this computer to be controlled remotely".
3. Configure the windows firewall to allow remote desktop on port 3389 (if the firewall is turned on).
4. Test.

You can also offer remote assistance to the clients directly from your PC without them asking for assistance. The menu's are a bit deep, but basically: Start/Help and support/Use Tools to view your computer information and diagnose problems/(in the left pane labeled "Tools") Offer Remote Assistance.

Offer Remote assistance is viable in an enterprise environment and requires additional settings. This is most efficiently deployed with GPO unless the number of client machines is small.
Refer http://support.microsoft.com/kb/301527 for more information.

0
 
CRB1609Author Commented:
Thanks, AJermo.  One last thing.  The client Windows firewall is configured to allow remote desktop.  Do I have to do anything specific to make sure it is configured for port 3389 and if so, how?
0
 
CRB1609Author Commented:
Thanks, AJermo.  I think offer based assistance would be the way to go.
0
 
CRB1609Author Commented:
Thanks AJermo.  This is quite a lot to get my head around.  I'll try it over the next few days and probably need to post some follow up questions.
0
All Courses

From novice to tech pro — start learning today.