• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 7545
  • Last Modified:

IE 7 can't download Excel file, popup blocker turned off

OK guys, I'm at my wits' end.  I have several users who are using PeopleSoft who are having problems downloading Excel files created from queries.  When they click the link to download the Excel file, they see a quick blip which looks like the Javascript is opening another IE window (you never actually see anything IN the window), then it disappears.  You don't get the Open/Save file box.  Now, the weird thing is that they have no problems downloading files from other parts of the site, just the one they need (of course).

I don't think it's the PeopleCode causing the issue because the download works from some computers and not from others with the same user account.  The machines which aren't working do not have any extraneous toolbars (Yahoo, Google, etc.) which would block popups and I have turned the IE 7 popup blocker off completely.  The site is listed as a trusted site, Active X is set to enable all downloads, they have the same add-ons enabled, and I've even gone so far as to check EVERY Internet Option setting is the same as it is on the working computer.  I've checked that both machines are running the same version of IE 7 and have the same Java version running and still no solution.  

On a whim, I downloaded Firefox to see if that would give me any clues and found that if I had the popup blocker enabled and told it to allow popups from that site, it gave me the same error, but if I disabled the popup blocker and deleted the site from allowed popup sites, it would work.  Unfortunately, Firefox isn't an officially supported browser for our version of PeopleSoft so I can't just tell the users to install and use that instead.

Any ideas?
0
ambalish
Asked:
ambalish
1 Solution
 
TWBitCommented:
Can they right-click and choose Open in New Tab/Window or Save Target as?
0
 
ambalishAuthor Commented:
Nope, tried that too. :(
0
 
TWBitCommented:
How about right-clicking the page and choosing View Source.  That will get you the location of the file in an <href> tag. Compare it to known links to see if you can spot anything out of the ordinary.  You should also be able to copy and paste that link in your browser's address bar to directly access the file.
0
Never miss a deadline with monday.com

The revolutionary project management tool is here!   Plan visually with a single glance and make sure your projects get done.

 
ambalishAuthor Commented:
Ok, I found a solution!!

Apparently I missed one location.  Instead of having the site listed in Trusted Sites in the security tab of Internet Options, it had to be listed in Local intranet > Sites > Advanced.

Once it was in there, it worked fine.  I guess that makes sense, but wasn't immediately obvious.
0
 
crichCommented:
brilliant!

I needed exactly this myself!
0
 
AljosaHCommented:
Great! Saved my day too.
0

Featured Post

Never miss a deadline with monday.com

The revolutionary project management tool is here!   Plan visually with a single glance and make sure your projects get done.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now