Exchange OMA not loading properly.

We have MS Exchange 2003 installed in our office here and we are getting intermittent load errors. The error is as listed below.

Line: 1038
Char: 1
Error: Invalid procedure call or argument
Code: 0
URL: https://<our mail server>:8090/exchange/<username>/Inbox/?
         Cmd=contents

We have some port fowarding for our mail which is why it goes to port 8090. We have checked permissions, logged in with the domain before the user, checked hard disk space, checked the queue and still haven't been able to get it to go away. It happens intermittently and is getting us very frustrated. Can anyone help?
glowboyAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

LeeDerbyshireCommented:
That URL is an OWA URL, not OMA.  Can you confirm that your problem is with OWA, not OMA (which is the text-only mobile version of OWA)?  If you see that error displayed when you try to use OMA, then something is seriously wrong.  As a reminder, to get to OWA, you use http://server/exchange .  To get to OMA, you use http://server/oma .

Assuming that it is, in fact, OWA, then that looks like a client-side JavaScript error message.  Do you have an FE/EB setup?
0
glowboyAuthor Commented:
My mistake. It is OWA. We can get to it with no problems if we log into it while doign the server name, however if we go thru the web thats when we get the problems. FE/EB?
0
LeeDerbyshireCommented:
Sorry, it should be FE/BE, which stands for Front-End/Back-End.  Have you added a front-end server for your OWA access, or are you using a single Exchange server?
0
The Ultimate Tool Kit for Technolgy Solution Provi

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy for valuable how-to assets including sample agreements, checklists, flowcharts, and more!

glowboyAuthor Commented:
We are using a single Exchange server.
0
LeeDerbyshireCommented:
Okay, so it is not going to be a FE/BE hotfix mismatch (the usual cause of scripting errors like this).

When you are logged into OWA (and after you dismiss the displayed error), what Internet Zone does IE say your server is in when you look at the right-hand side of the status bar.  It will be Internet, Local Intranet, Trusted Sites, or Restricted Sites.
0
glowboyAuthor Commented:
I am not sure as every time i have checked it today it has not had the error. When i do check it says internet
0
LeeDerbyshireCommented:
Oh, so it is intermittent on the same computer?  I thought that some machines were affected all the time, and others were never affected.  The Internet Zone is probably not going to make much difference, then, but since it is your own server, I think it would be better placed in Local Intranet (even though it's not really local at the user end).
0
glowboyAuthor Commented:
It happens on different computers outside and inside our domain intermittently. How would I go about changing that? It is ssl encrypted. Is moving it over going to change the security aspect of it?
0
LeeDerbyshireCommented:
Moving it into a more trusted zone removes some of the scripting restrictions, although I don't think that is likely to help a problem that only appears intermittently.

Each OWA page loads several supporting .js (JavaScript) files from the server.  Some of the files are common to each page, and create client-side objects that are then referenced in other .js files loaded by the same page.  It's a possibility that if the client end fails to load the first .js file, then attempts by other .js files to create objects will fail, producing an error similar to what you are seeing.  The only way to test this would be to examine your IIS log file at a time when the error has just occurred.  Look for any file requests that do not return a 200 or a 302 status.  Note that the times in IIS log files are in GMT.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
glowboyAuthor Commented:
I checked the logs when it was happeneing and it was returning alot of 401 requests. Any ideas?
0
LeeDerbyshireCommented:
Do the requested file names have /exchweb/ at the beginning?  If so, then it suggests that your exchweb Virtual Directory no longer has Anonymous Access enabled on it.  Can you check that in IIS Manager?
0
glowboyAuthor Commented:
I checked it and it has anonymous access already in place. I did change the user that it uses to get that access to a administrative user on the domain. It seems to be working fine. I'll check the logs tommorow and let you know. Thanks for the help.
0
LeeDerbyshireCommented:
It sounds like there is a problem with your IUSR_servername account.  Maybe it is deleted, or locked out?
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Exchange

From novice to tech pro — start learning today.