Messages stuck in the " Messages with an Unreachable destination" queue

I have not defined any administrative policy. Starting from yesterday I was able to send mails to users under the same server, but not to any other users.
I can receive mails from Internet. and from users sitting on other servers on our LAN (one server in the US and Australia - My server is in Paris)
I have a queue " Messages with an Unreachable destination " where all mails are stuck.

Can you please help? I have already rebooted the server, check the settings and don't know where to look...

Any quick response is much appreciated.
Thanks.
bahpangAsked:
Who is Participating?
 
boochknCommented:
Fingers crossed!
0
 
boochknCommented:

From http://support.microsoft.com/kb/823489

Queue: Messages with an unreachable destination
First Available: Exchange 2000
Description: Messages in this queue cannot reach their final destination server. For example, Exchange cannot determine a route or a connector to the final destination, or all available routes or connectors are marked as down.
Troubleshooting: Messages can accumulate in this queue if no route exists for message delivery. Also, if an Exchange connector or a remote delivery queue is unavailable or if it is in a retry status for a while, and no alternative available route exists to the connector or the remote destination, new messages may be moved to this queue. The administrator can then address the problem or define an alternative route. Use the WinRoute tool to help determine available routes and route status. For additional information about the WinRoute tool, click the following article number to view the article in the Microsoft Knowledge Base:
281382 (http://support.microsoft.com/kb/281382/) How to use the WinRoute tool

To troubleshoot the queue that is causing this issue, restart the SMTP Virtual Server to reset the connector status and to retry the messages that are queued. To restart the SMTP virtual server, follow these steps:1. Click Start, point to Programs, point to Microsoft Exchange, and then click System Manager.
2. Expand the Servers container, expand your Exchange Server computer, expand Protocols, and then expand SMTP.
3. Right-click the SMTP virtual server, and then click Stop.
4. Right-click the SMTP virtual server again, and then click Start.
0
 
bahpangAuthor Commented:
I have downloaded the Winroute and it seems that my Front end server is the problem.
The error message I have now is that the
"BridgeHead Status: Local Virtual Server Not Started (VS_NOT_STARTED)"

I have checked the virtual SMTP and IIS etc and I have stopped and restarted them but still the same issue.

Any clue ?
Thanks.

0
Simplify Active Directory Administration

Administration of Active Directory does not have to be hard.  Too often what should be a simple task is made more difficult than it needs to be.The solution?  Hyena from SystemTools Software.  With ease-of-use as well as powerful importing and bulk updating capabilities.

 
boochknCommented:
Make sure you have the firewall and bridgehead configured according to:

http://technet.microsoft.com/en-us/library/aa996084.aspx
0
 
boochknCommented:
0
 
bahpangAuthor Commented:
All the steps named above from the links have already been configured ...
Any other clue?


0
 
boochknCommented:
From your backend server, open a command prompt and type in: telnet frontendservername 691

you should get a response saying 'routing server ready'  if it doesn't connect, recheck the firewall to the perimeter network.

Also do the same command only use 25 instead of 691...you should get a blank response to which you can type ehlo then hit enter and get a readable list of commands.
0
 
bahpangAuthor Commented:
port 691 does not work " could not open connection to the host"
port 25 works fine.
I will check the firewall tomorrow.
Thanks.
0
 
boochknCommented:
:)  Been there, unfortunately.
0
 
bahpangAuthor Commented:
Thanlks for your help. Appreciate it.
Will keep you updated. The firewall issue may take longer to resolve.
I was able to find a workaround solution. I managed to define a server to reroute the mails through US.
0
 
bahpangAuthor Commented:
Hi,
 I am back from my holidays. The temporary solution is still working.
I am checking the Firewall settings and will get back to you.
Thanks.
0
 
bahpangAuthor Commented:
I have checked the port 691 on the Firewall and it is open. Support told me that there are no drop packets.

Can you tell me how to open the port 691 on the Front End server? Is it a service?

I have done telnet on the Back End server on port 691 and it gave me the right answer....
0
 
boochknCommented:
So now the routing engine can talk to the front end. This should allow you to undo the workaround you did and see if the mail will flow through these servers.
0
 
bahpangAuthor Commented:
If I telnet the front end via port 691 from my front end server, I still have the following error: "could not open connection to the host"

From Backend server: telnet backend 691 -> 'routing server ready'  
From Backend server: telnet frontend 691 -> "could not open connection to the host"

From Frontend server: telnet backend 691 -> 'routing server ready'
From Frontend server: telnet frontend 691 -> "could not open connection to the host"

I'm trying to figure out how to open the 691 port on the Frontend server.
0
 
boochknCommented:
Are you using IPSec?  I see that you can initiate connections from a frontend to a backend, but it seems like none of your front end servers will accept the 691 connection.  I am actually not sure where to go from here as I am pretty knee deep in another project I am working.  I will have to look at it closer later.
0
 
boochknCommented:
Also, you should get the 'routing server ready' on the frontends by telneting on port 691 to 'localhost'
0
 
bahpangAuthor Commented:
Have tried everything, but still no success in telnetting on port 691 on the Frontend Server.
Cannot think on what else to do...
0
 
boochknCommented:
you don't have windows firewall enabled do you? if so , disable this.
0
 
bahpangAuthor Commented:
No Windows firewall enabled.
0
 
boochknCommented:
Ok let's start with the basics...we need to make sure the front end servers have good network connectivity...you say you couldn't do a telnet to 'localhost' on port 691 right?

Have you made sure you can telnet on port 25 between all servers (frontend=>frontend, frontend=>backend,backend=>frontend)?

Make sure you can ping between the servers as well.

Routing engine service is started on the frontend?

Sorry to be so basic.
0
 
bahpangAuthor Commented:
Well Tried all the basics now and I have now the port 691 replying on the FrontEnd. I have stopped and restart the services, checked the settings again (for the 'n'th time...)
I think restarting again the services after all these changes was the trick...  I have only rebooted the server once but it did not do the trick...

I have now removed the workaround solution, i.e, my backend server in the connectors. I will wait and see it things works ok and I'll let you know.

Thanks.
0
 
bahpangAuthor Commented:
Hi,
It is working fine now. I have let it run for the weekend and it seems to be ok.

Thank you very much for your help.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.