OWA Login fails when using SSL but not without?

I have a Windows Server 2003 with Exchange Server 2003 installed on it, and everything works well, including Outlook Web Access.  The problem is that OWA isn't using SSL, and I'd like it to do so.

Currently when you login to OWA over http://mail.mydomain.com everything works great.  When I change to using https://mail.mydomain.com I get to the login page without problems, but then it gives me an error:

You could not be logged on to Outlook Web Access. Make sure your domain\user name and password are correct, and then try again.

The URL for the error shows that the error is "reason=2" ( https://mail.mydomain.com/exchweb/bin/auth/owalogon.asp?url=https://mail.mydomain.com/exchange/&reason=2  )

I've searched the web to see if I can figure out where the problem is, but I can't find it.  I even get this error if I replace the domain name with the local IP address and browse it from the exchange server itself.

Any help would be appreciated, thanks!
LVL 2
mdegoodAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

boochknCommented:
Can you also clarify from where you are attempting to login? (from a domain workstation or from an outside)  I would have expected you to mention a login dialog box but you didn't so I am assuming you are testing from a domain workstation.  Also, when you access from the http:// address does it redirect to the https:// when you are in your mailbox?
0
mdegoodAuthor Commented:
Browsing the https:// works perfectly fine, I just can't login.  As far as where I'm trying to access it from, it doesn't matter.  The server itself, a domain workstation, or outside, they all see the standard OWA login page, and then get the wrong password error I quoted.  Normal operation (ie: what happens currently with http:// ) is to get the OWA login, then a domain login box, and then see your mailbox.

So the first reference isn't really the case, as the https is working fine, it's just that OWA isn't allowing a valid login when using https.

And as far as the normal http login, no, it does not redirect you to https after login.

Thanks for your help sofar... any other ideas though?
0
Creating Active Directory Users from a Text File

If your organization has a need to mass-create AD user accounts, watch this video to see how its done without the need for scripting or other unnecessary complexities.

boochknCommented:
Quick idea, install OWA admin and see if it can connect and configure your OWA?
0
boochknCommented:
Here's a step by step for you...


http://www.msexchange.org/tutorials/MF004.html

0
mdegoodAuthor Commented:
RE: Step by step:

Been there, done that, saw that exact tutorial.  That is exactly what I did to get my SSL certificate into my server, and that is why the https page itself loads.  My problem is that I can never login to my OWA when I try to access it via the https.  If that step were wrong then I would be getting certificate warnings before the https page even loads, but it's working fine.

I've gone through all the bases that I could think of, but it's not working... thus why I decided to post here...
0
boochknCommented:
Problem is that we can't deduce everything that's been done yet so it's often hard to nail down a complicated problem without re-addressing something that's been done :)  I feel your frustration though...
0
mdegoodAuthor Commented:
Yeah, I know there's no way you can know what i have or haven't tried... but as you said, it's frustrating because I've already checked these things.

Any other ideas?  Anyone?
0
mdegoodAuthor Commented:
The problem resolved around the integrated login.  Once that was disabled, everything worked fine.

I have no idea why, but I don't really want to know why, as long as it works right now!
0
Computer101Commented:
PAQed with points refunded (250)

Computer101
EE Admin
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Exchange

From novice to tech pro — start learning today.