[Webinar] Streamline your web hosting managementRegister Today

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1922
  • Last Modified:

Embedded WMV, how to start with a still image

My webpage has an embedded WMV file.
I have designed it so that it doesn't autostart.
This all is fine, except that....
At the moment it shows a blank white screen at the beginning. How do I change it so that it shows a photo of the speaker at the beginning (ie before the movie starts)?
0
corrin18
Asked:
corrin18
  • 2
  • 2
  • 2
1 Solution
 
fredshovelCommented:
Yo have to re-edit the video. You get an image or a still frame of the video and put it on the timeline for whatever duration time you want to show the still image.
0
 
corrin18Author Commented:
....but the movie wont be Auto-playing
Do you mean put the image in the very 1st Frame only?
0
 
fredshovelCommented:
Not really the first frame because the video might be running at something like 15fps or 29.9fps or whatever. You can put a still slide on any video timeline in an editor. Then you either stretch it by clicking and dragging the mouse or just specify the duration time in the duration box. The image will occupy more than one frame. For instance, if it was visible for 3 seconds in a video running at 15 frames per second it would occupy 45 frames.  
0
Never miss a deadline with monday.com

The revolutionary project management tool is here!   Plan visually with a single glance and make sure your projects get done.

 
corrin18Author Commented:
   <div id="video_29">

        <span style=" width:300px; height: 300px; position: relative; margin-left: auto; margin-right: auto; border: solid 3px #000; overflow: hidden;"><img src="PATH TO DEFAULT JPG" width="300" height="300" />

 


      <a style="position: absolute; left: 0px; top: 0px; display: block; width: 300px; height: 300px; background: url(/utility/images/playoverlay.gif) no-repeat center center;" href="PATH" onclick="document.getElementById('video_29').innerHTML='&lt;OBJECT ID=\&quot;MediaPlayer\&quot; width=\&quot;300\&quot;  height=\&quot;300\&quot; classid=\&quot;CLSID:22D6F312-B0F6-11D0-94AB-0080C74C7E95\&quot; codebase=\&quot;http://activex.microsoft.com/activex/controls/mplayer/en/nsmp2inf.cab#Version=6,0,02,902\"; standby=\&quot;Loading Microsoft Windows Media Player components... \&quot; type=\&quot;application/x-oleobject\&quot; &gt; &lt;PARAM NAME=\&quot;FileName\&quot; VALUE=\&quot;PATH\&quot;&gt; &lt;PARAM NAME=\&quot;animationatStart\&quot; VALUE=\&quot;true\&quot;&gt; &lt;PARAM NAME=\&quot;autoStart\&quot; VALUE=\&quot;True\&quot;&gt; &lt;PARAM NAME=\&quot;transparentatStart\&quot; VALUE=\&quot;false\&quot;&gt;  &lt;PARAM NAME=\&quot;ClickToPlay\&quot; VALUE=\&quot;1\&quot;&gt;   &lt;PARAM NAME=\&quot;showControls\&quot; VALUE=\&quot;true\&quot;&gt;    &lt;EMBED type=\&quot;application/x-mplayer2\&quot;        pluginspage = \&quot;http://www.microsoft.com/Windows/MediaPlayer/\";       SRC=\&quot;PATH\&quot;       name=\&quot;MediaPlayer1\&quot;       width=\&quot;300\&quot;       height=\&quot;300\&quot;       AutoStart=\&quot;True\&quot;&gt;   &lt;/EMBED&gt;  &lt;/OBJECT&gt; ';return false;"></a>


</div>
0
 
skylyCommented:
hi,
when I click on the image, player is displayed but a frame under the player is displayed as well. what might be the problem ? I'm using IE7
thanx
video.jpg
0
 
skylyCommented:
by the way, this is just overlaying an image onto the player.however, loading the player with a default image, like a large "play" button within the player would be more suitable because in your solution when the user clicks the image, he will see a blank player trying to load again.
0

Featured Post

The new generation of project management tools

With monday.com’s project management tool, you can see what everyone on your team is working in a single glance. Its intuitive dashboards are customizable, so you can create systems that work for you.

  • 2
  • 2
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now