BlackBerry devices can receive but not send after changing BES service account

BES working fine since installed several  months ago.  After server reboot yesterday, problem occurred "Failed to retrieve the Server DN".  Fixed this by setting up a new service account (BesAdmin2) with all the required permissions as per installation guide and running all BlackBerry services with the new account.  Devices now communicate ok, but they can only receive, not send.  Errors in app log from BlackBerry Messaging Agent:

Event ID: 20265
{user@domain.com} MAPIMailbox::Send(ppMAPIMessage) - SubmitMessage (0x80070005) failed
Event ID: 20472
{user@domain.com} Send() failed: ERR_SUBMIT_MAIL, Tag=6408

Error only occurs for 3 of the 4 users - one works fine.  Only difference is the user that still works was added to the BES after it was installed a few months ago - others were already set up on old server and were migrated across when it was decommissioned.

Have checked Send As permissions, assigned to BesAdmin2 correctly as per documentation.
Have tried adding Send As permissions individually to users for BesAdmin2, no change.
Have tried removing user, wiping handheld and adding again, same problem.

Server is running SBS2003 Standard R2 SP2, patched up to date.

Would appreciate any help, thanks.
LVL 2
David HaycoxAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Dave StringfellowIT managerCommented:
when you say you have checked send as permissions, is that in the AD advanced>user properties?

Check the mail stores indervidualy as well, as last time i had this problem it was due to the permissions not propergating fown to the seperate stores.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
David HaycoxAuthor Commented:
Yes, AD (with advanced features enabled) user properties.  BesAdmin2 does not appear in the list (not sure if it's supposed to) so I added it anyway.

Mail stores - both public and private are both showing inherited permissions for BesAdmin2 already - so I've just added them in at that level as well (Send As, Receive As and Administer Information Store).

Let's try that - no, no difference I'm afraid.
0
Dave StringfellowIT managerCommented:
aye, BESadmin2 should be included in the users "send as.." part of the AD,, thats what fixed it for me when i had this issue, i know someone else who had this problem too, and we had to take Blackberry off the server, and install the new version of the software
0
David HaycoxAuthor Commented:
Problem solved!

Despite adding the "Send As" permission manually on each user, this would seem to be not enough.  The permission must be inherited from the parent object, as suggested in the first reply to the question by Dave_AND.

Although I'd got the permissions right, some of the user accounts (the ones that were migrated across from the customer's old SBS2000) has inheritance disabled.  User accounts created on the SBS2003 had inheritance enabled.

Solution was to enabled enheritance on the user accounts.
0
chetw66Commented:
Worked for me too after I restarted the server.  By server I mean Exchange Server and BES server too because both are installed on the same box.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
BlackBerry

From novice to tech pro — start learning today.