Fedora Core 5 Installation Help

I have installed a fedora core 5 system on a new computer.  Everything seems to go just fine until reboot.  It reboots to the grub command line only.  Is there a way I can get gnome to load from the command line?  I have tried the rescue and that doesn't seem to do any good.  Is there Any way to fix this or just type in a command that will get the rest of it up and running?  I really don't mind typing it in if I can get it to go that way.  I am fairly new at this Linux stuff so please keep that in mind when responding.

Thanks for any help that you can give me.
rick123456789Asked:
Who is Participating?
 
tajrobbCommented:
This is essentially what PeturIngiEgilsson said, but to clarify:

1) With your installation disk, boot up and select option "repair"
2) It will ask several questions, like to mount your linux install and to start netwroking.  You don't need networking.
3) when you get to a command line, type

chroot /mnt/sysimage

4) reinstall GRUB

grub-install /dev/Xda

You might need to type /sbin/grub-install
Like PeturIngiEgilsson said, X=h or s
0
 
ravenplCommented:
I assume You boot into text mode (not grub), so You can log in as root.
Edit /etc/inttab
find line
id:3:initdefault:
change to
id:5:initdefault:
reboot
0
 
rick123456789Author Commented:
it shows

GRUB>

with the cursor flashing.  I tried typing the commands in and it gave me unrecognized command error.
0
Cloud Class® Course: Certified Penetration Testing

This CPTE Certified Penetration Testing Engineer course covers everything you need to know about becoming a Certified Penetration Testing Engineer. Career Path: Professional roles include Ethical Hackers, Security Consultants, System Administrators, and Chief Security Officers.

 
ravenplCommented:
So it is grub problem...
Looks like grub was mis-installed
Try repairing grub with http://www.g-loaded.eu/2006/01/02/grub-repair-plus-installation-to-floppy/
0
 
Pétur Ingi EgilssonSoftware Engineer -- ConsultantCommented:
If all fails reinstall.

Create a partitoin /boot ( 100 MB )
install GRUB on the first harddrive your compter finds (/dev/Xda , where x is usually either h or s )
0
 
rick123456789Author Commented:
Turns out I had a bad hard drive.  I had multiple hard drives in the computer and once I replaced the hard drive that was bad everything went ok.  I split the points as I do appreciate all the responses I got.  Thank you.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.