Offline Files with mapping network Drives

I've encountered a problem with offline files that I can not find a clear resolution to.  The user in question has a laptop which he takes home or on travel frequently.  The setup once worked on his system, but he has since gotten a new laptop and we had problems getting the setup to work.  He puts his My Documents on his network drive (maps automatically with a login script) and then points his my documents folder to there.  This works fine when the machine is hooked to the network.  The Offline Files feature also seems to be working fine because we can unplug the network line and he can still access files and they will syncronize and whatnot.  The problem is when he logs in and the computer is not attached to the domain.  The P drive will not map automatically.  When he tries to open his my documents, it throws up an error saying that the drive could not be reached.  Changing the login script is not really an option due to the vast amount of users it affects.  there has to be a simple solution to this, yet I've wasted too much time trying to find it.

Thanks in advance.
clark-jaAsked:
Who is Participating?
 
idahoharleydudeConnect With a Mentor Commented:
Are you telling it to show your P drive offline as well as My Documents?  Try with just making My Documents available offline.

How do you have My documents mapped?  

 P:\homedirectory  or \\serverABC\homedirectory

Try mapping My Documents to \\serverABC\homedirectory, then make My Documents available offline rather than making the P drive available offline.   If the system is trying to map P: during logon even when not connected to the network I think it will be an issue with offline files if you choose P: to be available offline.  
I have a number clients who use offline files when away from the corporate network.  Works great, but their P: drive  and other drives are mapped persistent (not each time they log on) so they all work great offline and syc like they are supposed to.

0
 
Robert Sutton JrSenior Network ManagerCommented:
You should sync your files before going offline therefore the files are accessible whether connected or not.
0
 
idahoharleydudeCommented:
If the drive mapping was "persistent" everything should work fine. So, I am assuming it is not persistent and part his Logon script looks something like this:

net use p: "\\serverABC\homedirectory\%username%" /persistent:no


If this is true you could work around by mapping an different drive to his network location and select "Reconnect at Logon" and then point his My Documents to the other drive.   Make the new drive available offline instead of the P drive


net use h: "\\serverABC\homedirectory\%username%" /persistent:yes

Basically he would now have two drives mapped to the same place, however the new one will will work when he logs on offline.

Note:  You will get errors on certain file types such as MDB and PST.  You are not able to syc these files.
0
Learn to develop an Android App

Want to increase your earning potential in 2018? Pad your resume with app building experience. Learn how with this hands-on course.

 
clark-jaAuthor Commented:
changing the login script isn't really an option, as it is complex enough as is.  this setup USED to work for this user on a previous machine.  also one of our guys has a machine that the setup works with fine.  So when he unplugs his network, logs in (none of his network drives will map), he can still open his my documents.  My system got the same error.  I ended up formatting my system, just to get rid of all previous offline files settings that might cause a conflict and got the same error again after I set it back up.  is this something simple i'm missing that I can avoid remapping the same drive manually?
0
 
clark-jaAuthor Commented:
mapping as \\server\homedirectory as opposed to the non persistent P drive resolved the issue.  Thanks alot.  I wasted alot of time on such a simple problem.
0
 
clark-jaAuthor Commented:
mapping the mydocuments as \\server\share as opposed to using the non-persistent P mapping resolved this issue.  Thanks folks!
0
All Courses

From novice to tech pro — start learning today.