Problem with ST6UNST

Has anyone tried to run the ST6UNST.exe file with their logs...kinda like


c:\windows\st6unst.exe -n "c:\program files\(program)\st6unst.log -f -q


I am having troubles with my pc's actually running this file like that from SCCM. It seems the files starts on the client but never does anything.


Any Ideas?
Who is Participating?
Questar_EPConnect With a Mentor Author Commented:
I was never able to get this working. I just built a script to delete the registry entries and files with out using it.
Are you trying to uninstall this?
St6unst -n "C:\Program Files\MyApp\St6unst.log" -f -q , for example is the uninstall command...

Questar_EPAuthor Commented:
Yes...exactly like that. I am entering that into the command line in SCCM and its starts on the client but doesnt actually do anything just hangs there waiting for input or something. I can't tell because it is hidden.
Free Tool: IP Lookup

Get more info about an IP address or domain name, such as organization, abuse contacts and geolocation.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

Can you run it without the -q option?
Then you might be able to see what it is doing...
Questar_EPAuthor Commented:
I tried changing the program and recreated the SCCM advertisement with
St6unst -n "C:\Program Files\MyApp\St6unst.log" -f
as you had suggested but that just gave me errors and would not even start on the client. I did read some place that the -f -q was required when running it on SMS/SCCM. But like I said when I run it the st6unst process starts but just sits there doing nothing. I did get some feedback from TechNet that said to check a file called execmgr.log to see if it give me any further information.
I'm having this exact problem too, anyone find a solution to this yet?  My command line is (in vbs)"C:\WINDOWS\st6unst.exe -n C:\MyApp\ST6UNST.000 -f -q"), 2, True

The ST6UNST.exe seems to start the process in Task Manager but fails to complete successfully yet if i run it manually on the machine, it runs successfully.  Is there an issue running this using SMS?
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.