• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1347
  • Last Modified:

Exchange virtual directory not working as it should

We have an existing Exchange 2003 environment, with an Front-End server and two back-end servers. We have introduced an Exchange 2007 server with the CA role, and another Exchange 2007 server with the Mailbox and Hub Transport roles.

We want all clients to access the CA for web access.  The /owa works OK for the 2007 mailboxes, but the 2007 mailbox users cannot login using the /exchange url.  I always get a "HTTP Error 403.4 - Forbidden: SSL is required to view this resource"
I am using SSL.

Also, the /exchange virtual directory is set for forms-based authentication, and the logon format is "user name only" as I have specified the domain name (we only have one domain), but I need to log in twice for the 2003 mailbox users.  If I specify DOMAIN\username, everything works OK.

The connectors and mailflow is otherwise working OK, just this web access problem.
0
jlee069
Asked:
jlee069
  • 4
  • 4
1 Solution
 
alshahnazCommented:
checkout this KB,

http://support.microsoft.com/kb/946957

Thanks,
Shan
0
 
jlee069Author Commented:
Thanks alshahnaz

I checked the kb, but this is when the mailbox is located on an Exchange 2003 server.  In my case, the mailbox is on the Exchange 2007 server.  I'm trying to use the CAS as my common front-end for both 2003 and 2007 mailboxes.

Access for 2003 mailboxes is fundamentally working, but not for the 2007 mailbox users.
0
 
alshahnazCommented:
is Integrated Windows authentication for /owa virtual directory selected ?. also enable Integrated Windows authentication for /Exchange virtual directory and try, it should work.

Thanks,
Shan
0
Free tool for managing users' photos in Office 365

Easily upload multiple users’ photos to Office 365. Manage them with an intuitive GUI and use handy built-in cropping and resizing options. Link photos with users based on Azure AD attributes. Free tool!

 
jlee069Author Commented:
Integrated Windows authentication is now selected for both exchange and owa virtual directories, still same problem.
0
 
alshahnazCommented:
i belive the reson why while u use /owa it works is because it is handled by the eprox.dl. whereahs when u use /exchange it handled by davex.dll . So when u use /exchange the davex.dll redirect exchange 2007 mailbox users to /owa diretry and that is where its failing.  
0
 
jlee069Author Commented:
I know davex is supposed to redirect to /owa,  I just don't know why it doesnt.
0
 
alshahnazCommented:
try deleteing the OWA directtory and recreate again

On your exchange server, open up the PowerShell command
2.) Type Get-OwaVirtualDirectory. This will list all of the virtual directories on any of the exchange servers currently in your domain.
3.) Type Remove-OwaVirtualDirectory -identity owa (Default Web Site). This will remove the OWA directory in about 10 to 30 seconds.
4.) Type New-OwaVirtualDirectory -OwaVersion Exchange20073 -Name owa (Default Web Site). This will create the Virtual Directory again.

Thanks,
Shan
0
 
jlee069Author Commented:
I finally figured out that I had to untick "Require secure channel (SSL)" on the 2007 mailbox server.  Thanks for your help on this anyway.  Justin
0
 
kevwitCommented:
If you have this issue please check handler mappings under IIS 7 and under the exchange/exadmin/exchweb applications. I found on one server that a bunch were missing basically because .Net 1.1 was uninstalled. Some of the older DAV technology and legacy stuff still uses .Net 1.1, so I've seen a few times where removing .Net 1.1 (even if you have a good security reason to do so) isn't a good idea.
0

Featured Post

Has Powershell sent you back into the Stone Age?

If managing Active Directory using Windows Powershell® is making you feel like you stepped back in time, you are not alone.  For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why.

  • 4
  • 4
Tackle projects and never again get stuck behind a technical roadblock.
Join Now