No video after ubuntu boot up on a Thnikpad T21

No video after ubuntu boot up on Thinkpad T21.  Problem seems to be intermitten.  It will boot up and run normal video after 7 or 8 or more boot ups.

When the problem occurs it goes through the normal Ubuntu splash screen and boot up sequence and then the screen goes blank.  It has a blinking cursor in the upper left hand corner - it stops blinking and then - nothing, just a blank screen with no response from keyboard or mouse.    .  

System will start normally in secure mode.  When I get the command prompt and I run "startx" I get a the same blank screen with blinking cursor and then nothing.

System is up and running, I just can't see anything on the screen.  Wifi card configures properly (I can see the card lights change when it configures).  

Boot up sequence is obviously looking for something to do with the video that does not always "connect"..

You can press "escape" on the thinkpad to bring up the Grub Menu.  Don't know if it means anything, but my  Grub Menu lists the kernal and then the Rescue Mode 3 times and then memory check.  Does not seem to make any difference which one you select to boot.

 Any help in resolving the "non start" issue would be greatly appreciated.






KenSpeedieAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Pétur Ingi EgilssonSoftware Engineer -- ConsultantCommented:
I had the same problem.

press ctrl+alt+f1 once the "black screen of nothing" comes, it will throw you into terminal 1.
then press any key couple of times.
In case you don't get thrown back to terminal 7 (graphical) you can press ctrl+alt+f7

Never found a solution.. gaveup on this and installed Debian.
0
KenSpeedieAuthor Commented:
Tried ctr+alt+f1 through f7. No luck

Something I failed to mention in the original post was the fact that during the installation of Ubuntu I got a fleeting message about a module not being loaded because it could damage an eprom.  Went by so fast that I cannot tell you exactly what it said.  All i know is that it refused to load a module (IBM module?).

0
ridCommented:
Could be a problem with Ubuntu not handling the graphics OK. Did the install use a fully functional GUI or did you use a text-only install procedure?

I'd be inclined to suggest you use the newest distribution of Ubuntu or KUbuntu.
/RID
0
Pétur Ingi EgilssonSoftware Engineer -- ConsultantCommented:
type "dmesg" in your console to see your boot log.
dmesg | grep modules   <- will filter out everything which says *modules*

if you find the module then add it to your, /etc/modprobe.d/blacklist , in order to force linux NOT to load it during boot
the format is :  blacklist moduleName
0
KenSpeedieAuthor Commented:
I found the solution on a ubuntu forum.

Add the following line to the "Device" section of /etc/X11/xorg.conf:

Option    "Bus Tyoe"  "PCI"

Thanks for your input.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Laptops Notebooks

From novice to tech pro — start learning today.